Raspberry Pi 4 mmap

More
23 Sep 2020 06:23 #183409 by Bari
Replied by Bari on topic Raspberry Pi 4
Update on latency with software rendering.

isolcpus=1,2,3, idle=poll has lower latency than isolcpus=3, idle=poll

Core clock speed on Rpi4 max is set at 1500 set by
arm_freq=1500 in the config.txt

force_turbo=1 goes into the config.txt file, not the cmdline.txt

Playing videos over FF or Chrome and latency for 50,000 base and 200K servo is <50,000 for both with software rendering. Video playback is a little choppy, also have 4 glxgears running at the same time.
The following user(s) said Thank You: partec

Please Log in or Create an account to join the conversation.

More
23 Sep 2020 13:53 #183469 by kramerda
Sorry --- if this question doesn't belong here
I have installed and have desktop working on RPi4 2.8 iso image - trying to get connected to working 7i76e Mesa card that was part of amd64 linuxcnc plasmac system.
Within new RPi4 Linuxcnc desktop, I select internet symbol (upper right desktop) then 'Wireless and Wired Settings'. Then 'Interface' either wlan0 or eth0. Playing around with adding ipv4 address of 10.10.10.10 followed by ping from terminal does nothing. Didn't see option for subset mask or default gateway like I did on amd64 install.
Do I have to configure a sim machine first - or directly to duplicating my plasmac configuration to modify anything in the new Hal or INI files?
Sorry if it sounds like I'm lost ....I am.
Dennis

Please Log in or Create an account to join the conversation.

More
23 Sep 2020 14:02 #183470 by PCW
You would not set the RPI4s IP address to 10.10.10.10,
(assuming the 7I76E is set for 10.10.10.10), you would
set the RPI4s address to an IP address in the same
class C address range (say 10.10.10.100).

If you do not have an option to set the subnet mask,
that suggests you have not selected "manual" or "fixed"
for the IP address option.

Please Log in or Create an account to join the conversation.

More
23 Sep 2020 15:51 #183485 by kramerda
on the RPi4 drop down for the 'Wireless and Wired Settings' there were no options for manual or fixed ....I should look somewhere else? Can attach screen shot?
Thanks

Please Log in or Create an account to join the conversation.

More
23 Sep 2020 22:54 #183527 by kramerda
After loading RPi4 iso image 2.8 then pnconf for configure etc. I get an error report (see attached) I don't understand. Pi can communicate to internet via wifi on wlan0 but i'm not sure over ethernet cable to 7i76e (working on earlier amd64 system). Here is snippet from .hal file showing setup for address on 7i76e which matches Pi setting for ipv4, board settings, and hal file.

loadrt [KINS]KINEMATICS
loadrt [EMCMOT]EMCMOT servo_period_nsec=[EMCMOT]SERVO_PERIOD num_joints=[KINS]JOINTS
loadrt hostmot2
loadrt hm2_eth board_ip="10.10.10.10" config=" num_encoders=1 num_pwmgens=0 num_stepgens=5 sserial_port_0=00xxxx"
setp hm2_7i76e.0.watchdog.timeout_ns 5000000
loadrt pid names=pid.x,pid.y,pid.z,pid.s

anything as next step appreciated
Attachments:

Please Log in or Create an account to join the conversation.

More
23 Sep 2020 23:38 #183532 by PCW
what does

ip a

report?

Please Log in or Create an account to join the conversation.

More
24 Sep 2020 01:03 #183538 by kramerda
WITH PI CONNECTED TO 7I76E CONNECTED VIA ETHERNET CABLE
pi@linuxcnc:~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether dc:a6:32:39:79:b6 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.108/24 brd 192.168.0.255 scope global deprecated noprefixroute eth0
valid_lft forever preferred_lft forever
inet6 fe80::5d25:309b:a7bb:4bd4/64 scope link
valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether dc:a6:32:39:79:b7 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.108/24 brd 192.168.0.255 scope global noprefixroute wlan0
valid_lft forever preferred_lft forever
inet6 fe80::582a:3a1c:a31e:506b/64 scope link
valid_lft forever preferred_lft forever

Please Log in or Create an account to join the conversation.

More
24 Sep 2020 02:23 - 26 Sep 2020 00:32 #183540 by PCW
Right so you have not setup a static IP address on the RPI
Suggested static IP address is 10.10.10.100

You might look at the hm2_eth page for how to do this by editing the interfaces file, or just google for "static IP address RPI"
Last edit: 26 Sep 2020 00:32 by PCW.

Please Log in or Create an account to join the conversation.

More
24 Sep 2020 02:27 #183541 by phillc54
www.raspberrypi.org/documentation/configuration/tcpip/

This is my dhcpcd.conf:
Warning: Spoiler!

Please Log in or Create an account to join the conversation.

More
24 Sep 2020 11:05 #183571 by kramerda
thankyou very much - we'll get right on it
Dennis

Please Log in or Create an account to join the conversation.

Time to create page: 0.147 seconds
Powered by Kunena Forum