Remora - ethernet NVEM / EC300 / EC500 cnc board

More
05 Jul 2023 04:02 #274803 by tuxcnc

converting an ST-Link is a pain.
 

Not true.
There is many versions of ST-Link clones with different processors and different schematics...
The more important problem of many projects is that the authors work very hard, but most important information hold in secret...
The conversion to DAPLink is a good example.
I don't know which "ST-Link" clone you used.
I have few in green plastic case, marked "www.betemcu.cn" with processor marked "Geehy APM32F103C8T6".
Will it work with your firmware?
What will be pinout of dongle socket?
Without these informations the conversion is not easy.

Please Log in or Create an account to join the conversation.

More
05 Jul 2023 06:20 - 05 Jul 2023 06:30 #274807 by zmrdko
Thanks for reply.I tried as you suggested. However, if I doubled the speeds I got following error on joint0. Even at 70mm/s. I was only able to increase the speed from 40 to 60mm/s.

Can you please check my configurations in attachment?
Attachments:
Last edit: 05 Jul 2023 06:30 by zmrdko.

Please Log in or Create an account to join the conversation.

More
05 Jul 2023 12:07 - 05 Jul 2023 12:10 #274824 by Murphy
For anyone wanting to install firmware to EC500 with RT1052 with one ST-Link I just ran the Linuxcnc live install from USB and got it to work first go with zero drama.

Only three commands run, factory settings ST-Link. FW version V2.J29.S7sudo apt install python-pipsudo python -m pip install -U pyocd(run this last command from folder with firmware file, make sure highlighted text matches your file name)sudo pyocd flash ./[color=

Attachments:
Last edit: 05 Jul 2023 12:10 by Murphy.

Please Log in or Create an account to join the conversation.

More
05 Jul 2023 12:47 #274827 by Murphy
Success , I got it working in Windows. Stupid user error. I never ticked the box to allow python to be run from the CMD line. 
Attachments:
The following user(s) said Thank You: meister

Please Log in or Create an account to join the conversation.

More
05 Jul 2023 13:33 - 05 Jul 2023 13:34 #274829 by zmrdko
Good to hear Murphy. Did you already try some jogging?
Last edit: 05 Jul 2023 13:34 by zmrdko.

Please Log in or Create an account to join the conversation.

More
05 Jul 2023 21:39 #274851 by Murphy

Good to hear Murphy. Did you already try some jogging?

not yet zmrdko maybe tomorrow

Please Log in or Create an account to join the conversation.

More
06 Jul 2023 15:36 - 06 Jul 2023 19:33 #274895 by Murphy
Could someone help me with this attribute error. I have flashed the board with the firmware. I can ping the board at 10.10.10.10. when I go and upload the config I get this error below. 

I installed tftp. But it's getting an error when I check the status of it
Attachments:
Last edit: 06 Jul 2023 19:33 by Murphy.

Please Log in or Create an account to join the conversation.

More
06 Jul 2023 21:56 #274912 by scotta

Could someone help me with this attribute error. I have flashed the board with the firmware. I can ping the board at 10.10.10.10. when I go and upload the config I get this error below. 

I installed tftp. But it's getting an error when I check the status of it

When you said you installed tftp, what did you do as you should not need a daemon running. You should only need to install TFTPy using pip.
pip install tftpy

Please Log in or Create an account to join the conversation.

More
07 Jul 2023 05:57 - 07 Jul 2023 06:41 #274929 by Murphy
Thanks Scott I'll try that. I used "sudo apt-get install tftpd-hpa" 

ok so i installed with pip tftpy.Still the same error when I try and upload the config 
Last edit: 07 Jul 2023 06:41 by Murphy.

Please Log in or Create an account to join the conversation.

More
07 Jul 2023 19:26 - 07 Jul 2023 19:29 #274950 by Murphy
Ok so I managed to get the config uploaded. when I run linuxcnc I get the following error. I moved the remora-nv.h and remora-nv.c to the Linuxcnc module directory. But still comes up with the same error
Attachments:
Last edit: 07 Jul 2023 19:29 by Murphy.

Please Log in or Create an account to join the conversation.

Time to create page: 0.442 seconds
Powered by Kunena Forum