AXIS and EMC2 Stops

More
10 Oct 2009 15:44 - 10 Oct 2009 15:45 #942 by ChrUgel
AXIS and EMC2 Stops was created by ChrUgel
Hi everybody!

I'm using EMC2 to control my little router and it really works well! I'm wery impressed by this program and would really like the give the developers i big thank you!
Well the reason why I'm here is:
There is this little, quite anoying thing that keeps happening now and then, Axis and EMC2 just quits and gives me an erormessage i do not understand.
I have saved it to file and I'm pasting parts of it her so someone might be able to point me in the right direction.

"
Debug file information:
/usr/bin/emc: line 637: 5020 Segmentation fault $EMCDISPLAY -ini "$INIFILE" $EMCDISPLAYARGS $EXTRA_ARGS
4895
PID TTY STAT TIME COMMAND
5019
PID TTY STAT TIME COMMAND
Stopping realtime threads
Unloading hal components
"
Thsi happen randomly from seconds after i start EMC2 to hours in the middle of an ongoing job . . . . quite annoying!
I'm running the latest Ubuntu 8.04 Live CD downloaded from here.
The computer is an Athlon 3000 with 3 gb ram and matrox g550 graphics.

best regards
Chris

File Attachment:

File Name: new_file.txt
File Size:22 KB
Attachments:
Last edit: 10 Oct 2009 15:45 by ChrUgel.

Please Log in or Create an account to join the conversation.

More
10 Oct 2009 22:35 - 10 Oct 2009 22:40 #948 by BigJohnT
Replied by BigJohnT on topic Re:AXIS and EMC2 Stops

[ 104.810966] 1032: ERROR: Unexpected realtime delay: check dmesg for details.
[ 104.810971] In recent history there were
[ 104.810973] 1994552, 1996056, 1994077, 1994011, and 1995212
[ 104.810975] elapsed clocks between calls to the motion controller.
[ 104.810978] This time, there were 3391773 which is so anomalously
[ 104.810980] large that it probably signifies a problem with your
[ 104.810981] realtime configuration. For the rest of this run of
[ 104.810982] EMC, this message will be suppressed.


I assume your getting a real time error and you answer it ok and never see it again. It' designed that way because if it popped up for every error it might never go away.

Run the latency test for an extended period of time to see if you need to change your latency numbers. Many computers do some strange things at intervals and if you don't run the latency test long enough you will never see them.

Before you run emc clear the dmesg and when you get the error check dmesg.

www.linuxcnc.org/docview/html//common_Linux_FAQ.html#r1_5_6

BTW, the file attachment was a big help.

John
Last edit: 10 Oct 2009 22:40 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
13 Oct 2009 18:46 #972 by ChrUgel
Replied by ChrUgel on topic Re:AXIS and EMC2 Stops
Thank you for yur response John!
I did run the latency test for an extende period of time and at first i had problems with the graphics so i bought a Matorx G550 and that helped i lot. Now after 15 mins testing peak value is 18000ns.
Except if i plug in at USB memory thing . . . 300.000 every time.
the dmesg i have not checked, i will dump tis nex time and paste it here.

regards
Chris

Please Log in or Create an account to join the conversation.

More
20 Oct 2009 03:30 #1002 by BMG
Replied by BMG on topic Re:AXIS and EMC2 Stops
I use a USB to swap files all th etime, but I ALWAYS take it out of the computer before running a file.

Please Log in or Create an account to join the conversation.

More
13 May 2010 01:09 #2849 by decker070
Replied by decker070 on topic Segmentation Fault
Hi all -

I know this thread is old, but I'm getting the same issue with the segmentation faults, after weeks of use with no problems! EMC will crash at a random time interval from program launch with the error log attached.

I'll try some of the suggestions shown here and let y'all know what happens.

Until then, has there been any more progress on this? any other suggestions come to light in the past few months?

File Attachment:

File Name: emc_failure_log.txt
File Size:24 KB
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.139 seconds
Powered by Kunena Forum