Ethercat HAL driver

More
12 Sep 2018 03:42 #117378 by sqmathlete
Replied by sqmathlete on topic Ethercat HAL driver
Hi all,

I am trying to hook up a Delta C2000 vfd via the ethercat hal driver but mapping via the generic driver doesn't seem map more than the control word 0x6040. I think this is because the limited number of available pdo's are already mapped and that pdo mapping is not available. Dumb question; does this mean that I need to build a module similar to the DeAsda module for the ASDA-A2 servo amps? and the beckhoff terminals?

Also, my servo's seem to come online inconsistently, sometimes one or the other will come online sometimes none, sometimes both with no discernible pattern. Any one else experience such oddities?

Kind regards
Dan
More
17 Sep 2018 20:30 #117670 by schlank
Replied by schlank on topic Ethercat HAL driver
Hi Experts,

I may can get some EtherCAT drives with CoE402 protocoll.
I think they are very similar to what roschi is using here in his video:



Unfortunately the XML Files etc. that is linked in the video is not online anymore.

Where can I find them? His homepage is also down.

Thanks,

schlank
More
18 Sep 2018 05:40 #117692 by Ilya
Replied by Ilya on topic Ethercat HAL driver
Hi, schlank
Have you seen this document?
docs.google.com/document/d/1GiB065ZIAaoM...GQl2X9DM9-THNM/edit#

For my servos, I downloaded the XML file on the manufacturer's website. All parameters are described there

Then, using the roschi document (STEP 9), I started grabbing the parameters from the factory XML file into the ethercat-conf.xml file
More
18 Sep 2018 20:33 #117729 by roschi
More
21 Sep 2018 13:21 #117846 by Ilya
Replied by Ilya on topic Ethercat HAL driver
Hello everyone,
I'm facing a problem and can't find a solution.

I use Delta servos.
The machine is switched off from time to time during operation, and an error AL3E1 or AL3E3 appears on the servos.
This error appears then at all, then several, then one servo.

Here is what is said about these errors in the instructions:

AL3E1 CANopen SYNC failed (Servo Off). The synchronous communication with the external controller has failed.
Q: ASDA A2-E servo drive servo drive shows AL3E1
A: Working under Operational state with
CANopen CSP/CSV/CST mode and losing two consecutive PDOs will lead to this alarm.
1. Check the reference clock whether with big time jitter
2. Fault reset with control word 0x6040.7 = 1

AL3E3 CANopen SYNC time out (Servo Off). The CANopen SYNC signal is not received within the specified time.
Q: ASDA A2-E servo drive shows AL3E3
A: Working under Operational state with
CANopen CSP/CSV/CST mode and losing two consecutive PDOs will lead to this alarm.
1. Make sure the host controller periodically and stably sends PDO.
2. Make sure grounding and wiring are both correct.

I checked the grounding and the wiring. But I don't know how to check and fix the rest.
Whether this is due to jitter from the latency test?

Thanks,
Ilya
Time to create page: 0.093 seconds
Powered by Kunena Forum