Ethercat HAL driver

More
09 Oct 2019 18:20 - 18 Oct 2019 19:02 #147583 by chimeno
Replied by chimeno on topic Ethercat HAL driver
Hello guys,
I have a question, I'm trying to install the linuxcnc-ethercat patch in version 2.8 or 2.9 but it doesn't work, only version 2.7 works for me, if anyone can help me.

I attach the patch file.

Thank you
Chimeno

In the end it works in version 2.9, we go with the first synchronism tests, there are quite a few changes since version 2.7, I will have to update.
Attachments:
Last edit: 18 Oct 2019 19:02 by chimeno. Reason: attach screenshot

Please Log in or Create an account to join the conversation.

More
16 Oct 2019 13:16 #147992 by fabsilva
Replied by fabsilva on topic Ethercat HAL driver
hi Cpk_Rbt, I'm also trying to configure linuxcnc .hal .xml .ini file for 6 akd kollmorgen. I can connect LinuxCNC with the driver but the motors doesn't move. can you kindly forwards the configuration files that u have used?

Please Log in or Create an account to join the conversation.

More
18 Oct 2019 19:11 #148217 by chimeno
Replied by chimeno on topic Ethercat HAL driver
Hi fabsilva,
I don't have those drivers but I can still help you, exactly what problem do you have?
Are they in OP mode?
Are the motors configured correctly with the driver?
you will have to use the generic version of linuxcnc-ethercat
if you want you can build your own controller, I leave you an example link
www.iram.fr/~blanchet/ethercat/akd/examples/

Regards
Chimeno

Please Log in or Create an account to join the conversation.

More
22 Oct 2019 08:59 - 22 Oct 2019 10:15 #148536 by fabsilva
Replied by fabsilva on topic Ethercat HAL driver
hi chimeno,
first of all thanks
second i'm using this configuration:
debian wheezy with linuxcnc 2.6-12
ethercat 1.5.2 and rtai3.4-9

I developed a working prototype with linuxcnc and a beckoff configuration for servo motor.
now I would like to build something more industrial. I have AKD drivers and AKM motors from kollmorgen.
starting from the configuration done on beckoff I generated the xml file for AKD, the .hal file and the .ini for linuxcnc.
Now, linuxcnc start correctly without error, but when i tried to move motors two are the things: o doesn't happend or i have a joint ferror.
I'm probably wrong linking pins and signals in some way.
Attachments:
Last edit: 22 Oct 2019 10:15 by fabsilva.

Please Log in or Create an account to join the conversation.

More
23 Oct 2019 18:33 #148614 by chimeno
Replied by chimeno on topic Ethercat HAL driver
Hi fabsilva,
I have never used that configuration with the DDT component and the targetvel signal, I will try to investigate a bit, if there is another forum partner that manages that signal can help you.
Regards
Chimeno

Please Log in or Create an account to join the conversation.

More
24 Oct 2019 08:26 #148680 by fabsilva
Replied by fabsilva on topic Ethercat HAL driver
thank you so much.
I'd like to move AKMs even without DDT components. I would like to move it controlling in velocity mode but I wouldn't know how to link pins and signals to the AKD driver. May be there are also some enable signal or opmode signal that i 'm not able to set correctly.
Regards
Fabsilva

Please Log in or Create an account to join the conversation.

More
26 Oct 2019 09:02 #148819 by chimeno
Replied by chimeno on topic Ethercat HAL driver
Hello fabsilva,
if you have it properly configured and the engine is running, placing this signal you have to roll,
setp lcec.0.0.poscommand 100
if it works then you would have to look at the PID component for speed control,
linuxcnc.org/docs/html/man/man9/pid.9.html

Please Log in or Create an account to join the conversation.

More
29 Oct 2019 07:50 - 29 Oct 2019 09:58 #149031 by JimPanski
Replied by JimPanski on topic Ethercat HAL driver
Hi,

can anyone say how to read error messages from the beckhoff EL modules? In my first real world setup for my lathe i now got one of the three EL5101 get sometimes out of function. when i check with ethercat slaves in the terminal i can see that this module goes safeop+error. its really frustration that i dont know what is going on. sadly this is the newest one of all 5101 of this setup, so i cant imagine this one is defective.
thank you for your help!

Regards
Conny

Edit:
usr@we80-cnc:~$ ethercat slaves
 0  0:0   OP            +  EK1100 EtherCAT-Koppler (2A E-Bus)
 1  0:1   OP            +  EL1004 4K. Dig. Eingang 24V, 3ms
 2  0:2   OP            +  EL1004 4K. Dig. Eingang 24V, 3ms
 3  0:3   OP            +  EL1004 4K. Dig. Eingang 24V, 3ms
 4  0:4   OP            +  EL1004 4K. Dig. Eingang 24V, 3ms
 5  0:5   OP            +  EL1004 4K. Dig. Eingang 24V, 3ms
 6  0:6   OP            +  EL1004 4K. Dig. Eingang 24V, 3ms
 7  0:7   OP            +  EL1004 4K. Dig. Eingang 24V, 3ms
 8  0:8   OP            +  EL1004 4K. Dig. Eingang 24V, 3ms
 9  0:9   OP            +  EL1004 4Ch. Dig. Input 24V, 3ms
10  0:10  OP            +  EL1004 4K. Dig. Eingang 24V, 3ms
11  0:11  OP            +  EL2008 8K. Dig. Ausgang 24V, 0.5A
12  0:12  OP            +  EL2008 8K. Dig. Ausgang 24V, 0.5A
13  0:13  OP            +  EL2024 4K. Dig. Ausgang 24V, 2A
14  0:14  OP            +  EL5101 1K. Inc. Encoder 5V
15  0:15  SAFEOP+ERROR  E  EL5101 1K. Encoder 5V
16  0:16  OP            +  EL5101 1K. Inc. Encoder 5V
17  0:17  OP            +  EL4034 4K. Ana. Ausgang +/-10V, 12bit
Last edit: 29 Oct 2019 09:58 by JimPanski.

Please Log in or Create an account to join the conversation.

More
29 Oct 2019 12:35 #149045 by sqmathlete
Replied by sqmathlete on topic Ethercat HAL driver
@ Conny,

I wouldn't make any assumptions. Run the terminals through twincat and see if you still get an error.

Kind regards,
Dan

Please Log in or Create an account to join the conversation.

More
29 Oct 2019 12:47 #149046 by JimPanski
Replied by JimPanski on topic Ethercat HAL driver
Hi Dan,

thank you for your reply. Is the only chance to read the error with getting a win pc here with twincat running or is there a chance to do this from my debian pc at the machine?

Please Log in or Create an account to join the conversation.

Time to create page: 0.128 seconds
Powered by Kunena Forum