updating to lcnc 2.8-dev

More
21 Apr 2019 16:23 #131406 by sir_wolf_art
So I have been rebuilding my linuxcnc with ubuntu budgie 18.04.2 LTS with kernel 4.18.16-rt9 #1 SMP PREEMPT RT.
It has not been easy doing this rebuilding, getting the OS with the kernel build seemed easy (if it really worked and is doing what is supposed to) but the install of linuxcnc has not been as easy. I have run into some issues with updating my .hal and .ini files and getting them to run on Lcnc 2.8-dev.
I have Lcnc built but not installed yet, I am just running it out of the scripts folder for now. Once I have everything running as it should with the hardware I hope to use. I want to move forward with the install.
Right now I have rebuilt my config files for 2.8 in hopes of making it easier to edit them down the road for newer hardware like Mesa boards or if I build other CNC machines.
However, the issue I have run into is this werd error that Lcnc is spitting out.
./axises.hal:13: Pin 'axis.0.motor-pos-cmd' does not exist
I can’t really find anything on the error and I know it worked in 2.7. Looking in the the “Updating LinuxCNC” doc for 2.8, I cant find if there was a changes to the hal wording. All of the changes in the .ini that where listed have been make.
I have included all the files with log of the term output.

File Attachment:

File Name: lcnc_2.8v_...mill.zip
File Size:10 KB

File Attachment:

File Name: log_print.txt
File Size:19 KB

File Attachment:

File Name: axises.hal
File Size:3 KB


PS: What's up with this “Note” Lcnc is outputting as well?
Note: Using POSIX realtime
Attachments:

Please Log in or Create an account to join the conversation.

More
21 Apr 2019 16:29 - 21 Apr 2019 16:30 #131407 by PCW
Replied by PCW on topic updating to lcnc 2.8-dev
Normally if you have been running 2.7, the first time you run 2.8, a script detects that you have a 2.7
configuration and fixes various hal and ini names and settings like the change from
"axis.N.motor.xxxx" to "joint.N.motor.xxxx"

Did this script not run on your 2.7 configuration?
Last edit: 21 Apr 2019 16:30 by PCW.

Please Log in or Create an account to join the conversation.

More
21 Apr 2019 16:49 - 21 Apr 2019 17:04 #131409 by sir_wolf_art
No it did not run. It ran on the old config files but it did not work not sure why, maybe because the old ones where a mess. So thats is why i rebuild the the config, using what the script changed and what was in the “Updating LinuxCNC” doc for 2.8. the script did not run this time after the making the new config. Is there a way to force the script to run on the new files?
I can post the old files that the script did run but there have the same issue but with “axis.5”.

File Attachment:

File Name: 5_axis_mill_VFD.zip
File Size:1,559 KB
Attachments:
Last edit: 21 Apr 2019 17:04 by sir_wolf_art.

Please Log in or Create an account to join the conversation.

More
21 Apr 2019 18:39 #131416 by rodw
Replied by rodw on topic updating to lcnc 2.8-dev
Why don't you just run up stepconf again and make a basic working config? Then cut and paste your settings from ini to the new format and add any personalised stuff in your hal file?

Please Log in or Create an account to join the conversation.

More
21 Apr 2019 18:45 #131417 by sir_wolf_art
i would run it but it is not listed.
wolf@5-Axis-linuxCNC:~/linuxcnc-dev/scripts$ ls
decode_dmesg                halreport          linuxcnc.in            pyvcp_demo          simulate_probe
get-deb-component-from-git  halrun             linuxcnc_info          realtime            swish
get-version-from-git        halrun.in          linuxcncmkdesktop      realtime.in         torture.py
githelper.sh                haltcl             linuxcncmkdesktop.in   rip-environment     travis-build-test.sh
gladevcp_demo               haltcl.in          linuxcnc_var           rip-environment.in  travis-install-build-deps.sh
halcmd_twopass              latency-histogram  linuxcnc_var.in        rtapi.conf          update_ini
halcmd_twopass.in           latency-plot       monitor-xhc-hb04       rtapi.conf.in       version-is-release
hal_demo                    latency-test       moveoff_gui            runtests            xhc-hb04-accels
hal-histogram               linuxcnc           platform-is-supported  sim_pin
wolf@5-Axis-linuxCNC:~/linuxcnc-dev/scripts$ 

Please Log in or Create an account to join the conversation.

More
22 Apr 2019 01:16 #131445 by KCJ
Replied by KCJ on topic updating to lcnc 2.8-dev
You can force the update script to run by changing the config version in the INI file.

For current master the INI version is 1.1 so will look like this:
[EMC]
VERSION = 1.1

Try removing the version option or changing it to a lower number.

Cheers!
Kurt

Please Log in or Create an account to join the conversation.

More
22 Apr 2019 03:32 #131451 by sir_wolf_art
ok i got the script to run but got new errors and not sure of what to make of this????
wolf@5-Axis-linuxCNC:~/linuxcnc-dev/scripts$  ./linuxcnc
LINUXCNC - 2.8.0~pre1
Machine configuration directory is '/home/wolf/linuxcnc-dev/configs/lcnc_2.8v_5_axis_mill'
Machine configuration file is '5_axis_mill.ini'
halfiles =  ['main.hal', 'pinout.hal', 'axises.hal', 'other.hal', 'HY_VFD.hal', 'custom_postgui.hal', 'touchy.hal']
halpaths =  ['/home/wolf/linuxcnc-dev/configs/lcnc_2.8v_5_axis_mill/main.hal', '/home/wolf/linuxcnc-dev/configs/lcnc_2.8v_5_axis_mill/pinout.hal', '/home/wolf/linuxcnc-dev/configs/lcnc_2.8v_5_axis_mill/axises.hal', '/home/wolf/linuxcnc-dev/configs/lcnc_2.8v_5_axis_mill/other.hal', '/home/wolf/linuxcnc-dev/configs/lcnc_2.8v_5_axis_mill/HY_VFD.hal', '/home/wolf/linuxcnc-dev/configs/lcnc_2.8v_5_axis_mill/custom_postgui.hal']

check_config: (trivkins kinematics) WARNING:
  Unspecified [JOINT_0]MAX_VELOCITY,     default used: 1.0
  Unspecified [JOINT_0]MAX_ACCELERATION, default used: 1.0
  Unspecified [JOINT_1]MAX_VELOCITY,     default used: 1.0
  Unspecified [JOINT_1]MAX_ACCELERATION, default used: 1.0
  Unspecified [JOINT_2]MAX_VELOCITY,     default used: 1.0
  Unspecified [JOINT_2]MAX_ACCELERATION, default used: 1.0
  Unspecified [JOINT_3]MAX_VELOCITY,     default used: 1.0
  Unspecified [JOINT_3]MAX_ACCELERATION, default used: 1.0
  Unspecified [JOINT_4]MAX_VELOCITY,     default used: 1.0
  Unspecified [JOINT_4]MAX_ACCELERATION, default used: 1.0
  Unspecified [JOINT_5]MAX_VELOCITY,     default used: 1.0
  Unspecified [JOINT_5]MAX_ACCELERATION, default used: 1.0
  Unspecified [AXIS_X]MAX_VELOCITY,     default used: 1.0
  Unspecified [AXIS_X]MAX_ACCELERATION, default used: 1.0
  Unspecified [AXIS_A]MAX_VELOCITY,     default used: 1.0
  Unspecified [AXIS_A]MAX_ACCELERATION, default used: 1.0
  Unspecified [AXIS_Y]MAX_VELOCITY,     default used: 1.0
  Unspecified [AXIS_Y]MAX_ACCELERATION, default used: 1.0
  Unspecified [AXIS_B]MAX_VELOCITY,     default used: 1.0
  Unspecified [AXIS_B]MAX_ACCELERATION, default used: 1.0
  Unspecified [AXIS_Z]MAX_VELOCITY,     default used: 1.0
  Unspecified [AXIS_Z]MAX_ACCELERATION, default used: 1.0


check_config: (trivkins kinematics) ERROR:
  [JOINT_0]MAX_LIMIT < [AXIS_X]MAX_LIMIT (400.0 < 400.0 400.0)
  [JOINT_3]MAX_LIMIT < [AXIS_A]MAX_LIMIT (9999.0 < 9999.0 9999.0)
  [JOINT_1]MAX_LIMIT < [AXIS_Y]MAX_LIMIT (300.0 < 300.0 300.0)
  [JOINT_4]MAX_LIMIT < [AXIS_B]MAX_LIMIT (9999.0 < 9999.0 9999.0)
  [JOINT_2]MAX_LIMIT < [AXIS_Z]MAX_LIMIT (50.001 < 50.001 50.001)

check_config validation failed
LinuxCNC terminated with an error.  You can find more information in the log:
    /home/wolf/linuxcnc_debug.txt
and
    /home/wolf/linuxcnc_print.txt
as well as in the output of the shell command 'dmesg' and in the terminal
wolf@5-Axis-linuxCNC:~/linuxcnc-dev/scripts$ 

Please Log in or Create an account to join the conversation.

More
22 Apr 2019 05:28 #131457 by rodw
Replied by rodw on topic updating to lcnc 2.8-dev
If you run Linuxcnc from the command line what is printed on the terminal window? There's usually an error there that pinpoints the fault. (Says he who just spent afew hours going around the twist trying to resolve similar errors on an new build!

Please Log in or Create an account to join the conversation.

More
22 Apr 2019 05:42 #131459 by sir_wolf_art
right now the now way to run lcnc is the terminal I have NOT installed lcnc JUST built it so all the errors are what has been print in the terminal.
i have not installed lcnc yet because i dont think my kernel is working right because mouse well stop random for a sec, plus i get this note each time i run something that is part of lcnc, but one issue at a time.
Note: Using POSIX realtime

Please Log in or Create an account to join the conversation.

More
22 Apr 2019 07:00 #131463 by pl7i92
Replied by pl7i92 on topic updating to lcnc 2.8-dev
only the main mashine HAL files are updatet its a mess on halui files postgui all has changed

Please Log in or Create an account to join the conversation.

Time to create page: 0.098 seconds
Powered by Kunena Forum