eccentric turning

More
27 Nov 2018 11:06 #121463 by andypugh
Replied by andypugh on topic eccentric turning
Even with a RIP the configs will live in ~/linuxcnc

I suggest copying the config from the config.old folder into a config_2.7 folder in the root of linucnc/configs if you want to retain both versions on the same machine.

It might help if you could take a photo of the screen after the crash (assuming that copy/paste isn't going to work)

Please Log in or Create an account to join the conversation.

More
27 Nov 2018 11:11 #121464 by Peter_Cassar
Replied by Peter_Cassar on topic eccentric turning
Thanks I'll do that , I want to preserve the original system config until I'm confident it will work. I'll try and get a photo of the screen tomorrow. At least 2.7 still runs when I reboot and restore the config folder.

Please Log in or Create an account to join the conversation.

More
27 Nov 2018 22:48 #121496 by Peter_Cassar
Replied by Peter_Cassar on topic eccentric turning
Andy, I didn't see my post in the forum but here it is again See the screen shot from my controller. Only the Mesa configs are crashing. I'm using the 7I43 400k board with spindle encoder input . The other sample configs seem to work.

Peter.
Attachments:

Please Log in or Create an account to join the conversation.

More
28 Nov 2018 00:12 #121501 by andypugh
Replied by andypugh on topic eccentric turning
How does the latency test do? This looks at first glance like an RTAI problem.

Please Log in or Create an account to join the conversation.

More
28 Nov 2018 02:23 #121509 by Peter_Cassar
Replied by Peter_Cassar on topic eccentric turning
Servo period max jitter just under 77,000 ns
Base period max jitter just under 46,000 ns

This is watching youtube and web browsing.

Please Log in or Create an account to join the conversation.

More
28 Nov 2018 10:35 #121521 by andypugh
Replied by andypugh on topic eccentric turning
The question was actually whether the test ran at all without crashing, so that seems like a yes.

The function that is crashing is inside RTAI, not LinuxCNC. (Google for handle_lxrt_request ) so this might be a hard problem to track down.
As far as I can ascertain LinuxCNC doesn't even call that function directly.

Please Log in or Create an account to join the conversation.

More
28 Nov 2018 10:58 #121523 by Peter_Cassar
Replied by Peter_Cassar on topic eccentric turning
Thanks for the tip. I wonder why it only crashes with the Mesa interfaces though .

Please Log in or Create an account to join the conversation.

More
28 Nov 2018 16:57 #121532 by andypugh
Replied by andypugh on topic eccentric turning
I don't know why it only affects Mesa, but it could be related to the hardware access.

Did you do the "sudo make setuid" stage of the build?

at the ./configure stage, did you specify a realtime library to be used?

Please Log in or Create an account to join the conversation.

More
28 Nov 2018 19:38 #121543 by Peter_Cassar
Replied by Peter_Cassar on topic eccentric turning
All sorted. I failed to configure it for RTAI. I rebuilt and it now runs properly with my Mesa Hardware. Now to test the external offets and eccentric turning!

Thanks for your help.

Please Log in or Create an account to join the conversation.

More
29 Nov 2018 01:32 #121571 by Peter_Cassar
Replied by Peter_Cassar on topic eccentric turning
I've been setting up my system following the opa_demo. I'm not exactly sure how to integrate everything in with my current lathe config but I have the PYVC panel up and the C axis / Joint 2 configured but I get a Joint 2 following error when I run the opa_demo . The lathe x axis moves to into position and then the following error occurs. I'm not at all sure how the C axis is supposed to work, Perhaps the's a HAL pin issue.

Please Log in or Create an account to join the conversation.

Moderators: piasdom
Time to create page: 0.102 seconds
Powered by Kunena Forum