Beckhoff ethercat 64 with bit linuxcnc, How to install.

More
10 Oct 2020 21:13 #185632 by Mike duran
Thanks Grotius for your explanation, as I was telling you, I'm new to installing LinuxCNC with ethercat and I didn't know where it was going, so if this installation step can I skip it? :

# Install linuxcnc as rip git clone github.com/grotius-cnc/linuxcnc.git
cd linuxcnc / debian /
./configure uspace cd ..
cd src ./autogen.sh ./configure --with-realtime = uspace
Make # -j2
sudo make setuid

Since there is an executable LinuxCNC in the .iso without the need to use console scripts to start LinuxCNC and I copy the 2 lcec files into the linuxcnc folder that comes already when installing the .iso in their respective addresses.

Please Log in or Create an account to join the conversation.

More
10 Oct 2020 22:15 #185650 by Grotius
Hi Mike,

You can skip that step indeed.
Be sure the lcec.so goes into the rtlib of linuxcnc. The lcec_conf could be placed where your ini file is.
In the hal file, where you referere to the lcec_conf file, you could use a full path name.

Good luck !

Please Log in or Create an account to join the conversation.

More
12 Oct 2020 21:27 #185882 by Nico2017
Hi Grotius,
thanks for the update for installing linuxcnc and ethercat on Buster.
Did you manage to make glade and its library working on this OS? To me I manage to do like you: ethercat + linuxcnc but still struggling with the linuxcnc library for glade installation and I believe this is related to the python version.
Cheers,
Nicolas

Please Log in or Create an account to join the conversation.

More
12 Oct 2020 22:05 #185888 by Mike duran
hi grotius, in the script this part fails me:

3. Install linuxcnc-ethercat
$ cd linuxcnc-ethercat / => make

it shows me the following error:

configure.mk.8: *** halcompile / comp executable not found or set.

Do you know what is it?

Please Log in or Create an account to join the conversation.

More
13 Oct 2020 07:29 - 13 Oct 2020 08:17 #185931 by Grotius
@ Nico,

Ahaa... i did not know that.

To install glade on buster :

File Attachment:

File Name: setup2_2020-10-13.txt
File Size:0 KB

Usage : $ sudo ./setup2.txt

It has a txt extension, but that doesn't affect a bash script at all :laugh:

Good luck !!

@ Mike,

The linuxcnc-ethercat is the easyest to install.

For example, you can execute this script :

File Attachment:

File Name: setup1.txt
File Size:0 KB

usage $ ./setup1.txt
Attachments:
Last edit: 13 Oct 2020 08:17 by Grotius.

Please Log in or Create an account to join the conversation.

More
01 Dec 2020 12:08 - 01 Dec 2020 13:00 #190749 by TheRoslyak
A very dumb question
How I can to send command to el2004 from terminal?
Ethercat download -p (0/1) -t bool 0x7000 1 1 isn't work?

Upd. I do this by "halcmd lcec.0.D2.dout-0 1" But how to send it by simple terminal?
Attachments:
Last edit: 01 Dec 2020 13:00 by TheRoslyak.

Please Log in or Create an account to join the conversation.

More
02 Dec 2020 16:53 - 02 Dec 2020 16:54 #190881 by Grotius
Hi,

This post has a attachment txt file with example command's. It point's to the documentation for the command's.
forum.linuxcnc.org/24-hal-components/223...ver?start=990#189977

file
Last edit: 02 Dec 2020 16:54 by Grotius.

Please Log in or Create an account to join the conversation.

More
02 Dec 2020 20:42 - 02 Dec 2020 20:44 #190903 by chimeno
Hello @TheRoslyak

It is trying to send an SDO configuration value to a PDO, I think it is not possible, but it can send a pulse to the register that will be reflected in the output an instant.
ethercat reg_write -p4 --type int8 0xf00 0x01
0xf00
registry value
0x01
value


Greeting
Chimeno
Attachments:
Last edit: 02 Dec 2020 20:44 by chimeno.

Please Log in or Create an account to join the conversation.

More
19 Feb 2021 18:58 #199468 by V-max
Hi all,
I'm new here, in Linux CNC and some brick-brain, but I think that I can memorize this thread completely.
I have got an AX5203 (hardware 1) servo Beckhoff and I would like to integrate it in linuxcnc.
I would like to congratulate the major contributors to this thread. Grotius, Nicolas, Chimeno......
I've been having a lot of trouble installing due to several issues, the last one that I cant solve is the headers for 4.19.0-9 or 4.19.0-11 kernels, I'm am not able to find them in any repository, in Debian webpage they are no longer available. Finally, I've installed the updated one, I mean 4.19.0.14-rt-amd64, linux-image and kernel.
First question: Did I do well?, Do you know where to find the headers for 4.19.0.09?

Following with the installatiƶn I've been able to have the EtherCAT Master installed, running and I can detect the slave (AX5203) , but I'm blocking with the attached linuxcnc file report.

"Debug file information:
Note: Using POSIX realtime
note: MAXV max: 5.000 units/sec 300.000 units/min
note: LJOG max: 5.000 units/sec 300.000 units/min
note: LJOG default: 0.250 units/sec 15.000 units/min
note: jog_order='XYZ'
note: jog_invert=set([])
lcec_conf: ERROR: invalid arguments
postgui.hal:2: waitpid failed /home/avc/linuxcnc-ethercat/src/lcec_conf lcec_conf
postgui.hal:2: /home/avc/linuxcnc-ethercat/src/lcec_conf exited without becoming ready
2768
2814
Stopping realtime threads
Unloading hal components
Note: Using POSIX realtime
"
Any clue, documentation, recommendation, etc..... will be welcomed.

@Chimeno , Is the ax5203 config file correct,? Any clue or documentation recommended?
Attachments:
The following user(s) said Thank You: chimeno, Nico2017

Please Log in or Create an account to join the conversation.

More
19 Feb 2021 19:27 - 19 Feb 2021 19:34 #199469 by db1981
Hi,

your command for calling lcec_conf is wrong it should be like this:

loadusr -W /home/avc/linuxcnc-ethercat/src/lcec_conf /home/avc/linuxcnc/configs/sim.axis/ethercat-conf.xml

but i'm not sure at the moment if you can do this in an postgui.hal

Then in your ethercat_conf.xml your slave_idx should be "0" , because its the first device after the master .


From where did you get the initcmd's ? Format is correct. But the drive would stay in error. No Motors and encoders configured. Also for the DC-Bus there is linking enabled. (if it's only one drive, this couldn't be....) Saftycard enabled ....
Last edit: 19 Feb 2021 19:34 by db1981.

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.158 seconds
Powered by Kunena Forum