Beckhoff ethercat 64 with bit linuxcnc, How to install.

More
19 Jul 2020 19:15 #175186 by chimeno
Hi @bkt
sorry, I guess I misread your problem.

Greeting
Chimeno
The following user(s) said Thank You: bkt

Please Log in or Create an account to join the conversation.

More
21 Jul 2020 14:29 #175337 by bkt
@chimeno ... no worry for the work you have done on ethercat theme here on the forum you can allow yourself many other mistakes without anyone having anything to complain about :)

Any how only chance is try to install Lcnc 2.8 ..... but we need to use joint/axis trick (angular or world coordinates on ngc file) provided by dgarret .... on 2.9 works ok on real machine ....

about halcopile not find .... I've not a solution now.

regards
bkt
The following user(s) said Thank You: chimeno

Please Log in or Create an account to join the conversation.

More
21 Jul 2020 15:03 #175339 by bkt
now I have an other questions ..... If install more than one Lcnc-dev versions on home folder ..... linuxcnc-ethercat-master can see the right one?? How??

reagards
bkt

Please Log in or Create an account to join the conversation.

More
23 Jul 2020 07:04 #175469 by bkt
I try to understand snitter code and where is call halcopile comp, but not see the call .... i think is only a problem of wrong path on 2.9 lcnc rt-preempt versions ... so I try to find the problem and fix it .....

Please Log in or Create an account to join the conversation.

More
23 Jul 2020 12:31 - 23 Jul 2020 12:36 #175536 by bkt
Now for sure there are a problem. I try with these installation:
  1. Remove previous Lcnc istallation
    apt-get purge linuxcnc-doc-en linuxcnc-uspace-dev linuxcnc-uspace
  2. Setup LinuxCNC 2.8 (download zip file from github selecting 2.8 version)
    cd linuxcnc (renamed from linuxcnc2.8 into linuxcnc after extraction)/debian
    ./configure uspace
    cd ..
    cd src
    make
    ./autogen.sh
    ./configure --with-realtime=uspace
    make -j4
    sudo make setuid
  3. Setup "ec-debianize"
    git clone https://github.com/sittner/ec-debianize ec-debianize
    cd /ec-debianize
    ./get_source.sh
    cd etherlabmaster
    dpkg-buildpackage (the output error "failed to sign .dsc file" is no issue)
    sudo dpkg -i /git/ec-debianize/etherlabmaster_1.5.2+20190904hg33b922p8ea394-1_amd64.deb (in my case)
    sudo dpkg -i /git/ec-debianize/etherlabmaster-dev_1.5.2+20190904hgp8ea394-1_amd64.deb (in my case)
    gedit /etc/default/ethercat (change mac-address [MASTER0_DEVICE=""] e.g. [MASTER0_DEVICE="15:27:33:48:55:66"])
    gedit /etc/default/ethercat (change [DEVICE_MODULES=""] to [DEVICE_MODULES="generic"])
    sudo update-ethercat-config
    usermod -a -G ethercat demo (my user)
    reboot
  4. Setup "LinuxCNC-Ethercat"
    git clone http://github.com/sittner/linuxcnc-ethercat.git linuxcnc-ethercat"
    gedit /git/linuxcnc-ethercat/src/lcec_main.c (add here [#include "rtapi_mutex.h"] below [#include "rtapi_app.h"])
    cd /linuxcnc-ethercat
    make -j4  ----> error
  5. demo@demo:~/linuxcnc-ethercat$ make
    configure.mk:8: *** halcompile/comp executable not found or set.  Stop.
    Makefile:17: recipe for target 'config.mk' failed
    make: *** [config.mk] Error 2

so nothing change from 2.9 Lcnc versions .... same problem ... where do I check to solve?
regards
bkt
Last edit: 23 Jul 2020 12:36 by bkt.

Please Log in or Create an account to join the conversation.

More
26 Jul 2020 20:54 - 26 Jul 2020 20:54 #175969 by Grotius
If you have some time left,

Soon i will do a new Ethercat installation to trigger your problem. Will let you know what can be your problem.
Last edit: 26 Jul 2020 20:54 by Grotius.

Please Log in or Create an account to join the conversation.

More
27 Jul 2020 07:53 #176014 by bkt
Ok thanks ... today i try to install the iso you have posted on first page of these thread .... in these way I hope I can start .... after these we can verify, with some your help, the differences between installation on debian 9 and ubuntu18.04/mint19 (that is the same SO with different WM and less bloatware on mint side, more or less .... but normally I start from minimal installation on ubuntu .... ).

Thanks for your help test ..... to date I have not seen what happened .... but I think it's just a problem of folder paths or rt-preemt patch version. If I knew the way linuxcnc-ethercat builds the paths and what it expects to find in the various folders, I probably would have already solved ... but this takes time which I don't know where to go.

regards
bkt

Please Log in or Create an account to join the conversation.

More
27 Jul 2020 08:43 #176025 by Tady
Hey guys.

Can anyone tell me if someone installed this on a PI?

I am trying to build this package but after running
sudo dpkg -i etherlabmaster_1.5.2+20190904hg33b922p8ea394-1_armhf.deb

i get ....
DKMS: install completed.
Building initial module for 4.19.118-v7l+
Error! Bad return status for module build on kernel: 4.19.118-v7l+ (armv7l)
Consult /var/lib/dkms/etherlabmaster/1.5.2+20190904hg33b922p8ea394/build/make.log for more information.
dpkg: error processing package etherlabmaster (--install):
 installed etherlabmaster package post-installation script subprocess returned error exit status 10
Processing triggers for libc-bin (2.28-10+rpi1) ...
Errors were encountered while processing:
 etherlabmaster

Any ideas? probably the kernel is not supported?
Linux raspberrypi 4.19.127-rt55-v7l+ #1 SMP PREEMPT RT Mon Jul 13 09:30:06 CEST 2020 armv7l GNU/Linux

Please Log in or Create an account to join the conversation.

More
27 Jul 2020 09:54 #176037 by Tady
Huh i just noticed that kernel versions do not match

Please Log in or Create an account to join the conversation.

More
27 Jul 2020 10:09 #176039 by bkt
and where did you find the news? I'm using the 4.18 kernel on mint .... and I'm having problems ...

regards
bkt

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.122 seconds
Powered by Kunena Forum