computer / linuxcnc unable to detect mesanet 6i24 board

More
18 Apr 2020 20:36 #164509 by PCW
Does the 6I24 configure itself at power up? (both red lights out)

Please Log in or Create an account to join the conversation.

More
18 Apr 2020 20:42 #164511 by owhite
no LEDs go on during the boot up sequence.

one flashes for ~200ms when the computer powers down.

Please Log in or Create an account to join the conversation.

More
18 Apr 2020 20:46 #164512 by PCW
Hmm you should get a red LED briefly at power up (not boot related)

Please Log in or Create an account to join the conversation.

More
18 Apr 2020 20:58 - 18 Apr 2020 20:59 #164515 by owhite
okay sorry I was looking for the lights flashing as it was booting up - but it DOES flash one red, one orange briefly exactly when I hit the power.

still no joy. I'm still getting the "Error: BootSector is invalid" however.
Last edit: 18 Apr 2020 20:59 by owhite.

Please Log in or Create an account to join the conversation.

More
18 Apr 2020 21:02 #164516 by PCW
Is the 6I24 jumpered for 33 MHz? (default to 5I24 firmware)

Please Log in or Create an account to join the conversation.

More
18 Apr 2020 21:08 #164517 by owhite
yes - I checked again. That's the default jumper settings as shown on page 8 of:
http://www.mesanet.com/pdf/parallel/6i24man.pdf
.

Please Log in or Create an account to join the conversation.

More
18 Apr 2020 21:28 #164520 by owhite
is it relevant that lspci -v is reporting:
02:00.0 DPIO module: Device 2718:5124 (rev 01)
           Subsystem: Device 2718:5124
           Flags: medium devsel, IRQ 11
           Memory at f7c00000 (32-bit, non-prefetchable) [disabled] [size=64K]

Please Log in or Create an account to join the conversation.

More
18 Apr 2020 21:33 #164523 by PCW
That looks OK except the "disabled"

What does
sudo mesaflash --device 5i24 --readhmid
report?

Please Log in or Create an account to join the conversation.

More
18 Apr 2020 21:39 #164524 by owhite
ERROR: no HOSTMOT2 firmware found. FFFFFFFF
Configuration Name: 

General configuration information:

  BoardName : 
  FPGA Size: 0 KGates
  FPGA Pins: 0
  Number of IO Ports: 0
  Width of one I/O port: 0
  Clock Low frequency: 0.0000 MHz
  Clock High frequency: 0.0000 MHz
  IDROM Type: 0
  Instance Stride 0: 0
  Instance Stride 1: 0
  Register Stride 0: 0
  Register Stride 1: 0

Modules in configuration:

Configuration pin-out:

Please Log in or Create an account to join the conversation.

More
18 Apr 2020 21:43 #164525 by PCW
OK so its possibly a BIOS issue disabling the card for some reason

Does
halcmd -kf
halcmd: loadrt hostmot2
halcmd: loadrt hm2_pci
get any further?
(I know at one time the pci driver enabled disabled cards to work around BIOS issues)

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.108 seconds
Powered by Kunena Forum