After years of running, my first break down

More
06 Jan 2018 20:56 #104090 by schmidtmotorworks
schmidtmotorworks created the topic: After years of running, my first break down
I don't know where to start, does anything in this file give a clue?

Print file information:
RUN_IN_PLACE=no
LINUXCNC_DIR=
LINUXCNC_BIN_DIR=/usr/bin
LINUXCNC_TCL_DIR=/usr/lib/tcltk/linuxcnc
LINUXCNC_SCRIPT_DIR=
LINUXCNC_RTLIB_DIR=/usr/realtime-2.6.32-122-rtai/modules/linuxcnc
LINUXCNC_CONFIG_DIR=
LINUXCNC_LANG_DIR=/usr/share/linuxcnc/tcl/msgs
INIVAR=inivar
HALCMD=halcmd
LINUXCNC_EMCSH=/usr/bin/wish8.5
LINUXCNC - 2.5.4-64-g28ebd43
Machine configuration directory is '/home/mvjr/linuxcnc/configs/hm2-servoss'
Machine configuration file is '5i23ss.ini'
INIFILE=/home/mvjr/linuxcnc/configs/hm2-servoss/5i23ss.ini
PARAMETER_FILE=hm2-servo.var
TASK=milltask
HALUI=halui
DISPLAY=axis
Starting LinuxCNC...
Starting LinuxCNC server program: linuxcncsvr
Loading Real Time OS, RTAPI, and HAL_LIB modules
Starting LinuxCNC IO program: io
Starting HAL User Interface program: halui
Shutting down and cleaning up LinuxCNC...
Killing task linuxcncsvr, PID=1462
Removing HAL_LIB, RTAPI, and Real Time OS modules
Removing NML shared memory segments
Cleanup done

Debug file information:
Can not find -sec MOT -var MOT -num 1
Can not find -sec IO -var IO -num 1
Can not find -sec LINUXCNC -var NML_FILE -num 1
Can not find -sec EMC -var NML_FILE -num 1
hm2-servoss.hal:381: Pin 'hm2_5i23.0.7i64.0.0.digin.19.in' does not exist
1462
PID TTY STAT TIME COMMAND
Stopping realtime threads
Unloading hal components
More
06 Jan 2018 21:07 - 06 Jan 2018 21:13 #104091 by PCW
PCW replied the topic: After years of running, my first break down
hm2-servoss.hal:381: Pin 'hm2_5i23.0.7i64.0.0.digin.19.in' does not exist

indicates trouble with the 7I64, its power, or the 7I64s connection to the host:
( daughterboard cable, daughterboard, daughteboard power, serial cable )

Though the earlier errors may indicate some other basic LinucCNC issue
It might be that the kernel log after attempting to start LinuxCNC will offer more clues

can you:
sudo dmesg -C
( attempt to start LinuxCNC )
dmesg > log.txt
and then post log.txt here
Last Edit: 06 Jan 2018 21:13 by PCW.
More
06 Jan 2018 23:59 #104093 by schmidtmotorworks
schmidtmotorworks replied the topic: After years of running, my first break down
Thank you for looking at the problem.

Aside from these messages, the other symptoms that I notice are:

1. The board that is not 7I64 has 3 LEDs near the power input.
The LED nearest to the power input is green
the other two are orange.

2. Both of the 7I64 have one red and one green LED from the time they are powered up.

When I first started looking for the problem I wiggled some wires to see if anything was loose.
While doing that a contractor was clicking on and off. I narrowed the location down to one of about 8 wires one of the 7I64s.
I tried to find a loose one but did not find any.
I tried to tighten the set screws in those connectors a little but did not find any loose ones.
Now wiggling those wires does not make the contractor click ( I am not sure which exact wire or contractor it was).

Thanks again.
Attachments:
More
08 Jan 2018 01:08 #104140 by schmidtmotorworks
schmidtmotorworks replied the topic: After years of running, my first break down
Looking at the log file, the text near the end refers to the IO board, can this be taken as an indication that it might be reasonable to try replacing it?

Also, I see that the boards are not expensive, so I was thinking of getting back-ups for all of them just in case any of them become obsolete in the future. Would that be reasonable to do?
More
08 Jan 2018 01:51 - 08 Jan 2018 01:51 #104141 by PCW
PCW replied the topic: After years of running, my first break down
You can certainly buy spares, and even one spare would help isolate the problem,
but its still not clear what the problem is.

It looks like you have a 7I48, a 7I44, and 2 7I64s. is this correct?
If so both 7I64s were detected:

[ 210.958808] hm2/hm2_5i23.0: 2 7i64s

So if you only have two 7I64s that looks OK

Have you changed any thing with LinuxCNC? (any updates etc?)
Last Edit: 08 Jan 2018 01:51 by PCW.
More
08 Jan 2018 03:34 #104143 by schmidtmotorworks
schmidtmotorworks replied the topic: After years of running, my first break down
Yes, that is what I think it has, I can't see the name on all of them.

The last time I ran it about a week ago, I turned off the 220 volt part of the machine and left the 110 volt PC and Mesa stuff powered up as I usually do. This allows me to start the 220 volt portion of the machine and start working without homing the machine.

There were a few error messages in LINUX CNC but that isn't unusual, for example if I move a hand-wheel with the servos turned-off those messages come up. I didn't read them and dismissed them. I don't know if they are saved in a log somewhere or if they would be useful.

I turned on the 220 power and clicked on the button next to Emergency stop, this normally turns on the servos. But this time the button didn't change tint when I clicked it and the servos didn't turn on.

So I restarted LINUX CNC and the messages page came up.
I had not seen that in years and forgot what little I knew about what most of it means.

I don't think anything was updated, at least I didn't do anything to update anything and no one else uses the machine.

So it seems like there is no obvious problem, I can try replacing some boards.
The question is which are most likely the problem?
I hope it is one without so many wires connected to it.
If there is no particular higher probability that the problem is associated with one board vs another, I guess it makes sense to replace the easiest one to connect (fewest wires) first.

Thanks again.
More
11 Jan 2018 16:27 #104293 by schmidtmotorworks
schmidtmotorworks replied the topic: After years of running, my first break down
I have an idea about how I might be able to diagnose the source of the problem.

If I were to comment out all of the code in the config file that related to one particular board at a time could that tell me anything?
More
11 Jan 2018 16:34 #104294 by PCW
PCW replied the topic: After years of running, my first break down
There's an easier way to check with halrun/halcmd commands

If you post you current hal/ini files, I can give you the commands
The following user(s) said Thank You: schmidtmotorworks
More
13 Jan 2018 21:09 #104399 by schmidtmotorworks
schmidtmotorworks replied the topic: After years of running, my first break down
PCW,

Thanks for your help!

Here are my hal and ini files.

I noticed one new symptom with the computer that might be relevant.
Normally it is able to navigate the web on Firefox quite well.
Now it seems to be quite slow and not responding to some right mouse button clicks, (even after replacing the mouse and keyboard).
I barely get by on LINUX so I don't know what to make of it.

Best Regards

Jon Schmidt
Attachments:
More
14 Jan 2018 01:21 #104403 by PCW
PCW replied the topic: After years of running, my first break down
try this (from a terminal window):

halrun &
halcmd loadrt hostmot2
halcmd loadrt hm2_pci config="firmware=hm2/5i23/SVSS6_8.BIT sserial_port_0=00000000"
halcmd show all > all.txt
then attach all.txt here
You can kill the halrun in the background with

if the computer is acting strange you might have problems unrelated to the 5i23/7I64s
kill %1
Moderators: cncbasher
Time to create page: 0.115 seconds
Powered by Kunena Forum