Weeke BP 10

More
19 Jan 2019 19:53 #124455 by db1981
Replied by db1981 on topic Weeke BP 10
Attachments:

Please Log in or Create an account to join the conversation.

More
19 Jan 2019 22:29 #124461 by Marki123
Replied by Marki123 on topic Weeke BP 10
Hallo db1981, mein Englisch ist auch nicht so gut. Ich komme auch aus Deutschland. Der originale E-Stop Schalter ist noch vorhanden. Leider kann ich die Schaltpläne nicht so lesen und tuh mich deshalb schwer dies richtig zu verdrahten

Please Log in or Create an account to join the conversation.

More
20 Jan 2019 18:31 #124485 by db1981
Replied by db1981 on topic Weeke BP 10
Hallo,

ich meinte ob der Schaltschrank noch Original verdrahtet oder schon zerpflückt ist.
Dann brauchst du nur die Kabel welche zur Num gingen umverdrahten.
Wo in Deutschland?

Please Log in or Create an account to join the conversation.

More
20 Jan 2019 18:51 #124487 by Marki123
Replied by Marki123 on topic Weeke BP 10
Hi, ja der Schaltschrank ist soweit noch Original verdrahtet. Mit dem umverdrahten bin ich grade dabei. Momentan hängt es beim Notaus. Ich habe die Pins von der Steuerung überbrückt und die enable in / enable out angeschlossen. Leider lässt sich der Button in Linux nicht schalten. Es kommt ein Fehler dass der externe Notaus aktiv ist? Nähe München...
Attachments:

Please Log in or Create an account to join the conversation.

More
20 Jan 2019 19:19 #124490 by db1981
Replied by db1981 on topic Weeke BP 10
München - Westerwald ist leider weit.

Lief die Maschine denn vorher?
Du musst den Kontakt RS Num noch schliesen, oberhalb von 0K0. Das war ein Relais in der Num welches Betriebsbereitschaft meldet oder bei Absturz/ groben Fehlern abschaltet.

Ich habe bei mir die "Steuerspannungs Schaltung" original gelassen und schalte mit Linuxcnc dann nur die Freigabe der Indramats ein. Der RS Num ist mit einem Relais ersetzt worden welches konstant in der HAL eingeschaltet wird. Hat der Rechner ein Problem oder Linuxcnc wird beendet geht auch die Steuerspannung weg.
heist:
EMC enable in - 1 Kontakt von 0K0 (die alte Leitung A1 von 1K0 )
EMC enable out - 1K0 A1 (schaltet die Achsfreigaben und Bremse)

Trotzdem solltets du jetzt keinen Fehler ext. Notaus haben, sind denn 24V an dem Pin emc-enable-in . Potential richtig aufgelegt? Mesa GND mit Schaltschrank 24V GND verbunden?

Achtung bei der Inbetriebnahme:
Ich würde zuerst 1K0 still legen (A1 weg) und erst einmal schauen ob der ganze Lastteil vernünftig hochfährt. Die Achsen können richtig los heizen. Am besten Stück für Stück. Freigaben weglassen alle Encoder checken, messen ob die Sollwerte richtig an den Indramats ankommen. Dann immer nur eine Achse freigeben (die enables der anderen beiden abklemmen, Achtung auch das Relais welches die Z-Bremse öffnet, die Z Achse fällt sonst runter wenn der Regelkreis vom Servo nicht aktiv ist.)

Please Log in or Create an account to join the conversation.

More
20 Jan 2019 19:38 #124491 by db1981
Replied by db1981 on topic Weeke BP 10
Vielleicht sollte ich noch dazu sagen, das ich das Projekt zwar 2014 komplett abgeschlossen habe. (Mit M-Funktion für die Aggregate, Wechseltisch belegung, Achsen Spiegeln, GUI etc., selbst geschriebenem CAM Plugin für Bohren, Horz Bohren, Nut-Säge etc.)

Aber es nie geschaft habe die X-Achse brauchbar hin zu bekommen. Habe sogar bei Weeke für einen 4-stelligen Betrag die komplette 4m X-Spindel samt neuer Mutter gekauft, da wir ein mechanisches Problem vermuteten.

Ich musste dann auf eine "richtige" €€ Steuerung umsteigen (Beckhoff). Die Massenträgheit vom Support mit seinen Y-Auslegern ist mit dem "infinite" Ruck von Linuxcnc nicht in den Griff zu bekommen. Der ganze Ausleger federt durch den Ruck beim Beschleunigen/ Bremsen immer hin und her, so sind keine Konturen/Bögen/Formen möglich.
Dafür benötigt man leider ein ruckbegrenztes S-Curve Profil.

Ich gebe eigentlich nicht auf, aber mit der Sache bin ich nicht weiter gekommen. Ich weiß was ich da tue, da ich im Alltag 5-Achsen WZ Maschinen baue.

Das Weeke Projekt war nur Hobby zum Flightcase bauen....

Please Log in or Create an account to join the conversation.

More
20 Jan 2019 19:56 #124492 by Marki123
Replied by Marki123 on topic Weeke BP 10
Hi, vielen Dank erst mal für die geniale Hilfe.. Ja ist leider nicht so um die Ecke. Nein die Maschine lief vorher nicht. Die stand auch einige Zeit.. Ich denke dass die Steuerspannungs Schaltung bei mir original ist. Schaut zumindest so aus. Ich wollte dass auch so original lassen. Ich habe leider auch nicht alle Pläne von der Maschine des erschwert das ganz.. Die alten Bezeichnungen von der NUM stehen aber noch drauf. Die 24V an den Pin emc-enable-in muss ich nochmal schauen. GND ist mit dem Schaltschrank 24V verbunden wenn ich es richtig gemacht habe:). Wenn ich Linux starte blinkt die grüne LED auf der 7i77. Aber auf der 7i71 hab ich noch einen Fehler weil die LED rot ist (CR33 oder so). Mit der Inbetriebnahme bin ich soweit schon vorsichtig weil die Motoren sau viel Kraft haben... Ich will halt erstmal sicher die Maschine starten können und mich dann langsam an die Sache herantasten.

Please Log in or Create an account to join the conversation.

More
20 Jan 2019 20:12 #124493 by Marki123
Replied by Marki123 on topic Weeke BP 10
Ok, dass dachte ich mir schon beim schreiben dass du da ein absoluter Profi bist:)Bei mir ist es auch nur ein Hobby und wahr. für mein CNC Wissensstand etwas zu heavy mit so einem Projekt zu starten. Aber no risk no fun:) Soweit bin ich noch lange nicht... Aber dass mit der Trägheit kann ich mir schon Vorstellen. Ich habe mir auch schon überlegt alles weg zu bauen nur eine Fräse damit zu nutzen. Falls die bei mir mal laufen soll möchte ich schon Konturen Fräsen...Du bringst mich da auf eine Idee: Die Y-Ausleger einfach wegschneiden:-)

Please Log in or Create an account to join the conversation.

More
25 Jan 2019 18:53 #124846 by Marki123
Replied by Marki123 on topic Weeke BP 10
Hi db1981, leider kommt der Fehler beim starten von der Oberfläche immer noch. (Externer Notaus ist aktiv)
Ich habe den Kontakt wie folgt angeschlossen...

EMC enable in - 1 Kontakt von 0K0
EMC enable out - 1K0 A1 Achsfreigabe und Bremse
Am Pin emc-enable-in liegen die 24 Volt an. auch der GND auf der Mesa sind mit 24V GND verbunden...

Wäre es evtl. machbar den Einschalttaster zu überbrücken... Oder mach ich doch grundlegend etwas falsch..


Attachments:

Please Log in or Create an account to join the conversation.

More
26 Jan 2019 10:38 - 26 Jan 2019 10:39 #124882 by db1981
Replied by db1981 on topic Weeke BP 10
Hallo,

Zieht gar kein Schütz an wenn du den Steuerung-Ein Taster betätigst ? Mindestens der k230 müsste anziehen.
Last edit: 26 Jan 2019 10:39 by db1981.
The following user(s) said Thank You: aluplastvz

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.212 seconds
Powered by Kunena Forum