rtapi -- uspace -- "Using POSIX non-realtime"

More
01 Apr 2021 09:47 #204380 by andypugh
There is something strange going on here, it seems.
Who owns linuxcnc-dev?
Try
make clean
git clean
then check the permissions in linuxcnc-dev (should all belong to your user)
then the
./autogen.sh
./configure
make
sudo make setuid
sequence.

Please Log in or Create an account to join the conversation.

More
05 Apr 2021 19:27 #204940 by V-max
Hi Andy
if there are permissions problems this maybe help.
"
avc@avc:~$ ls -l
total 60
drwxr-xr-x 4 avc avc 4096 Mar 24 20:50 Desktop
drwxr-xr-x 2 avc avc 4096 Mar 9 19:01 Documents
drwxr-xr-x 3 avc avc 4096 Apr 3 10:32 Downloads
drwxr-xr-x 4 root root 4096 Mar 21 10:19 ec-debianize
drwxr-xr-x 16 root root 4096 Mar 10 10:10 ethercat-hg
drwxr-xr-x 4 avc avc 4096 Mar 10 14:08 linuxcnc
-rw
1 avc avc 56 Mar 24 21:59 linuxcnc_debug.txt
drwxr-xr-x 7 avc avc 4096 Mar 24 21:06 linuxcnc-ethercat
-rw
1 avc avc 771 Mar 24 21:59 linuxcnc_print.txt
drwxr-xr-x 21 root root 4096 Mar 10 22:14 LinuxCncRip
drwxr-xr-x 2 avc avc 4096 Mar 9 19:01 Music
drwxr-xr-x 2 avc avc 4096 Mar 9 19:01 Pictures
drwxr-xr-x 2 avc avc 4096 Mar 9 19:01 Public
drwxr-xr-x 2 avc avc 4096 Mar 9 19:01 Templates
drwxr-xr-x 2 avc avc 4096 Mar 9 19:01 Videos
avc@avc:~$
"

Must I reinstall all root programs without use sudo commands?

Please Log in or Create an account to join the conversation.

More
05 Apr 2021 19:31 #204942 by andypugh
I don't know for sure, but my linuxcnc-dev directory is owned by my user.

I would be tempted to chmod that to yourself and see if it helps.

(Or just re-clone it without a sudo)

Please Log in or Create an account to join the conversation.

More
06 Apr 2021 15:22 #205128 by PCW

Please Log in or Create an account to join the conversation.

Time to create page: 0.062 seconds
Powered by Kunena Forum