Lathe Z axis/joint not homing after updating to 2.8

More
19 Jun 2019 20:58 #137308 by andypugh
This is now fixed in update_ini.
github.com/LinuxCNC/linuxcnc/commit/4542...f5bbf9f5e569ec5f90ba
It would be valuable if you could try running that on a copy of your original config to see if that produces a working setup on your actual hardware.

Please Log in or Create an account to join the conversation.

More
07 Nov 2019 08:50 #149817 by ftkalcevic
There are still some UI issues with this.

There are some bits of code that assume joints 0-8 map directly to axis xyzabcuvw

For example, in touchy/emc_interface.py
        for i in range(1, 9):
            h = " "
            if self.emcstat.homed[i]: h = "*"
            if am & (1<<i):
                letter = 'XYZABCUVW'[i]
                set_text(self.relative[d], fmt % (letter, relp[i]))

Here self.emcstat.homed[ i ] maps to the joints 0,1, while "am" (the axis mask) and "letter" use i as the axis number (index) - which doesn't work because of the gap in joints.

This stops the homed flag from being displayed for Z.

Please Log in or Create an account to join the conversation.

More
07 Nov 2019 11:33 #149834 by andypugh
I have an XZ lathe, and there is a problem with the display of the homing symbols in Touchy, but the axis does home.

There is a problem with unhoming, though, as I recall.

Please Log in or Create an account to join the conversation.

Time to create page: 0.085 seconds
Powered by Kunena Forum