LinuxCNC on RPI4b 8GB with P-LCNC Adapter and parallel BOB

More
22 Sep 2022 13:58 #252569 by geostein8888
 Hello,
after a long way und thousands of tries i got my pi running a RT Raspian what works also with the model B pi and 8GB of RAM.I also got the linuxCNC Version 2.9 (current from git) compiled and running. I have 4 axis set up (xyz and a) and they all are running when i push the /- button for each axis. But when i start the standard cnc program (linuxCNC logo) nothing happens.
I do not get an error nothing moves on the steppers and also in the visual screen the tool is not moving at all. Also when i go to the command line for gcode nothing moves at all.
I have no end/reference switches connected right now, its only a setup with the hardware and the steppers wired together on a table.

Can anybody give me a hind where i have to search? i could not find a log file or something like that. 

Georg
 

File Attachment:

File Name: siriCNC.ini
File Size:4 KB

File Attachment:

File Name: siriCNC.hal
File Size:6 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
22 Sep 2022 18:48 #252580 by tommylight
From a quick glance, there is nothing about spindle in the ini file and there is an entry about spindle-at-speed in the hal file, assuming there is an M3 in the gcode you are using to test, nothing happens as it is waiting for the spindle to reach the set speed.

Please Log in or Create an account to join the conversation.

More
22 Sep 2022 18:49 #252581 by MikeM
It sounds like you need to home the axes. Click the Home All button and that should get you going.

Please Log in or Create an account to join the conversation.

More
23 Sep 2022 03:05 #252596 by geostein8888
Hello,
the homing i did also. As i wrote even sending gcode to move the axis is not working.

Please Log in or Create an account to join the conversation.

More
23 Sep 2022 03:06 #252597 by geostein8888
sending a simple gcode to move the axis is not working (MDI tab). For this a spindle should not be needed

Please Log in or Create an account to join the conversation.

More
23 Sep 2022 13:59 #252616 by geostein8888
i switched now to the latest 2.8 Version, same behavior except that i get now a message that i have to make a reference run (deutsch Referenz Fahrt)

i tried to suppress this with the ini setting in TRAJ
NO_FORCE_HOMING = 1
but this is ignored somehow

Georg

Please Log in or Create an account to join the conversation.

More
24 Sep 2022 10:35 #252655 by geostein8888
so finally i got it to work, there was a problem with my file, the NO_FORCE_HOMNG=1 did the job

Please Log in or Create an account to join the conversation.

Time to create page: 0.085 seconds
Powered by Kunena Forum