Mesa 5i25 + 7i77D can't cofig

More
27 Apr 2021 13:54 - 27 Apr 2021 13:56 #207225 by Taichi
All axes response in loop test, but they slowly turn to one side.
How i can correct zero position in analogout?
And how i can make 5 axes in gmoccapy? Cos i how only 4 axis.
Thx.
Last edit: 27 Apr 2021 13:56 by Taichi.

Please Log in or Create an account to join the conversation.

More
27 Apr 2021 14:43 - 27 Apr 2021 15:18 #207235 by PCW
Replied by PCW on topic Mesa 5i25 + 7i77D can't cofig
Analog axis turning slowly when there is no feedback is expected and not harmful.
Once configured,the drives should be disabled until LinuxCNC is running and
the feedback loop from the encoders is working, so no drift is possible in a working
setup.

The 5 Axis question is probably better asked in the gmoccapy section of the forum
Last edit: 27 Apr 2021 15:18 by PCW.

Please Log in or Create an account to join the conversation.

More
27 Apr 2021 16:02 #207242 by tommylight

Please Log in or Create an account to join the conversation.

More
28 Apr 2021 11:03 #207299 by Taichi
tommylight, i stack on first tuning step.
My X axes - work normal, in pncconfig response normal. In linuxcnc X - make some noise and little jump.
Y axes - normal response in pncconfig but in linuxcnc make big jumps and loud noise
Z axes - normal response in pncconfig. In linuxcnc after press enable Z axes make earthshake for 1 sec and drop to error joint 2.
In your instructions you say if joints make noise or jumps put in calibration joint 2 (Z axes) "output scale" -10. In jog speed i set 15mm/min. I press test button then pres enable and Z axes go to one side fast.
Your instruction i translated in google. What i do wrong?
Thx

Please Log in or Create an account to join the conversation.

More
28 Apr 2021 17:33 #207315 by tommylight
Check the encoder wiring, make sure the DRO counts UP when moving towards the positive side and vice versa, lower the values of the P in the ini file, test again.
Do not change anything or try to tune or calibrate without being able to enable the machine and no motors running or vibrating.
Z axis is not wired or set up properly so it can not be tuned before fixing that.

Please Log in or Create an account to join the conversation.

More
28 Apr 2021 18:03 #207318 by PCW
Replied by PCW on topic Mesa 5i25 + 7i77D can't cofig
To second what tommylight said, make absolutely sure that linuxCNC can
enable/disable the drives before continuing. A runaway can hurt you and or the
machine.

Please Log in or Create an account to join the conversation.

More
28 Apr 2021 20:27 - 28 Apr 2021 20:29 #207330 by Taichi
1 step: I mast check all encoders for normal connect and test them separately from drivers. DRO mast counting while "enable" turn on and power to drivers disable if i move axes by hands?

-- I already wired pin enable output to relay contactor (enable on = 200v go to power drvers/ brake resistor disconnect) (enable off = power off/ brake resistor connect)
!!!But i connected "permission to move" on drivers by jumper!!! for avoid electromagnetic noise to analog control pins.--

2 step: I mast connect control pins for axes what i tune and when enable on motor mast stay still ? But motor can make some sound and little jump while move?

3 step: Go to "calibration", lower the P value to get minimum noise at stop position and disable jumping while moving?

Its plan minimum for tomorrow
Please correct me if i wrong.
If need move topic to correct thread of forum.
Thanks for your help!
Last edit: 28 Apr 2021 20:29 by Taichi.

Please Log in or Create an account to join the conversation.

More
28 Apr 2021 21:00 #207332 by tommylight

1 step: I mast check all encoders for normal connect and test them separately from drivers. DRO mast counting while "enable" turn on and power to drivers disable if i move axes by hands?

Drives disabled and move motor by hand, check DRO if it counts correctly

-- I already wired pin enable output to relay contactor (enable on = 200v go to power drvers/ brake resistor disconnect) (enable off = power off/ brake resistor connect)
!!!But i connected "permission to move" on drivers by jumper!!! for avoid electromagnetic noise to analog control pins.--

No jumpers! LinuxCNC must be able to disable drives when required. This is very important.

2 step: I mast connect control pins for axes what i tune and when enable on motor mast stay still ? But motor can make some sound and little jump while move?

Yes. But if the motors jump when enabled, wiring or hal setup is not correct regarding direction and that can be changed in hal.

3 step: Go to "calibration", lower the P value to get minimum noise at stop position and disable jumping while moving?

Yes.

Please Log in or Create an account to join the conversation.

More
29 Apr 2021 09:50 - 29 Apr 2021 10:47 #207357 by Taichi
Tommylight, i checked all encoders on all axes - DRO counting correctly to both side. All wire have EM shield and grounded.
Then i lower P value for X = 40, Y = 40, Z = 10.
"Permission to move" connected to ENAn+ and ENAn- as you said.

Results:
All axes response and move correctly when i press +\- from LinuxCNC
X axes - stay still and have minimal noise. DRO jump to 0.001
Y axes - stay still, i can't hear any noise. DRO stay still no jump.
Z axes - stay still, but have loud noise and vibration. DRO jumps 0.01 - 0.002 at this division.
To change P value of Z axes - not response. I try between 5 and 50 P value.

Yesterday, you said then no reason to continue tuning until fix this vibration on axes. So i decide to wait your reply to continue.
Thx.
Last edit: 29 Apr 2021 10:47 by Taichi.

Please Log in or Create an account to join the conversation.

More
29 Apr 2021 13:46 #207374 by PCW
Replied by PCW on topic Mesa 5i25 + 7i77D can't cofig
Can you post your hal and ini files?

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.087 seconds
Powered by Kunena Forum