rigid tapping fail advice and "discriminant" err

More
28 Jul 2015 02:19 #60966 by skunkworks
What is the acceleration of you spindle? I am trying to get this to trip in sim and am not having any luck so far

Please Log in or Create an account to join the conversation.

More
28 Jul 2015 03:03 - 28 Jul 2015 05:15 #60970 by tome

What is the acceleration of you spindle? I am trying to get this to trip in sim and am not having any luck so far


Sam,

In the INI file (also attached) is this:

MAX_VELOCITY = 2.5
MAX_ACCELERATION = 50.0
# The values below should be 25% larger than MAX_VELOCITY and MAX_ACCELERATION
# If using BACKLASH compensation STEPGEN_MAXACCEL should be 100% larger.
STEPGEN_MAXVEL = 3.125
STEPGEN_MAXACCEL = 62.50

Or were you talking about VFD accel parameters? In the VFD I am accelerating from 0-3400 rpm in 1.0 second (linear ramp).

-Tom
Last edit: 28 Jul 2015 05:15 by tome.

Please Log in or Create an account to join the conversation.

More
28 Jul 2015 03:11 - 28 Jul 2015 03:12 #60971 by tome
I should also add that sometimes, AFTER completion of the cycle, I get an error that says (paraphrasing) 'Linear move on line 35 would exceed joint 2's physical limit'. I get this sometimes along with the other error, and sometimes by itself.

I just noticed this error today after running this quite a few times.
-Tom
Last edit: 28 Jul 2015 03:12 by tome.

Please Log in or Create an account to join the conversation.

More
28 Jul 2015 03:19 - 28 Jul 2015 03:25 #60972 by tome
Also, also... I noticed that even though my deceleration in the VFD is set to 0.8 second from 3400 to 0 (again linear ramp), at 275 RPM (stops very quick) it looks from this attached video that the spindle doesn't stop when motion in Z stops. You will see slow motion just at the point of transition. You can see, from black sharpee lines i drew on the workpiece at the collet that the piece is screwed up the tap by the spindle - and hence pulled out of the collet a bit. When the cycle finishes and retracts the tap, it isn't fully out of the workpiece. I previously had a G53 Z0 X0 which retracts and [with tap partially inserted] SNAP...That is what happened the first time I am sure. I have since removed the G53 after finish so it just sits there...



-Tom
Last edit: 28 Jul 2015 03:25 by tome.

Please Log in or Create an account to join the conversation.

More
28 Jul 2015 18:29 - 28 Jul 2015 18:41 #60983 by skunkworks
Could we have your whole config? Rob it thinking the discriminant error is a red hearing. Either you are missing steps or there is some sort of configuration error.
Last edit: 28 Jul 2015 18:41 by skunkworks.

Please Log in or Create an account to join the conversation.

More
28 Jul 2015 20:36 #60987 by tome

Could we have your whole config? Rob it thinking the discriminant error is a red hearing. Either you are missing steps or there is some sort of configuration error.


Sam,
I will post the whole config later today if II get to the shop. I could be missing steps. I upped the speed recently, running at 150 ipm. I spent several hours running a long series of movements the other day and didn't have any lost steps (measured a return position with a dial indicator), and I have run some programs that have run fine so I was fairly convinced that wasn't a problem. But, I have seen some other odd issues and am now wondering if that could be the problem. If I get a chance I will also slow the machine down and see if that makes any difference.
-Tom

Please Log in or Create an account to join the conversation.

More
28 Jul 2015 20:47 - 28 Jul 2015 20:48 #60988 by skunkworks
Could you also plot motion.spindle-revs vs z axis.2.motor-pos-cmd?

sam
Last edit: 28 Jul 2015 20:48 by skunkworks.

Please Log in or Create an account to join the conversation.

More
28 Jul 2015 21:50 #60992 by tome

Could you also plot motion.spindle-revs vs z axis.2.motor-pos-cmd?

sam


I assume you mean with halscope, motion.spindle.res on one channel and z axis.2.motor-pos-cmd on the other?
-Tom

Please Log in or Create an account to join the conversation.

More
28 Jul 2015 22:01 #60994 by skunkworks

Please Log in or Create an account to join the conversation.

More
30 Jul 2015 00:17 #61020 by tome
Here is the plot...
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.430 seconds
Powered by Kunena Forum