Umrüstung einer Sinumerik 3T 3-Achs Drehmaschine

More
26 Aug 2019 07:57 #143196 by Leow91
Tommylight any recommendation how to tune the pid parameters?

Please Log in or Create an account to join the conversation.

More
26 Aug 2019 09:53 #143198 by tommylight
I already posted a link to servo tuning and i added more info thanks to PCW for FF1 calculation, so you should have a look at the very first post.

Please Log in or Create an account to join the conversation.

More
26 Aug 2019 10:07 #143199 by tommylight
-turn the motors by hand while the drives are disabled and check the DRO if the encoders are wired properly and counting up and down as the table moves, make shure they are counting in the right direction
-set P to 30
-set deadband to something like 0.0001
-leave everything else at 0
-set the jog speed in Axis GUI or Gmoccapy to 50mm/m
-enable machine/drives
- try a short jog, check the DRO and also check the motor for vibrations
-try another longer jog, again check DRO and vibrations
- if no vibrations add more P
-if to much vibrations less P
-try jog again
This should just get you going, for nore check the tutorial, take your time with it, it looks hard but after you get the first tune right, the rest is easy.
MFG
Tom.

Please Log in or Create an account to join the conversation.

More
27 Aug 2019 01:02 #143268 by HueyHQ

tommylight wrote: set P to 30

Can I just suggest, if retrofitting, start with P=1 - coming from personal experience, I had to reduce to P=0.6, but some further refinement might get it back up to 1.

Please Log in or Create an account to join the conversation.

More
27 Aug 2019 08:07 #143292 by tommylight

HueyHQ wrote:

tommylight wrote: set P to 30

Can I just suggest, if retrofitting, start with P=1 - coming from personal experience, I had to reduce to P=0.6, but some further refinement might get it back up to 1.

Yes of course, that is a good advice.
I never had to set anything lower than 30, so that is usually my starting point.
Thank you.

Please Log in or Create an account to join the conversation.

More
30 Aug 2019 15:12 #143664 by pl7i92
P below 10 is very wear
Die Servo endstufen haben eine interne divisor der ist bestimmt zu hart eingestellt
du solltest den mal mitteln DIP switch auf 64
dann sollte das viel schneller und zarter laufen

Please Log in or Create an account to join the conversation.

Time to create page: 0.097 seconds
Powered by Kunena Forum