Problem homing z axis

More
16 May 2021 11:25 - 16 May 2021 11:26 #209071 by newbynobi
Replied by newbynobi on topic Problem homing z axis
Please read careful and enter exactly what we told you!

HOME = -10.000
HOME_OFFSET = 0.5
HOME_SEARCH_VEL = - 8.0
HOME_LATCH_VEL = 0.5

This are the setting in your case, SEARCH and Latch need different directions
You do not need a HOME_FINAL_VEL entry, if not used, max vel will be used.

Norbert
Last edit: 16 May 2021 11:26 by newbynobi.

Please Log in or Create an account to join the conversation.

More
16 May 2021 11:46 - 16 May 2021 11:50 #209077 by anli
Replied by anli on topic Problem homing z axis

you have not put the - sign in

You're right - I missed the - in front of HOME_LATCH_VEL :unsure: . With the config
MIN_LIMIT = -190
MAX_LIMIT = 0.001
HOME = -10.000
HOME_OFFSET = 0.5
HOME_SEARCH_VEL = 4.000000
HOME_LATCH_VEL = -0.50000
HOME_FINAL_VEL = 0.50000
HOME_USE_INDEX = NO
HOME_SEQUENCE = 0
HOME_IGNORE_LIMITS = YES

I get the following error (10 changed to 14):



What happens is that it moves towards the switch (right direction) and then stops once it hits the switch. It does not move further. I also tried with HOME_FINAL_VEL being negative - although it states in the documentation linuxcnc.org/docs/devel/html/config/ini-...html#_home_final_vel that it has to be a positive number. But the error is the same.

With
MIN_LIMIT = -190
MAX_LIMIT = 0.001
HOME = -10.000
HOME_OFFSET = 0.5
HOME_SEARCH_VEL = -4.000000
HOME_LATCH_VEL = 0.50000
HOME_USE_INDEX = NO
HOME_SEQUENCE = 0
HOME_IGNORE_LIMITS = YES
the axis moves towards the wrong direction.
Attachments:
Last edit: 16 May 2021 11:50 by anli.

Please Log in or Create an account to join the conversation.

More
16 May 2021 11:56 #209080 by anli
Replied by anli on topic Problem homing z axis
Ah, once I looked at the source I think I know where the problem is!

This is the place where the first message is thrown:



It should not throw this message because HOME_IGNORE_LIMITS is YES in my config. However it does.

This is my config:



As you can see there is no line break at the last line - which is HOME_IGNORE_LIMITS = YES. So I think the missing line break is the problem. I'll try and be back in a minute.
Attachments:

Please Log in or Create an account to join the conversation.

More
16 May 2021 12:06 - 16 May 2021 12:07 #209081 by anli
Replied by anli on topic Problem homing z axis
That it was :woohoo: ! Once I added a line break after the last line homing works with this config as expected:
MIN_LIMIT = -190
MAX_LIMIT = 0.001
HOME = -1.000
HOME_OFFSET = 2.000
HOME_SEARCH_VEL = 8.000000
HOME_LATCH_VEL = 0.500000
HOME_USE_INDEX = NO
HOME_SEQUENCE = 0
HOME_IGNORE_LIMITS = YES
#file needs a line break after last line!



Thanks a lot to everyone who helped! Have a great sunday!
Attachments:
Last edit: 16 May 2021 12:07 by anli.

Please Log in or Create an account to join the conversation.

More
16 May 2021 13:10 #209090 by newbynobi
Replied by newbynobi on topic Problem homing z axis
Hi,

glad you found it, I would never ever have looked at this!
My last lines are normally the spindle settings, so I might not have seen this behavior.

By the way, why do you have 4 digits in the DRO, being in metric mode?
Do you know it can be set on the settings page?

Norbert

Please Log in or Create an account to join the conversation.

Time to create page: 0.185 seconds
Powered by Kunena Forum