Install current master 2.8

More
24 Sep 2016 15:32 #80852 by BigJohnT
BigJohnT replied the topic: Install current master 2.8
If you find out that was removed during the update, compare to the backup file the file a bug report.

JT
More
24 Sep 2016 15:59 #80854 by terkaa
terkaa replied the topic: Install current master 2.8
I will check this on monday

Tero
More
06 Dec 2016 11:38 - 06 Dec 2016 11:56 #83712 by emad
emad replied the topic: Install current master 2.8
I have installed the master branch using the master zip archive from Github,I used the default Linuxcnc Debian ISO(rtai) to install
it because it has most dependencies installed. I can't find the master in Synaptic package manager but I can still run it from place .I've disabled the default Linuxcnc in Synaptic. My problem is the rip-environment script which I don't know how to use. I can't start the Stepconfig to setup 4axis gantry plasma machine.XYYZA.Norbert told me to start the config linuxcnc-dev/configs/sim/gmoccapy/gmoccapy-JA/Gantry/gantry_mm.ini .Do not forget to start from terminal and do a rip-environment befor starting the config.Than change the sim config to fit your needs.I don't know how to start it.
Last Edit: 06 Dec 2016 11:56 by emad.
More
06 Dec 2016 13:36 #83713 by rodw
rodw replied the topic: Install current master 2.8
Follow the instructions on the buildbot to configure synaptic. See
buildbot.linuxcnc.org/

Very easy
More
17 Jul 2017 14:09 #95895 by joel0407
joel0407 replied the topic: Install current master 2.8

rodw wrote: Follow the instructions on the buildbot to configure synaptic. See
buildbot.linuxcnc.org/

Very easy


Not quite. What is this?

"Upgrading to a new major version

If you're upgrading from one major version to another, for example from 2.6 to 2.7, you may need to do config changes! Read about it on the Wiki."

What do I need to read on the Wiki?

Happy Days
More
17 Jul 2017 14:18 #95896 by Todd Zuercher
Todd Zuercher replied the topic: Install current master 2.8
More
17 Jul 2017 14:27 #95898 by andypugh
andypugh replied the topic: Install current master 2.8
config changes from 2.7 to 2.8 are extensive. Luckily there is a script that should make all of the required changes automatically. The script should run the first time you launch the new version and will ask if you want the config to be auto-converted.
More
07 Aug 2017 15:19 #97106 by hardware_crash
hardware_crash replied the topic: Install current master 2.8
Hey guys,

Today I tried to download the master branch for wheezy with uspace: realtime with RT-Preempt, but it seems that the buildbot server is down .

Is there another way to install the linuxcnc master with rt-preemt ?
Thanks in advance

Lukas
More
07 Aug 2017 15:27 - 07 Aug 2017 15:28 #97108 by grump
grump replied the topic: Install current master 2.8
Dunno where you will get 2.8 from without the buildbot but I have just installed this and upgraded from it it installed the new linux image i think 9.3 over 9.2 but haven't run the cnc yet to know what version it is
www.linuxcnc.org/testing-stretch-rtpreempt/


Just did it's 2.7.11
Last Edit: 07 Aug 2017 15:28 by grump.
More
08 Aug 2017 12:34 #97170 by grump
grump replied the topic: Install current master 2.8
Looks like buildbot is back up and running again it just upgraded me to 2.8
Time to create page: 0.116 seconds
Powered by Kunena Forum