PCI parallel port disabled with Wheezy / Linuxcnc 2.7

More
18 Dec 2017 19:27 #103304 by Arnief3
I have my system up and running on Ubuntu Lucid and LinuxCNC 2.5. I am trying to upgrade to upgrade to wheezy / Linuxcnc 2.7 via the Live/Install CD and am running into issues with the parallel port card I am using.

lspci -vv Give me the following:
03:00.0 Parallel controller: NetMos Technology Device 9900 (prog-if 03 [IEEE1284])
Subsystem: Device a000:2000
Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 7
Region 0: I/O ports at cc00 [disabled]
Region 1: I/O ports at c800 [disabled]
Region 2: [virtual] Memory at fdbff000 (32-bit, non-prefetchable) [size=4K]
Region 5: [virtual] Memory at fdbfe000 (32-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>

I tried to follow the instructions detailed here (wiki.linuxcnc.org/cgi-bin/wiki.pl?NetMos) but without success.

Any help / tips would be greatly appreciated!

Thanks,
Arnie

Please Log in or Create an account to join the conversation.

More
18 Dec 2017 21:07 #103311 by Todd Zuercher
When upgrading a parallel port config from version 2.5 to 2.7 there was minor change in how the parallel port driver is configured.
linuxcnc.org/docs//2.7/html/getting-star..._configuration_files
You have to remove this line from any of your hal files.
[coded]loadrt probe_parport[/code]

Please Log in or Create an account to join the conversation.

More
18 Dec 2017 21:54 #103314 by Arnief3
I wasn't clear in my initial post - I did a clean install of Weezy and Linuxcnc in a new partition and created the configuration from scratch using stepconf. Just to be sure, I checked the HAL files and they look good as far as I can tell.

Please Log in or Create an account to join the conversation.

More
18 Dec 2017 22:05 #103315 by Todd Zuercher
So is this the same hardware you were using with your old 2.5 install? Or is this a new pc and/or different parallel port card?

Please Log in or Create an account to join the conversation.

More
18 Dec 2017 22:24 #103318 by Arnief3
Yep - same PC, parallel port card and hardware. The old partition with 2.5 is still up and running. It seem as if the change from Lucid to Wheezy may be the problem. I am stuck trying to figure out why the port is showing up as disabled when I run the lspci -vv command. This wasn't an issue with the old install.

Thank for all of your help!

Please Log in or Create an account to join the conversation.

More
18 Dec 2017 23:04 #103322 by InMyDarkestHour
What is the section of dmesg before and after following the instructions on the wiki, with relation to driving loading & unloading ?

May give some insight as to what is happening.

Please Log in or Create an account to join the conversation.

More
19 Dec 2017 18:55 #103352 by Arnief3
I am running the following sequence of commands before starting LinuxCNC:
sudo /sbin/insmod /lib/modules/3.4-9-rtai-686-pae/kernel/drivers/parport/parport_pc.ko
sudo /sbin/rmmod ppdev
sudo /sbin/rmmod lp
sudo /sbin/rmmod parport_pc

What in particular should I be looking for in the dmesg output?

Please Log in or Create an account to join the conversation.

More
19 Dec 2017 20:11 #103358 by InMyDarkestHour
Anything relating to parallel port ?
Preferably from a clean boot then after loading the modules.

You may also try:
sudo modprobe parport_pc io=0xcc00

A second thing you may want to experiment with is to set change the setting in the bios, if the option is there, to a non plug and play operating system. This "should" configure the card and enable the ports. I have no idea why the previous install configured the card.

Remember to try one thing at a time, and check the output of dmesg & lspci

Please Log in or Create an account to join the conversation.

More
20 Dec 2017 23:48 #103415 by Arnief3
Thanks to everyone for the help! I am still stumped but I have not given up yet.

I may try another approach and try to upgrade to 2.7 on my 2.5 / Ubuntu Lucid partition.

Thanks again!

Please Log in or Create an account to join the conversation.

More
21 Dec 2017 07:34 #103421 by InMyDarkestHour
No joy with the above suggestions ?

Out of interest what was the demsg output after the suggestions ?

Please Log in or Create an account to join the conversation.

Time to create page: 0.300 seconds
Powered by Kunena Forum