PCI parallel port disabled with Wheezy / Linuxcnc 2.7

More
24 Dec 2017 01:05 #103507 by andypugh

I am running the following sequence of commands before starting LinuxCNC:
sudo /sbin/insmod /lib/modules/3.4-9-rtai-686-pae/kernel/drivers/parport/parport_pc.ko
sudo /sbin/rmmod ppdev
sudo /sbin/rmmod lp
sudo /sbin/rmmod parport_pc


Nobody else does that :-)

What makes you think that you need it?

Please Log in or Create an account to join the conversation.

More
26 Dec 2017 06:02 #103615 by tommylight
Did you try the c800 address?
What error do you get when starting linuxcnc?
Why are you adding those lines before starting linuxcnc? The last line will remove parallel port driver!
Basically, install wheezy, make the config and change the parallel port address, run linuxcnc.
No terminal commands necessary.
Regards.

Please Log in or Create an account to join the conversation.

More
26 Dec 2017 13:19 #103642 by Todd Zuercher

Did you try the c800 address?
What error do you get when starting linuxcnc?
Why are you adding those lines before starting linuxcnc? The last line will remove parallel port driver!
Basically, install wheezy, make the config and change the parallel port address, run linuxcnc.
No terminal commands necessary.
Regards.


I think because he was trying to follow instructions on a 10 year old wiki page.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
26 Dec 2017 16:31 #103681 by Arnief3
After a few days off, I am back to trying to get this sorted out. Thanks for all of the input.

I have set up a few EMC/LinuxCNC systems over the years but I am not a Linux expert so when it come to obscure linux driver setup issues I am a bit lost.

I have tried all of the normal setup procedures. Installed using the latest live cd (wheezy), config, tried the obvious parallel port addresses - no luck. Then I discovered that the parallel port was coming up as "disabled" using the lspci -vv command. This is what started me down the path of following these instructions ( wiki.linuxcnc.org/cgi-bin/wiki.pl?NetMos).

Moving forward, I am going to try a few things:
- dig a little deeper into the demsg output and try to get the parallel port up and running
- I am setting up a new pc and pci-e parallel port card. I may swap things around until I find something that works.
- try upgrading from 2.5 to 2.7 under Ubuntu Lucid (I don't want to break what I have now so I will try this as a last resort)

I have a working 2.5 system so none of this is an emergency at this point.

Arnie

Please Log in or Create an account to join the conversation.

More
26 Dec 2017 17:44 #103690 by andypugh
It might be disabled in the BIOS.

Please Log in or Create an account to join the conversation.

More
29 Dec 2017 03:15 #103809 by Arnief3
The new parallel port card arrived and it worked without a hitch with Ubuntu Lucid and Wheezy.

Thanks to everyone for their help!

Arnie

Please Log in or Create an account to join the conversation.

More
29 Dec 2017 03:20 #103810 by Arnief3
In case anyone is interested, here is the card that worked for me:
StarTech.com 1 Port PCI Express Dual Profile Parallel Adapter Card - SPP/EPP/ECP - 2x DB25 IEEE 1284 PCIe Parallel Card

www.amazon.com/gp/product/B001Q7X0Z8/ref...00_s00?ie=UTF8&psc=1

Please Log in or Create an account to join the conversation.

More
05 Apr 2018 18:22 #108461 by probotix
We have been using MCS9900 PCIe cards on Biostar A68N-2100 motherboards as a secondary parallel port for quite some time. So we changed to an ECS KAM1-I recently because the Biostar is getting hard to find, and the MCS9900 cards do not work. Both motherboards use PCIe version 2.0 spec. The card appears to show up fine with lspci, but starting LinuxCNC will either cause the PC to reboot, or it will disable the card.

Whats really interesting is that I went into the bios and disabled the sound and onboard serial and when it came back up, the card had changed address and was now working. But upon reboot, it picked up the old address again and the failures starting happening again. Subsequent reboot continue to bring up the old address and same problem.

Please Log in or Create an account to join the conversation.

More
05 Apr 2018 23:05 #108470 by tommylight
You have to change the IRQ assignment in BIOS, from auto to manual and try to set it to a free IRQ ( not easily done as most of the hardware share IRQ's ).
How? I do not know as it differs a lot across the mainboards.

Please Log in or Create an account to join the conversation.

More
05 Apr 2018 23:16 #108471 by probotix
There doesn't appear to be any way to do that in the BIOS.

Please Log in or Create an account to join the conversation.

Time to create page: 0.185 seconds
Powered by Kunena Forum