Buildbot + Debian 11 / Bullseye Questions

More
02 Sep 2021 15:41 #219438 by robertspark
I have been playing around with a few virtual machines trying to find all the dependancies that may be required to get LinuxCNC (+ gmoccapy + qtplasmac) to run.

At one point I tried to add the master build-bot repository to the repositories list (with the buster distribution listed) and the terminal threw up a couple of errors when I tried to update apt. {I forget what they were, I will try again later out of curiosity).

I was wondering if the buildbot master list could be expanded to include bullseye in the list of distributions now that master is python3 and that will be the way things go in the future I expect?
buildbot.linuxcnc.org/

I was also wondering what the procedure / approach was to adding dependencies to linuxcnc or its install?
I found 2x troubling dependencies that I had trying to run linuxcnc (with a RIP master build) on plain vanilla debian bullseye [i.e. bullseye + XFCE desktop + standard system utilities + linuxcnc dependencies] and I'm not sure where they would be best located for future potential people to be aware that they are needed.
forum.linuxcnc.org/gmoccapy/43477-gmoccapy-theme#219291


I also know that there is a script that we need to use / run to get QTPlasmaC to work...... would some of these dependencies not be best placed in a central Linuxcnc dependencies list so that once you install LinuxCNC it will work with all of the GUI's that it is installed with by default and they will work out of the box so to speak for us linux newbs.

Please Log in or Create an account to join the conversation.

More
02 Sep 2021 23:40 #219472 by andypugh
Dependencies are typically listed in the debian config:

github.com/LinuxCNC/linuxcnc/blob/master/debian/control.top.in
and
github.com/LinuxCNC/linuxcnc/blob/master.../control.main-pkg.in

But note that those are ,in files which are expanded into the real control files during the autogen / config stage of the build.

AFAIK that is the only list, and it has to be tweaked to suit the dependencies discovered during the build, ie it isn't automatic.
The following user(s) said Thank You: robertspark

Please Log in or Create an account to join the conversation.

More
13 Sep 2021 11:06 #220422 by hhogendoorn
I Installed Debian 11 +linuxcnc without failures from : linuxcnc.org/docs/devel/html/code/buildi...g-Build-Dependencies. All tests are pass.
But when starting linuxcnc axis it started 1 time with this log file :

RUN_IN_PLACE=yes
LINUXCNC_DIR=
LINUXCNC_BIN_DIR=/home/hans/linuxcnc-dev/bin
LINUXCNC_TCL_DIR=/home/hans/linuxcnc-dev/tcl
LINUXCNC_SCRIPT_DIR=
LINUXCNC_RTLIB_DIR=/home/hans/linuxcnc-dev/rtlib
LINUXCNC_CONFIG_DIR=
LINUXCNC_LANG_DIR=/home/hans/linuxcnc-dev/src/objects
INIVAR=inivar
HALCMD=halcmd
LINUXCNC_EMCSH=/usr/bin/wish8.6
INIFILE=/home/hans/linuxcnc-dev/configs/sim/axis/axis.ini
VERSION=1.1
PARAMETER_FILE=sim.var
TASK=milltask
HALUI=halui
DISPLAY=axis
COORDINATES=X Y Z
KINEMATICS=trivkins
Starting LinuxCNC server program: linuxcncsvr
Loading Real Time OS, RTAPI, and HAL_LIB modules
Starting LinuxCNC IO program: io
Starting HAL User Interface program: halui
Starting TASK program: milltask
Starting DISPLAY program: axis
Removing HAL_LIB, RTAPI, and Real Time OS modules
Removing NML shared memory segments


debug.txt :
60833
60878
Stopping realtime threads
Unloading hal components

And will not start anymore ???? What did I do wrong?

thanks, Hans
 

Please Log in or Create an account to join the conversation.

More
13 Sep 2021 19:52 #220493 by robertspark
I suspect that there is a dependency missing..... which one, I've not got a clue.

Below is a list of the dependencies that I presently install.

Note, I am installing from Debian Bullseye 11 with an XFCE desktop.

Default (first things to install... allows me to edit text files (I like geany), and to customise grub (adding "splash and isolcpus 1,3... yes I know some don't like isolcpus.... it works for me and I seem to get more consistent servo thread times).  Git is installed so that I can clone linuxcnc from git (+ other stuff).
sudo apt install -y geany grub-customizer git 

the following is a list of the linuxcnc build dependencies:
sudo apt install -y debhelper dh-python libudev-dev tcl8.6-dev tk8.6-dev bwidget tclx libeditreadline-dev asciidoc dblatex docbook-xsl dvipng ghostscript graphviz groff imagemagick inkscape python3-lxml source-highlight w3c-linkchecker xsltproc texlive-extra-utils texlive-font-utils texlive-fonts-recommended texlive-lang-cyrillic texlive-lang-french texlive-lang-german texlive-lang-polish texlive-lang-spanish texlive-latex-recommended asciidoc-dblatex python3-dev python3-tk libxmu-dev libglu1-mesa-dev libgl1-mesa-dev libgtk2.0-dev libgtk-3-dev gettext intltool autoconf libboost-python-dev libmodbus-dev libusb-1.0-0-dev psmisc yapps2 libepoxy-dev python3-xlib

install realtime linux kernel:
sudo apt install -y linux-image-rt-amd64

I build debs from the git clone, and then install them.... this then provides all of the linuxcnc dependencies to run linuxcnc (different from build!):
[ok.... some of these may / may not be required if you run some of the plane gui's ...]
sudo apt install -y libboost-python1.74.0 libboost-python1.74.0-py39 libc6 libcairo2 libedit2 libepoxy0 libgcc-s1 libglib2.0-0 libgtk-3-0 libgtk2.0-0 libmodbus5 libpango-1.0-0 libpangocairo-1.0-0 libpython3.9 libstdc++6 libtk8.6 libudev1 libusb-1.0-0 libx11-6 libxinerama1 libxmu6 libudev-dev iptables tcl8.6 tk8.6 bwidget libtk-img python3 python3 python3.9:any python3:any python3-tk python3-numpy python3-pil python3-pil.imagetk libgtksourceview-3.0-dev python3-xlib python3-cairo python3-gi-cairo python3-opengl python3-configobj tclreadline procps psmisc tclx mesa-utils blt udev python3-pyqt5 python3-pyqt5.qsci python3-pyqt5.qtopengl python3-pyqt5.qtsvg python3-pyqt5.qtwebkit python3-opencv librsvg2-dev python3-dbus.mainloop.pyqt5 python3-espeak pyqt5-dev-tools

for me to run Gmoccapy, I found that I needed to install a few additional dependencies...... so these are the few extra in my case:
sudo apt install -y python3-opengl gnome-icon-theme

The following I have been playing with Probe Basic and also QtPyVCP.... and these are the dependencies for running those (as development install):
sudo apt install -y g++ python3-serial python3.9:any udev python3-yapps
sudo apt install -y python3-pyqt5 python3-dbus.mainloop.pyqt5 python3-pyqt5.qtopengl python3-pyqt5.qsci python3-pyqt5.qtmultimedia python3-pyqt5.qtquick qml-module-qtquick-controls gstreamer1.0-plugins-bad libqt5multimedia5-plugins pyqt5-dev-tools python3-dev python3-setuptools python3-wheel python3-pip
The following user(s) said Thank You: Aciera

Please Log in or Create an account to join the conversation.

More
14 Sep 2021 12:09 #220581 by hhogendoorn
Thanks for your help!  Debian 11 + 2.9 linuxcnc is running ! Maybe I missed a file yesterday.

  
 
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Sep 2021 12:37 - 14 Sep 2021 14:33 #220584 by hhogendoorn
See answer below, it worked perfect , started with "linuxcnc" command. But after restart the pc I can not get it to work ?? linuxcnc: command not found.

How to do the "install" instead "run in place"
(ps new to linux hi)
Last edit: 14 Sep 2021 14:33 by hhogendoorn.

Please Log in or Create an account to join the conversation.

More
14 Sep 2021 12:59 #220585 by phillc54
For a run in place install you could use:
~/linuxcnc-dev/scripts/linuxcnc
The following user(s) said Thank You: hhogendoorn

Please Log in or Create an account to join the conversation.

More
14 Sep 2021 13:36 #220590 by hhogendoorn
That's the trick! ok thanks

Please Log in or Create an account to join the conversation.

Time to create page: 0.119 seconds
Powered by Kunena Forum