Linuxcnc 2.9.2 for Raspberry Pi 4 & 5 images

More
02 Jan 2024 22:32 - 02 Jan 2024 22:59 #289612 by der hobbyist
Hi,
I found another small bug. Then I change a tool the icons of the desktop menu become visible (see picture below).
Attachments:
Last edit: 02 Jan 2024 22:59 by der hobbyist.

Please Log in or Create an account to join the conversation.

More
03 Jan 2024 04:05 #289634 by rodw

Hi,
I found another small bug. Then I change a tool the icons of the desktop menu become visible (see picture below).

That is nothing to do with the installation process. I can't help. Report in the correct GUI section

Please Log in or Create an account to join the conversation.

More
03 Jan 2024 10:02 - 03 Jan 2024 10:03 #289644 by cornholio

Hi,
I found another small bug. Then I change a tool the icons of the desktop menu become visible (see picture below).

 
That's normal behaviour for the bottom panel in Debian for  XFCE (for amd64 & arm64) when you move the mouse over the area where the panel would be no matter the application you are using, if you right click on the panel you can change the properties. Not a bug & does not require reporting.
Last edit: 03 Jan 2024 10:03 by cornholio.

Please Log in or Create an account to join the conversation.

More
03 Jan 2024 10:18 #289646 by rodw
Aah, now I know what you were looking at. an XFCE feature

Please Log in or Create an account to join the conversation.

More
06 Jan 2024 16:09 #289978 by cauldron_boy
Installed on a Pi5 8Gb.
Running great with a Mesa 7i76e
The following user(s) said Thank You: rodw

Please Log in or Create an account to join the conversation.

More
11 Jan 2024 09:32 #290411 by Calysto
I have an older image installed on my PI, with 2.9.1. The normal update/upgrade procedure won't help. Can I upgrade to this 'image'?

Please Log in or Create an account to join the conversation.

More
11 Jan 2024 09:40 #290413 by rodw
Install the 2.9.2 image from the downloads page
If its a Pi 5, this image is likely better but you need o use Balena Etcher to burn it to an SD card as the rpi imager does not like it.
drive.google.com/drive/folders/1NfRV8bho...3VXtN?usp=drive_link
This has been fixed upstream but I have not had time to rebuild it

Please Log in or Create an account to join the conversation.

More
11 Jan 2024 10:02 - 11 Jan 2024 13:54 #290414 by Calysto
Hmm... then I have to re-install all the rest.... might do that later...

Pi4
Last edit: 11 Jan 2024 13:54 by Calysto.

Please Log in or Create an account to join the conversation.

More
15 Jan 2024 14:19 - 16 Jan 2024 17:47 #290759 by U2fletch
I have a Pi 400 and the image loads fine. I have sound, and can confirm that it runs great on my setup.  Had a minor hiccup with my Mesa 7i96s board. I could ping the board at address 10.10.10.10, but when I started LinuxCNC I got the "temporarily unavaliable" error. Had to go configure my network settings. Once that was set everything works great.  Thanks!
Last edit: 16 Jan 2024 17:47 by U2fletch. Reason: Had wrong image loaded

Please Log in or Create an account to join the conversation.

More
31 Jan 2024 22:25 #292108 by itai
Hi,
I want to use Raspberry PI 4 + LinuxCNC-RIO (Tangoboard) with SPI connection.
How can I enable SPI (using the IO pins) with the LinuxCNC image?
How can I disable the automatic screen lock?

Thanks,
-- Itai

 

Please Log in or Create an account to join the conversation.

Time to create page: 0.102 seconds
Powered by Kunena Forum