Pathpilot V2 and 7i96 MESA Card

More
19 Nov 2019 18:27 #150671 by davidimurray
Thanks for the info guys - as you say the 7i96 looks like a very useful card so it would be great if it did work.

I've just been out to the garage to have a look at my current lathe (running on parallel port) to have a look at what software version I've got.

I'm running pathpilot 2.2.4 and the EMCVERSION in the log file is 2.8.0-pre1. Kernel is 4.11.9-rt7 and Linux Mint 17.3.

Searching on the harddrive i can find the hm2_eth.so file and looking here - 2.8 Manual HM2_ETH
lists the 7i96 as being supported.

What do you reckon the chances are that it might work? Is there anyway for me to interrogate the hm2_eth file to see what is in it?

Cheers
Dave

Please Log in or Create an account to join the conversation.

More
19 Nov 2019 18:35 #150672 by Vmax549
Only one way to find out (;-). IF PCW does teh bit file to test I will test it here and let you know. That worst thing that could happen is it would not work. Nothing ventured nothing gained.

(;-) TP

Please Log in or Create an account to join the conversation.

More
04 Dec 2019 13:58 #151993 by davidimurray
Out of interest did you guys to get chance to try this out?

Please Log in or Create an account to join the conversation.

More
04 Dec 2019 14:09 #151997 by Vmax549
PCW has not sent a bit file to test.

Sorry, (;-) TP

Please Log in or Create an account to join the conversation.

More
04 Dec 2019 15:42 #152002 by PCW
Replied by PCW on topic Pathpilot V2 and 7i96 MESA Card
Oops I completely forgot about this
What card do you have?

Please Log in or Create an account to join the conversation.

More
04 Dec 2019 17:12 #152010 by Vmax549
7i80

Please Log in or Create an account to join the conversation.

More
04 Dec 2019 17:19 #152011 by PCW
Replied by PCW on topic Pathpilot V2 and 7i96 MESA Card
-16 or -25?

Please Log in or Create an account to join the conversation.

More
04 Dec 2019 18:13 #152013 by Vmax549
16

Please Log in or Create an account to join the conversation.

More
04 Dec 2019 21:54 #152024 by PCW

Please Log in or Create an account to join the conversation.

More
05 Dec 2019 02:01 #152035 by Vmax549
Here are the errors on load. I have not tried to resolve any yet.

hm2: loading Mesa HostMot2 driver version 0.15
hm2_eth: loading Mesa AnyIO HostMot2 ethernet driver version 0.3
iptables: No chain/target/match by that name.
hm2_eth: 10.10.10.10: Hardware address: 00:60:1b:10:00:7e
hm2_eth: discovered 7I80DB-16
hm2/hm2_7i80.0: config.num_encoders=4, but only 3 are available, not loading driver
hm2/hm2_7i80.0: failed to parse Module Descriptor 3
board fails HM2 registration
hm2_eth: rtapi_app_main: Invalid argument (-22)
tormach_mill_clearpath_ecm1.hal:11: waitpid failed /home/operator/tmc/bin/rtapi_app hm2_eth
tormach_mill_clearpath_ecm1.hal:11: /home/operator/tmc/bin/rtapi_app exited without becoming ready
tormach_mill_clearpath_ecm1.hal:11: insmod for hm2_eth failed, returned -1
HALCMD ini file /home/operator/tmc/configs/tormach_mill/tormach_1100MX.ini load failed with config file tormach_mill_clearpath_ecm1.hal
Shutting down and cleaning up LinuxCNC...

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.113 seconds
Powered by Kunena Forum