THCAD unresponsive

More
11 Jul 2020 23:50 #174341 by Kale Dobrohoczki
I'm using a THCAD-300 with a mesa 7i96 in Plasmac gmoccapy. Mode 0. My plasma does not have a voltage divider so I'm using raw voltage. I have hooked the THCAD up according to Tommy's advice here: forum.linuxcnc.org/plasmac/39515-thcad-300-jumper#174265

I have set the scale voltage and offset voltage with this calculator: jscalc.io/calc/NTr5QDX6WgMThBVb


The numbers above make the on-screen voltage readout 42v. If I set the offset to 37 I get a readout of 0v. This is when the torch is not firing. When I do fire the readout does not change no matter what my offset is set to. Also, the Arc OK LED never lights up and when I try to run a simple line cut(made in Plasmac) the torch physically fires but errors out due to not finding the Arc OK.

So I think the THCAD is not sending frequency or Linuxcnc is not reading it. I think my two problems are a symptom of one issue.

I read the voltage across the points I have the THCAD hooked up and I got around 180v with the torch firing in the air.

Thanks.
Attachments:

Please Log in or Create an account to join the conversation.

More
11 Jul 2020 23:57 #174343 by PCW
Replied by PCW on topic THCAD unresponsive
Is the yellow light blinking on the THCAD?
does it blink faster when a higher voltage is applied?

Please Log in or Create an account to join the conversation.

More
11 Jul 2020 23:57 #174344 by phillc54
Replied by phillc54 on topic THCAD unresponsive
Check that you have the following in one of your hal files:
setp  hm2_7i96.0.encoder.00.scale -1
setp  hm2_7i96.0.encoder.00.filter 1
setp  hm2_7i96.0.encoder.00.counter-mode 1

and the following in your <machine_name>_connections.hal file:
net plasmac:arc-voltage-in hm2_7i96.0.encoder.00.velocity => plasmac.arc-voltage-in

and that your physical connections between the THCAD and the 7i96 are correct.
The following user(s) said Thank You: Kale Dobrohoczki

Please Log in or Create an account to join the conversation.

More
12 Jul 2020 04:40 #174354 by Kale Dobrohoczki
Replied by Kale Dobrohoczki on topic THCAD unresponsive
I was missing the scale, filter and counter. Thanks for the help. The THCAD is working as expected.
The following user(s) said Thank You: phillc54

Please Log in or Create an account to join the conversation.

More
04 May 2021 00:36 #207773 by kevpsk8
Replied by kevpsk8 on topic THCAD unresponsive
Kale
How did you enter the scale, filter and counter in the Hal file?

Please Log in or Create an account to join the conversation.

More
04 May 2021 23:50 #207910 by rodw
Replied by rodw on topic THCAD unresponsive

Kale
How did you enter the scale, filter and counter in the Hal file?


add it with a text editor

Please Log in or Create an account to join the conversation.

Moderators: phillc54
Time to create page: 0.165 seconds
Powered by Kunena Forum