qtpyvcp - widget rules editor missing

More
20 Jul 2022 03:57 #247810 by spumco
Been fiddling with .ui's and just realized I can't find the widget rules editor. Right-clicking a widget doesn't give me the same menu options as displayed on the qtpyvcp tutorial page.

Looking back through some earlier threads it seems that I don't have something installed quite right.  Earlier thread poster reported missing python3-pyqt5.qtquick, but package manager reports that's installed on my PC.

Anyone have some insights?

output from qtpyvcp --info:

mill@millvm:~
$ qtpyvcp --info

    QtPyVCP Info
        Version:        python3_master+273.g268f4593

    LinuxCNC Info
        Version:        2.9.0~pre0

    Qt Info
        Qt Version:     5.15.2
        Qt API:         PyQt5
        Qt API Version: 5.15.2

    System Info
        Description:    Debian GNU/Linux 11 (bullseye)

        Kernel:         5.10.0-16-rt-amd64
        Version:        #1 SMP PREEMPT_RT Debian 5.10.127-1 (2022-06-30)
        Ram:            4 GB

    CPU Info
        Vendor ID:      Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz
        Architecture:   
        Physical Cores: 1
        Logical Cores:  1

    Network
        Hostname:       millvm
        IP Address:     127.0.0.1
        MAC Address:    08:00:27:af:25:a5

 

Please Log in or Create an account to join the conversation.

More
20 Jul 2022 05:32 #247820 by TurBoss
hello,


to get rules editor you only need to doble click in any qtpyvcp widget, Qt native widgets dont have rules

Please Log in or Create an account to join the conversation.

More
20 Jul 2022 11:39 #247834 by spumco
I tried on some qtpyvcp widgets, but still dont see a rules editor available.

Probe Basic example - the ATC widget doesn't show up on screen - it's just a blank white box.  When I double click it, a change object name dialog pops up but no rules editor.

Screenshot attached.

What are some other qtpyvcp-specific widgets in PB that have rules so I can see how/if the rules editor works?

Thx
Attachments:

Please Log in or Create an account to join the conversation.

More
20 Jul 2022 11:47 #247835 by TurBoss
can you try with a dro number

just in case, did you install the pyqt5libs using this script?
github.com/kcjengr/qtpyvcp/tree/master/p...15.2-64bit/python3.9

attached picture of the velocity rule
thanks
Attachments:

Please Log in or Create an account to join the conversation.

More
20 Jul 2022 13:22 #247847 by spumco
I'll have a go with one of the DRO boxes tonight, as well as check on my 'real' machine.  One is a VM for testing, the other is a normal installation.  Both are running MX21, LCNC2.9, qtpyvcp master, and PB python3.  VM is a package install, real machine is RIP.

I'll report back after that.

I did run the install.sh script right after I read the other thread  LINK

I didn't download a new version from github... just navigated in terminal to the /././python3.9 folder and ran sudo ./install.sh.

No errors after I ran it, but no change in behavior either.

Please Log in or Create an account to join the conversation.

More
21 Jul 2022 00:13 #247895 by spumco
Nope, still no rules editor when selecting the DROs.

Follwed the dev install instructions at the qtpyvcp page and uninstalled & reinstalled.  No error messages, but still no rule editor.

Attached screenshot of plugins loaded in qtdesigner if that helps.
Attachments:

Please Log in or Create an account to join the conversation.

More
23 Jul 2022 16:23 #248129 by Lcvette
i have both the widget settings and the editor option on my install, but i used the scripted install on debian bullseye xfce. so it is working as this is a recent install.

 

 
Attachments:
The following user(s) said Thank You: spumco

Please Log in or Create an account to join the conversation.

More
23 Jul 2022 18:28 #248132 by spumco
Yes, I'm sure it's me and not anything actually buggy.

I'll revisit this when I'm done with the ATC cleanup and am ready to get back to fidding with PB-vertical
The following user(s) said Thank You: Lcvette

Please Log in or Create an account to join the conversation.

More
26 Oct 2022 21:31 #255137 by spumco
Revisiting this issue on another PC.  Still don't have the lcnc/qtpyvcp plugin installed in QTdesigner.  LCNC, qtpyvcp, and probe basic installed via the Joco-nz script.

PB loads & runs ok through a few sim tests.

I ran the recently updated python3.10 installer and didn't get any errors, but no joy.  Any suggestions?

QtPyVCP Info
        Version:        python3_master+306.g93e8344f

    LinuxCNC Info
        Version:        2.9.0~pre0

    Qt Info
        Qt Version:     5.15.3
        Qt API:         PyQt5
        Qt API Version: 5.15.6

    System Info
        Description:    Linux Mint 21

        Kernel:         5.19.0-2-rt-amd64
        Version:        #1 SMP PREEMPT_RT Debian 5.19.11-1 (2022-09-24)
        Ram:            8 GB

    CPU Info
        Vendor ID:      Intel(R) Celeron(R) N5105 @ 2.00GHz
        Architecture:   x86_64
        Physical Cores: 4
        Logical Cores:  4

 

Please Log in or Create an account to join the conversation.

More
26 Oct 2022 23:13 #255152 by Lcvette
Have you tried with Debian xfce? Mine works here on Debian xfce so not sure what to even look for being out of place.

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.189 seconds
Powered by Kunena Forum