qtpyvcp - widget rules editor missing

More
28 Oct 2022 02:06 #255274 by Lcvette
That's for qtvcp

Please Log in or Create an account to join the conversation.

More
28 Oct 2022 02:14 #255276 by spumco

Are you clicking in linuxcnc widgets?
 


Just reinstalled using the qtpyvcp python3 page instructions.

I'm opening a qtpyvcp .ui file, then right-clicking on a widget in the working window.  There's no rules editor selection available in the pop-up menu.

About plugins: libpyqt5.so, libquickwidget.so, libqwebview.so

Please Log in or Create an account to join the conversation.

More
28 Oct 2022 02:16 #255277 by Lcvette
Maybe run through this and adjust anything that says Debian to mint..

github.com/joco-nz/lcnc-bullseye-install.../install_for_lcnc.sh
The following user(s) said Thank You: spumco

Please Log in or Create an account to join the conversation.

More
28 Oct 2022 02:19 #255278 by spumco
That's a great idea.  I'll have a go right now.

Thx,

Please Log in or Create an account to join the conversation.

More
28 Oct 2022 02:25 - 28 Oct 2022 02:28 #255279 by Lcvette
And maybe run each dependent individually to find the culprit, if there is a compatibility issue that may surface it for you. Or at least maybe find items requiring additional deps to run in mint.
Last edit: 28 Oct 2022 02:28 by Lcvette.

Please Log in or Create an account to join the conversation.

More
28 Oct 2022 02:35 #255280 by spumco
Rand the joco-nz script (there was nothing debian-specific I could find to edit)

Spotted some errors in terminal at the beginning and managed to get a copy of them before it scrolled too far.

Any idea where I can go to get these resolved?  Add a repository or something?
Note, selecting 'tclx8.4' instead of 'tclx'
E: Unable to locate package libepsilon1
E: Unable to locate package libgdal28
E: Unable to locate package libgeos-3.9.0
E: Couldn't find any package by glob 'libgeos-3.9.0'
E: Unable to locate package libglew2.1
E: Couldn't find any package by glob 'libglew2.1'
E: Unable to locate package libnetcdf18
E: Unable to locate package libopencv-calib3d4.5
E: Couldn't find any package by glob 'libopencv-calib3d4.5'
E: Unable to locate package libopencv-contrib4.5
E: Couldn't find any package by glob 'libopencv-contrib4.5'
E: Unable to locate package libopencv-core4.5
E: Couldn't find any package by glob 'libopencv-core4.5'
E: Unable to locate package libopencv-dnn4.5
E: Couldn't find any package by glob 'libopencv-dnn4.5'
E: Unable to locate package libopencv-features2d4.5
E: Couldn't find any package by glob 'libopencv-features2d4.5'
E: Unable to locate package libopencv-flann4.5
E: Couldn't find any package by glob 'libopencv-flann4.5'
E: Unable to locate package libopencv-highgui4.5
E: Couldn't find any package by glob 'libopencv-highgui4.5'
E: Unable to locate package libopencv-imgcodecs4.5
E: Couldn't find any package by glob 'libopencv-imgcodecs4.5'
E: Unable to locate package libopencv-imgproc4.5
E: Couldn't find any package by glob 'libopencv-imgproc4.5'
E: Unable to locate package libopencv-ml4.5
E: Couldn't find any package by glob 'libopencv-ml4.5'
E: Unable to locate package libopencv-objdetect4.5
E: Couldn't find any package by glob 'libopencv-objdetect4.5'
E: Unable to locate package libopencv-photo4.5
E: Couldn't find any package by glob 'libopencv-photo4.5'
E: Unable to locate package libopencv-shape4.5
E: Couldn't find any package by glob 'libopencv-shape4.5'
E: Unable to locate package libopencv-stitching4.5
E: Couldn't find any package by glob 'libopencv-stitching4.5'
E: Unable to locate package libopencv-video4.5
E: Couldn't find any package by glob 'libopencv-video4.5'
E: Unable to locate package libopencv-videoio4.5
E: Couldn't find any package by glob 'libopencv-videoio4.5'
E: Unable to locate package libproj19
E: Unable to locate package python3-pil-dbg
E: Unable to locate package python3-pil.imagetk-dbg
E: Couldn't find any package by glob 'python3-pil.imagetk-dbg'

Please Log in or Create an account to join the conversation.

More
28 Oct 2022 02:40 #255282 by Lcvette
Just try running the script components individually

Please Log in or Create an account to join the conversation.

More
28 Oct 2022 02:49 - 28 Oct 2022 02:50 #255283 by spumco
Got it.  But those packages aren't present - where do I go or how to I get them?

They dont' show up in synaptics as available but not installed, so I'm a little lost on wher to find them.
Last edit: 28 Oct 2022 02:50 by spumco.

Please Log in or Create an account to join the conversation.

More
28 Oct 2022 02:53 #255284 by Lcvette
They should be available through git

Please Log in or Create an account to join the conversation.

More
28 Oct 2022 03:21 #255287 by spumco
I give up.

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.384 seconds
Powered by Kunena Forum