component compile problem

More
10 May 2018 18:21 #110533 by andypugh
andypugh replied the topic: component compile problem

andypugh wrote: What is the actual encoding scheme? How many position do you have?
Possibly you have a one-sensor-per-pocket scheme that I have not been aware of previously.


No, hang on :-)

That is exactly what "single" means. So you were right the first time. Which leaves the question of why it wasn't working.

Was the encoding type all that you changed?
More
10 May 2018 18:33 #110534 by Skidloaders1
Skidloaders1 replied the topic: component compile problem
Yes , it was all I changed

Maybe I must also try BCD ? ( tomorrow)

Still trying to make sense of iocontrol.
The only icontrol only has 2 inputs
Tool changed and tool change prepare. So I'm trying to figure out how it gets activated in the first place .
More
10 May 2018 19:23 #110535 by andypugh
andypugh replied the topic: component compile problem
You can see the sequence by opening sim->axis->axis
estop-off then turn on and home

Machine-show HAL configuration
Then select the watch tab and add the iocontrol.0 pins

You will see that
T4 sets the tool-prepare pin true, and sets the tool-prep-number to 4
(in the sim tool-prepare is linked direct to tool prepared, so the leds just flash once)
Then on M6 tool-change is set to 1 and the system waits for hal_manualtoolchange to set tool-changed to 1
Then tool-prep-number goes to 0 and tool-number goes to 4.
More
11 May 2018 17:48 - 11 May 2018 17:50 #110585 by Skidloaders1
Skidloaders1 replied the topic: component compile problem
Evening Andy
i followed your Sim-axis-axis suggestion and it worked flawlessly.
I learned that I have to home the axis's on my machine

In the sim Tx activates iocontrol.0.tool-change and iocontrol.0.user-enable-out and shows the correct iocontrol.0.tool-number

On my machine and using the carousel single option Tx activates iocontrol.0.tool-prepare but does not display the iocontrol.0.tool-number or carousel.0.current-position at all.

How can I get the carousel.0.current-position to work?

I tried to link the sense pins to various carousel or iocontrol pins without succes.
Attachments:
Last Edit: 11 May 2018 17:50 by Skidloaders1.
More
12 May 2018 15:12 #110603 by andypugh
andypugh replied the topic: component compile problem
Do you have T re-mapped for lathe-style tool-changing?

It almost looks like carousel is stuck, and the fact that I don't see a parity pin might indicate that you are not using the latest version. (And the earlier version did have a way to get stuck)

Showing neither fwd nor rev but at the same time not asserting "ready" is a bit suspicious.

There is a HAL parameter which shows where the carousel state machine currently is.
More
13 May 2018 11:15 #110662 by Skidloaders1
Skidloaders1 replied the topic: component compile problem
T re-mapped for lathe-style tool-changing

sorry, don't know about this or how to re-map T
More
15 May 2018 23:28 #110780 by andypugh
andypugh replied the topic: component compile problem
If you don't know about remapping the you probably haven't done it.

It is possible to configure LinuxCNC so that a T0202 command calls a G-code subroutine that does:

G43 H02 (tool offset)
G43.2 H10002 (add wear offset)
M6 T02

This makes LinuxCNC behave a bit more like most lathes, where the M6 command is not needed to cause a tool change.

If your system has such a remap then it would be in the INI file in the [RS274NGC] section. But you would know if you had put it there.

What state is the carousel state machine in?

There is a Weiler lathe in Stuttgart working really well with the carousel component. I know that it works, I have made parts on the lathe.
More
16 May 2018 16:59 #110791 by Skidloaders1
Skidloaders1 replied the topic: component compile problem
Good day Andy

Obtaining a copy of the Stuttgart Weiler files would be a optimum solution I would say.

Busy reading the remap tutorial files.
A lot a words are used in there that are way above my pay grade.

Question : would a lot of the solutions not be solved in a custom post processor ( maybe easier ? )

rgds Wilfried
More
16 May 2018 17:00 - 17 May 2018 16:01 #110792 by Skidloaders1
Skidloaders1 replied the topic: component compile problem
carousel.0.state value = 0
Last Edit: 17 May 2018 16:01 by Skidloaders1.
More
18 May 2018 21:47 #110855 by andypugh
andypugh replied the topic: component compile problem

Skidloaders1 wrote: carousel.0.state value = 0


That's odd.

github.com/LinuxCNC/linuxcnc/blob/master...s/carousel.comp#L200

It should never be in state 0 if enable is true.

Does the carousel respond to jog buttons? (You can create fake jog buttons with sim_pin )

What is enable connected to? Is that changing state on tool-change?
The following user(s) said Thank You: Skidloaders1
Time to create page: 0.100 seconds
Powered by Kunena Forum