Parallell Port PCI & PCIe Add In Card Info Thread

More
17 Jun 2021 01:21 #212247 by phillc54
This is parport relative stuff with the Oxford chip PP:
garage:~ $ dmesg | grep par
[    0.041549] Booting paravirtualized kernel on bare hardware
[    0.416801] hpet0: 3 comparators, 64-bit 14.318180 MHz counter
[    1.653518] Asymmetric key parser 'x509' registered
[    4.583641] PCI parallel port detected: 1415:c110, I/O at 0xdc00(0xd880), IRQ 16
[    4.585498] parport0: PC-style at 0xdc00 (0xd880), irq 16 [PCSPP,TRISTATE,EPP]
[    5.039707] ppdev: user-space parallel port driver
[    8.105808] lp0: using parport0 (interrupt-driven).
garage:~ $ dir /dev/parport*
/dev/parport0
garage:~ $ 

Please Log in or Create an account to join the conversation.

More
17 Jun 2021 01:37 #212248 by BeagleBrainz
Ok have you been trying that with the Oxford chip ? Which would explain nothing coming from dmesg.

How does all that go with the other card ?

Please Log in or Create an account to join the conversation.

More
17 Jun 2021 01:53 #212249 by phillc54
IDK why I am not getting email responses from this thread...

No, the last post was the Oxford chip the previous post was the MosChip chip.

Please Log in or Create an account to join the conversation.

More
17 Jun 2021 02:44 #212254 by BeagleBrainz
Shame there is no dmesg output from the Moschip, at least we'd know what was going on.

Please Log in or Create an account to join the conversation.

More
17 Jun 2021 06:12 #212257 by phillc54
Yep, it would help a bit. I am still not getting forum emails, that is also a PITA...

Please Log in or Create an account to join the conversation.

More
27 Jun 2021 10:44 - 27 Jun 2021 10:47 #213015 by john11668
My thread initially.. forum.linuxcnc.org/38-general-linuxcnc-q...arallel-port?start=0

The procedures advised to test a card and establish an address for the hal file seemed convoluted and time consuming at a time when I did not have a lot of time anyway.

I eventually changed the PP Card Set up a configuration in Stepconfig , tested it using Hal show and have proceeded from there without real difficulty.
This to me I found far easier than some of the routes I was being guided to in the thread .
I suppose you could say that I muddled my way through this!

The card I opted for was this one
www.ebay.co.uk/itm/320555540172
I presume the details in the description should suffice . I did not note anything further and do not wish to disturb my current setup in order to obtain additional details .
I am reliably informed that these also work.
www.ebay.co.uk/itm/324446248655
I bought one as first reserve so still have it in the box and have not tried it .
Last edit: 27 Jun 2021 10:47 by john11668.
The following user(s) said Thank You: BeagleBrainz

Please Log in or Create an account to join the conversation.

More
27 Jun 2021 11:09 - 27 Jun 2021 11:12 #213016 by BeagleBrainz
Cheers John,
To really identify the card, as ebay listings come & go could you add the output of
sudo lspci -vnn

Once you supply the PCI ID I'll add it to the list.

If you ever get around to trying the other card, and can confirm working, throw up the PCI ID and I'll add it to the mix. What we need is a list of confirmed cards.
Last edit: 27 Jun 2021 11:12 by BeagleBrainz.

Please Log in or Create an account to join the conversation.

More
27 Jun 2021 17:48 - 27 Jun 2021 17:52 #213042 by john11668
3 Pci descriptions turned upI really cant tell which is which but no doubt you can

00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev e1) (prog-if 01 [Subtractive decode])    Flags: bus master, fast devsel, latency 0    Bus: primary=00, secondary=03, subordinate=03, sec-latency=32    I/O behind bridge: 0000c000-0000cfff    Memory behind bridge: fbe00000-fbefffff    Capabilities: [50] Subsystem: Dell 82801 PCI Bridge [1028:0000] 

 00:1c.0 PCI bridge [0604]: Intel Corporation NM10/ICH7 Family PCI Express Port 1 [8086:27d0] (rev 01) (prog-if 00 [Normal decode])    Flags: bus master, fast devsel, latency 0, IRQ 16    Bus: primary=00, secondary=02, subordinate=02, sec-latency=0    I/O behind bridge: 00001000-00001fff    Memory behind bridge: fbf00000-fbffffff    Prefetchable memory behind bridge: 00000000fa000000-00000000fa1fffff    Capabilities: [40] Express Root Port (Slot ), MSI 00    Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit-    Capabilities: [90] Subsystem: Dell NM10/ICH7 Family PCI Express Port 1 [1028:0400]    Capabilities: [a0] Power Management version 2    Capabilities: [100] Virtual Channel    Capabilities: [180] Root Complex Link    Kernel driver in use: pcieport

00:01.0 PCI bridge [0604]: Intel Corporation 4 Series Chipset PCI Express Root Port [8086:2e31] (rev 03) (prog-if 00 [Normal decode])    Flags: bus master, fast devsel, latency 0, IRQ 16    Bus: primary=00, secondary=01, subordinate=01, sec-latency=0    I/O behind bridge: 0000d000-0000dfff    Memory behind bridge: fc000000-fdefffff    Prefetchable memory behind bridge: 00000000f0000000-00000000f9ffffff    Capabilities: [88] Subsystem: Dell 4 Series Chipset PCI Express Root Port [1028:0400]    Capabilities: [80] Power Management version 3    Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-    Capabilities: [a0] Express Root Port (Slot ), MSI 00    Capabilities: [100] Virtual Channel    Capabilities: [140] Root Complex Link    Kernel driver in use: pcieport 

Hope this helps
Last edit: 27 Jun 2021 17:52 by john11668.

Please Log in or Create an account to join the conversation.

More
27 Jun 2021 19:09 #213044 by BeagleBrainz
No John, none of the info mentions the parallel port. If you have a look here forum.linuxcnc.org/18-computer/42826-par...hread?start=0#211997 you’ll see that there is mention of the parallel port and ends with name of the driver, parport_pc.
If you could run the command again and edit your post to suit that would be great.
If you aren’t sure add the whole output and I’ll show you which bit that we need.

Please Log in or Create an account to join the conversation.

More
27 Jun 2021 23:36 #213061 by john11668
Will do it again tomorrow , but dont remember any thing actually mentioning parallel port ??
Will look again and post whole file if I cant find PP info.
A PM facility would be useful

Please Log in or Create an account to join the conversation.

Time to create page: 0.098 seconds
Powered by Kunena Forum