Can someone help me understand what's on this preview screen?

More
31 May 2022 15:42 #244291 by snowgoer540

I like it, i can take a quick glance and see that machine 0 and material 0 are not the same, it reminds me to set material 0, I tend to forget that sometimes. :)


Looking at Axis' implementation of this makes MUCH more sense to me. They also can show a label next to the small origin to show the currently active offset (G54, etc.).

The GUIs I spend most of my time in (QtPlasmaC, and PathPilot) don't allow machine vs relative, and don't use the offset label next to the small origin... so it never made any sense to me.

Glad to have acquired these new brain wrinkles :)
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
01 Jun 2022 15:56 #244381 by snowgoer540
Tommy, 
Chris made me aware that showing the current offset label with the small origin is a stylesheet settable option in qtvcp, and as such, you can turn it on in QtPlasmaC if you'd like:

 

To set it in QtPlasmac:
1. create a file in the <machine_name> config folder called "qtplasmac_custom.qss" 
2: open the file, enter the following, save and close:
#gcodegraphics {
qproperty-_offsets:True
}

Also if anyone dislikes the small origin on a qtvcp screen, it can be hidden via stylesheets now too:
#gcodegraphics {
qproperty-_small_origin:False
}
Attachments:
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
01 Jun 2022 16:30 #244383 by tommylight
Nice, thank you.
Any idea why the tool and the tool path disappear from the view as soon as the mouse is over it and is never shown again until restarting the software, and then it disappears again??

Please Log in or Create an account to join the conversation.

More
01 Jun 2022 17:23 #244386 by snowgoer540
Any chance you could make a YouTube video showing what you mean? I don’t see any behavior like that over here (on any pc virtual or otherwise)…

Could possibly be a result of unstable?

Please Log in or Create an account to join the conversation.

More
01 Jun 2022 21:10 #244406 by tommylight
The following user(s) said Thank You: snowgoer540

Please Log in or Create an account to join the conversation.

More
02 Jun 2022 16:57 #244462 by snowgoer540

Yes, of course.


Realized I wasnt sure if you meant "yes of course, I can grab a screen recording and post it to youtube", or "yes of course it could be unstable". I did not mean the latter as a cop-out. Still would be nice to see exactly what is going on with your setup. Hard to diagnose anything otherwise :)

Please Log in or Create an account to join the conversation.

More
03 Jun 2022 19:33 #244533 by tommylight


Explanation in the description.
The following user(s) said Thank You: snowgoer540

Please Log in or Create an account to join the conversation.

More
03 Jun 2022 20:21 #244537 by billykid
Tom seems to be the problem that mine too ... Phill had told me to disable the view material box in the parameters and the defect disappears.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
03 Jun 2022 21:15 #244543 by tommylight
Oh it was you, i recall reading about it but i could not find it, my search-foo is failing me sometimes. :)
I'll give that a try tomorrow if i get a chance, thank you.

Please Log in or Create an account to join the conversation.

More
04 Jun 2022 06:51 #244559 by billykid
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

Moderators: piasdom
Time to create page: 2.035 seconds
Powered by Kunena Forum