A retrofit of a Stanko SMO 32 CNC milling machine (Ukrainian clone of a Maho)

29 Sep 2022 11:48 #253025 by drogus
I had some other priorities in the workshop in the recent few months, so I had to take a break from this project. I got back this week a bit.

I started by trying to connect the DRO. Initially I ordered Heidenhain 602 EXE units and I wasn't sure if they even work, so I figured out I'll start there. I decided to go for external units, because the EXE module for the existing Heidenhain controller is built in into the controller. Leaving the entire controller just to use signal converters seemed like a bad idea also because of space reasons - the only good place to mount the Linux CNC hardware seems to be in place of the old controller.

I started by installing LinuxCNC and connecting Mesa 6i25 and Mesa 7i77 boards. I ran into a problem with field voltage after flashing the firmware. If you want more details there were two problems I had, described in this thread . Summary: 1) I didn't supply 5V to 7i77 and it needs it either from 6i25 (which needs swapping some jumpers on 6i25) or from external power supply 2) I flashed the wrong firmware - 5i25_7i77x2r instead of 5i25_7i77x2

Quick note about 5V supply. As I'm using only one DRO I supply the 5V voltage from 6i25, but I ordered an external 5V power supply, because 6i25 will likely be two weak to power 3 Heidenhain EXE modules and scales.

After figuring out the problem with mesa cards I connected the Y axis scale to the EXE module and suprisingly it worked on a first try!

I connected pins as described here: www.forum.linuxcnc.org/38-general-linuxc...-encoder-and-exe602e with help from this graphic posted by RotarySMP: forum.linuxcnc.org/27-driver-boards/4117...000t?start=10#198365

The next step was to connect the Indramat 3TRM2 servo drive. Indramat has differential input of -10/+10V on pins marked as E101/E102, E201/E202 and E301/E302. I connected Y axis pins to AOUT0 and GND plus I connected Indramat ground to 7i77 and I could move the axis, but it was moving very rapidly. Like even when setting 0.1mm movement it was jumping 2mm. I think it's due to settings as I haven't changed anything other than voltage level yet. I will wait with further checking it until I connect the rest of the points. I wanted to check the Indramat drive as soon as possible, so it doesn't even have lubrication connected. Doing one 2mm movement without lubrication shouldn't destroy anything, but anything further would probably not be wise.

One more tricky thing that I want to get to as soon as possible is the spindle motor. It is geared, so I will have to program the gear changer, but it also has a VFD - Indramat TRK6. So I need to figure out what kind of encoder the motor uses for calculating the speed and then try to plug it into the VFD. Ideally I would replace the motor with a bigger motor and bypass the gearbox altogether, but this might get too involved. I think I will leave this idea at least until I make the machine work as is.

Please Log in or Create an account to join the conversation.

30 Sep 2022 16:06 #253109 by drogus
Ok, so there is a plot twist. While I was checking the drive controller I got an error that already happened before: PUE, ie. problem with the phases. When I encountered it earlier this year I didn't make much of it - while investigating I felt like I'm chasing my tail, it felt like each component is dependent on the next and ultimately I thought that the problem is in the CNC controller and thus there is no power on the phases inputs to the drive controller.

This time, however, when connecting the spindle controller to LinuxCNC I had mains voltage on the motor controller inputs. I opened a topic asking about that here: forum.linuxcnc.org/30-cnc-machines/47007...amat-trk-6-pue-error and shortly after found out it's because the phases are swapped. Which makes so much sense now. When I bought the machine I was able to turn it on and then when I got back to it, it stopped working. I thought there were no external reason for this, but now I see there was. At some point an electrician connected my workshop to a new power cabinet and probably changed the phases then.

Fortunately when trying LinuxCNC I haven't done too much damage, so I swapped the phases and tried the original control and lo and behold - it worked! I was able to move the axis, change the spindle speed, turn the spindle on/off etc. Which was great, cause I wanted to see how exactly does gear changing works, how many gears there is etc.

My happiness didn't last long, though. I was changing gear speeds to see how many gears there are and I checked a few random speeds: 4000, 100, 500 and 300. I have no idea why, but when I entered 300 it couldn't finish changing the gear and there was a ticking noise. It didn't help to restart the machine - it's stuck now like if the gear servo/stepper broke. I swear this machine just doesn't want to be run.

Anyways, for the conversion I would have to learn how the gear changes worked, so it's a good time to debug it, but I'm getting a bit tired with this machine. And also thinking more and more about a new motor + a VFD. I have no idea how strong it would have to be, though, so that would be another thing to figure out.

Please Log in or Create an account to join the conversation.

30 Sep 2022 20:08 - 30 Sep 2022 22:20 #253120 by drogus
I guess I started having ideas about removing the gearbox a bit too soon. The gears are changed by two DC motors with a high gear ratio to achieve higher torque when switching gears. When I measured the voltage that should be supplied to the motors there was nothing there. I connected an external power supply to supply voltage where needed and when I tried changing gears one of the motors started spinning, but also sparking and smoking. So it's just some kind of a short-circuit, possibly broken motor. Plus something burned on the 24V rail. Not sure where, though cause both power supplies inside the machine work.

While this doesn't sound like a complex issue to fix, it's rather frustrating that as soon as I managed to turn on the machine again something burned without any apparent reason.
Last edit: 30 Sep 2022 22:20 by drogus.

Please Log in or Create an account to join the conversation.

03 Oct 2022 12:00 #253338 by drogus
I swear this machine doesn't want to be fixed. I was playing with it yesterday and I wanted to check what's wrong with the gear changing motor. It was all grimy and dirty, so I cleaned it up and wanted to turn it on again to see if it helps. It didn't want to spin, so I hit the emergency stop and a while after that one of the capacitors on the relay board blew up. I don't have any capacitors around, so I ordered a set and I will try to replace it when they arrive.

I'm not sure if this is just a coincidence, but if it's not, I have no idea why would it blow up like that. I was thinking that maybe the current got too big on the line, but that capacitor was connected in parallel - between 24V rail and ground.

Please Log in or Create an account to join the conversation.

03 Oct 2022 17:17 #253358 by arvidb
What blows capacitors is usually overvoltage or simply old age. (Reverse voltage can blow them too.) I would check the voltage on the 24 V rail.

Please Log in or Create an account to join the conversation.

03 Oct 2022 17:56 #253365 by tommylight

(Reverse voltage can blow them too.)

Spectacularly! :)
The following user(s) said Thank You: arvidb

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.188 seconds
Powered by Kunena Forum