Can this computer be used?

More
08 Jan 2016 02:54 #68046 by jamby
Hey

I've got a Dell Optiplex 745 with a ATI Radeon card. Looking at the plots below is there any using this computer to drive a Bridgeport clone 3 axis knee mill? The mill has Servos, Tacho, and glass scales that are all working now. The Anilam Crusader II needs to be replaced and I would like to use a Mesa 5i25-7i77 kit.

This is with the video card


This is without the card.

Attachments:

Please Log in or Create an account to join the conversation.

More
08 Jan 2016 02:59 - 08 Jan 2016 03:00 #68047 by jamby
Replied by jamby on topic Can this computer be used?
So

If that computer can't be used. How about this collection of parts.

////////////
ASRock H97 Pro4 LGA 1150 Intel H97 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard

Intel Pentium G3258 Haswell Dual-Core 3.2 GHz LGA 1150 53W BX80646G3258 Desktop Processor Intel HD Graphics

G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9D-8GBXL

APEVIA ATX-CW500WP4 500W ATX Power Supply

Cooler Master Elite 130 - Mini-ITX Computer Case with Mesh Front Panel and Water Cooling Support
///////////////////

Does that look like it would all work together to give me a low latency and be able to support the Mesa 5i25-7i77 kit??
Is there anything else that would be needed?

Thanks
Jim
Last edit: 08 Jan 2016 03:00 by jamby.

Please Log in or Create an account to join the conversation.

More
08 Jan 2016 12:53 #68057 by andypugh
Replied by andypugh on topic Can this computer be used?
The without-car max latency of 63uS is acceptable for use with a Mesa Card. You won't need the base-thread with a Mesa setup, so can ignore that.
The following user(s) said Thank You: jamby

Please Log in or Create an account to join the conversation.

More
08 Jan 2016 13:38 - 08 Jan 2016 13:40 #68061 by Todd Zuercher
Setting up isocpus=0 or 1 should help. Also double check your bios to be sure any power saving stuff is turned off. (for the most part if you don't know what it is, or you aren't going to use it turn it off.)
Last edit: 08 Jan 2016 13:40 by Todd Zuercher.
The following user(s) said Thank You: jamby

Please Log in or Create an account to join the conversation.

More
08 Jan 2016 18:25 #68072 by jamby
Replied by jamby on topic Can this computer be used?
Andy
Thanks that will save a few bucks. And I can always upgrade if needed.

Todd
Added isolcpus to the end of this line "GRUB_CMDLINE_LINUX_DEFAULT="lapic quiet rootdelay=5 isolcpus=1" to the /etc/default/grub file and ran grub-mkconfig. Now plot looks like:





I spent a lot of time fighting with that isolcpus setting. The upper left corner says no-isolcpus but the cores show 1.
Checking with "cat /proc/cmdline" doesn't show the isolcpus so I am not sure if its working or not.

Shut off everything in the bios as you mentioned. And finally got the screen saver and power saver to shut down.

Thanks
Jim
Attachments:

Please Log in or Create an account to join the conversation.

More
08 Jan 2016 19:07 #68075 by Todd Zuercher
Still looks like there might be a gremlin or 2 hiding in the bios.

It is somethimes possible to disable all but one core in the bios, maybe you did that?

Please Log in or Create an account to join the conversation.

More
08 Jan 2016 21:05 - 08 Jan 2016 21:34 #68081 by jamby
Replied by jamby on topic Can this computer be used?
Todd

Yup. That's what I did, turned of multi-core I turned it back on. . But still the isolcpus doesn't show up?
I've seen the isolcpus listed in the output of the grub-mkconfig command but it never shows in the plot. Always no_isolcups.
Anyone have any idea why it does not work?

Thanks
Jim
Last edit: 08 Jan 2016 21:34 by jamby.

Please Log in or Create an account to join the conversation.

More
08 Jan 2016 21:34 #68082 by Todd Zuercher
Setting up isolcpus is always difficult for me as well. Every time I set up a new machine, I always flail around for a couple of hours until I finally find the right set of instructions to make it work. I don't do it often enough to remember what worked last time.

Please Log in or Create an account to join the conversation.

More
09 Jan 2016 18:14 #68115 by jamby
Replied by jamby on topic Can this computer be used?
Todd & Andy

Thanks, I finally got isolcpus=1 to work. I followed these instructions.

www.wiki.eusurplus.com/index.php?title=Install_LinuxCNC

With that I had it working however the results don't look that much different. Even though the time is tripled.





Thanks Again
Jim
Attachments:

Please Log in or Create an account to join the conversation.

More
09 Jan 2016 18:35 #68117 by Fastest1
Replied by Fastest1 on topic Can this computer be used?
I am new to this and am trying to understand or improve my pc issues too.

Why is your latency test screen so different than mine? Mine has no graph features, just 6 numeric fields. It doesnt show the computers specs either.

Please Log in or Create an account to join the conversation.

Time to create page: 0.162 seconds
Powered by Kunena Forum