Latency mesage

More
11 Oct 2019 10:41 #147690 by macsddau
Latency mesage was created by macsddau
Hi,

I have setup latency to maximum in stepconf because test were near 65000ns and I get this message :


I don't now how to resolve this. I'm a beginner in Linux world.
Attachments:

Please Log in or Create an account to join the conversation.

More
11 Oct 2019 12:41 #147698 by tommylight
Replied by tommylight on topic Latency mesage
Open the ini file in a text editor and change
Base_period
to something larger, try 100000 ( one hundred thousand )

Please Log in or Create an account to join the conversation.

More
11 Oct 2019 16:01 #147710 by Todd Zuercher
Replied by Todd Zuercher on topic Latency mesage
What PC motherboard and CPU are you using?

Have you turned off all power saving features in the Bios?

It is important to have the PC configured correctly when running real-time operations, but some computers just are not well suited for it. (maybe you have a bad one.)

If you are trying to use an older PC, failing hardware, especially hard-drives, can cause latency problems.

Please Log in or Create an account to join the conversation.

More
13 Oct 2019 04:49 #147787 by macsddau
Replied by macsddau on topic Latency mesage
Hi
The PC is made with :
- ASRock mini ITX J3355B mother board
- 4GB Ram G.Skill SO-DIMM DDR3L 1333 MHz
- Radeon HD4650 Graphic card
- WD Green 120GB SSD Drive
I have turn off all power saving feature in the BIOS. But I will check it.

Please Log in or Create an account to join the conversation.

More
13 Oct 2019 06:25 #147794 by macsddau
Replied by macsddau on topic Latency mesage

macsddau wrote: I have turn off all power saving feature in the BIOS. But I will check it.

Checked !
There is not a lot of settings in the BIOS, all fans are turned to full speed. Mother board has no fan and chassis fans are connected to power supply.

Please Log in or Create an account to join the conversation.

More
13 Oct 2019 06:27 #147795 by macsddau
Replied by macsddau on topic Latency mesage

tommylight wrote: Open the ini file in a text editor and change
Base_period
to something larger, try 100000 ( one hundred thousand )

Changing to this value will remove the message but it is not sure that the CNC will work fine.

Please Log in or Create an account to join the conversation.

More
13 Oct 2019 08:54 #147802 by tommylight
Replied by tommylight on topic Latency mesage
It will work fine, so change it.
While you are getting the error, that causes lost steps, usually not noticeable if the latency is not bad, very noticeable if latency is really bad.

Please Log in or Create an account to join the conversation.

More
13 Oct 2019 09:14 #147806 by macsddau
Replied by macsddau on topic Latency mesage
Ok value changed to 100000.
I can't check the result, milling machine is not built yet :( .
Wait and see...

Please Log in or Create an account to join the conversation.

More
13 Oct 2019 15:06 - 13 Oct 2019 15:06 #147821 by macsddau
Replied by macsddau on topic Latency mesage
This affect the max speed.
For this time go back to 50000.
Last edit: 13 Oct 2019 15:06 by macsddau.

Please Log in or Create an account to join the conversation.

More
13 Oct 2019 19:57 #147825 by Leon82
Replied by Leon82 on topic Latency mesage
You will have to test it out but speed with lost steps is worse than slow rapid speed

Please Log in or Create an account to join the conversation.

Time to create page: 0.134 seconds
Powered by Kunena Forum