Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.

More
10 Sep 2017 14:49 - 10 Sep 2017 14:49 #98776 by tecno
tecno replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
OK,
Will go back to net spindle-enable motion.spindle-on => hm2_7i76e.0.7i76.0.0.spinena

This only works with M4 so that is where to start looking for errors.

Just for kicks I will use old HAL/INI just to verify that M3/M4 still works.
Last Edit: 10 Sep 2017 14:49 by tecno.
More
10 Sep 2017 15:09 #98777 by tecno
tecno replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
Enclosed HAL works OK with M3 and M4 but obviously NOT the spindle encoder.


File Attachment:

File Name: combimillx...9-10.hal
File Size:19 KB
Attachments:
More
11 Sep 2017 08:53 #98819 by tecno
tecno replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
Done some editing to HAL and now I have encoder working as well so G33.1 is functional

........encoder.00 to encoder.04

---Encoder feedback signals/setup---

setp hm2_7i76e.0.encoder.04.counter-mode 0
setp hm2_7i76e.0.encoder.04.filter 1
setp hm2_7i76e.0.encoder.04.index-invert 0
setp hm2_7i76e.0.encoder.04.index-mask 0
setp hm2_7i76e.0.encoder.04.index-mask-invert 0


net spindle-revs <= hm2_7i76e.0.encoder.04.position
net spindle-vel-fb-rps <= hm2_7i76e.0.encoder.04.velocity
net spindle-index-enable <=> hm2_7i76e.0.encoder.04.index-enable
More
13 Sep 2017 05:40 #98911 by andypugh
andypugh replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
Glad to hear it, and I think this means that your 7i76 cards are not broken?

Is it all working now, or are there remaining problems?
More
13 Sep 2017 07:25 #98915 by tecno
tecno replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
Hello Andy,

First of all I am very grateful of all help I have received from you and others on this forum.

The 7i76e in my milling machine appears to be OK.
( the other for lathe is not OK pin 13 is busted, but more of this in another thread later on)

Stil have to tweak motor parameters but I think I can do this if not I will ask for help.

Remaining, well it is time to get all added peripherals to work. First in line is my MPG, see link below.
forum.linuxcnc.org/24-hal-components/332...of-3-to-output#98841

Update as regards the selector swithes, X1-X10-X100 works OK looking with Halshow.
Off - X - Y - Z is behaving odd so it might be so that I have to move those wires to other Inputs.
Will get back to this later today maybe. Sun is shining and have some gardening to do before upcoming rainstorm.
More
14 Sep 2017 11:58 #98938 by tecno
tecno replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.

Off - X - Y - Z is behaving odd


Problem solved = 1 wire not seated properly.
More
15 Sep 2017 16:23 #99002 by tecno
tecno replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
Here my config to my milling machine that now is working with basics.

File Attachment:

File Name: mpg_2017-09-15-3.hal
File Size:2 KB

File Attachment:

File Name: combimillx...15-4.ini
File Size:5 KB

File Attachment:

File Name: combimillx...15-4.hal
File Size:16 KB


Maybe this can be of help to other newbies like me :)
Attachments:
More
11 Oct 2017 19:14 #100231 by zinsade
zinsade replied the topic: This post is for "Andypugh"
This post is for "Andypugh"
Hello Andy,
I know it is not the right place to write this.
But I see no other way to contact you.
In the Liuxcnc-WIKI in the "SpindleOrientation" section, only one part is shown for the spindle orientation.
To be able to follow your idea I am missing a lot of information.
Is it possible to get the corresponding files?
Can you post all files for a really working machine here?
Only for information. I use a 5i76 / 7i76 combination with a Lenze 8201-E VFD under Linuxcnc V2.7.11.
Sorry, but I do not speak English and use the Google translator here.

Best regards
Peter
More
12 Oct 2017 22:58 #100288 by andypugh
andypugh replied the topic: This post is for "Andypugh"
Do you mean this page: wiki.linuxcnc.org/cgi-bin/wiki.pl?SpindleOrient
Or the other one? wiki.linuxcnc.org/cgi-bin/wiki.pl?SpindleOrientation

I should perhaps admit that I have never actually needed to set up spindle-orientation on a real machine.

However, it is configured on this virtual machine:
github.com/LinuxCNC/linuxcnc/blob/master...olchange/spindle.hal

You can run that config (safely, even connected to your real machine) from the config picker:
sim/axis/vismach/VMC-toochange
More
22 Oct 2017 09:24 #100625 by zinsade
zinsade replied the topic: This post is for "Andypugh"
Hello Andy,
You write:
Do you mean this page: wiki.linuxcnc.org/cgi-bin/wiki.pl?SpindleOrient
Or the other one? wiki.linuxcnc.org/cgi-bin/wiki.pl?SpindleOrientation
I mean both sides.
I've seen the flow chart.

However, I do not yet understand the basic relationships, in particular the connection of the inputs of the encoder to the spindle output. It is an -A + A, -B + B, -Z + Z encoder with 1250 pulses per revolution, where -Z + Z is the index signal. I use a 5i25-7i76 combination. The encoder I have connected and I can see the pins in the Hal.
The VMC simulated machine from the Linuxcnc selection I have looked at me but can not connect to my real machine. I can not recognize the connections to my 7i76 there.

Best regards from Germany
Peter
Moderators: cmorley
Time to create page: 0.084 seconds
Powered by Kunena Forum