Spindel 2,2 kw FU läuft nach umstellung nur ganz langsam?

More
23 Aug 2021 18:12 - 23 Aug 2021 18:13 #218532 by xpkiller
chris@cnc wrote:
Hi,
schau mal Zeile 24 und 25 in der MF1040_axis.hal
setp pwmgen.0.pwm-freq 1800.0
setp pwmgen.0.scale 6086.95652174


Hallo,
Ich habe folgende Versuche gemacht. setp pwmgen.0.scale 29000, setp pwmgen.0.offset -1.2 eingegeben,probe_basic gestartet und FDW Taste gedrückt, dann zeigt die Anzeige RPM 300 U/min Spndel läuft kurz an und bleibt stehen, gebe ich dann in der G-Code Leiste S35000 und bestätige mit Enter, passiert nichts, betätige dann die FDW Taste erneut läft die Spindel laut Anzeige 35000 U/min am FU wird 19584 U/min, erhöhe ich dann den Schieberegler auf 120% läuft die Spindel mit höchstleistung Anzeige 42000 U/min und Am FU 23400.Ich habe einiges an Kombinationen ausbrobiert, aber damit läuft es so einigermaßen? In der ini, unter [EMCMOT] ein anderer Wert als BASE_PERIOD = 35000 lässt linuxcnc einfrieren, das geht garnicht? Beim Start von prbe_basic und Drücken der FDW Taste steht dann 300 U/min, wo kann man diesen Eintrag ändern, damit die Spindel direkt anäuft?
Last edit: 23 Aug 2021 18:13 by xpkiller.

Please Log in or Create an account to join the conversation.

More
23 Aug 2021 19:19 #218538 by chris@cnc
linuxcnc.org/docs/2.8/html/config/ini-co...tml#_display_section

DEFAULT_SPINDLE_0_SPEED = 10000
versuch es mal mit diesem Eintrag zusätzlich in der INI display section 
Und dein scale passt nicht. Wenn ich es richtig verstehe muss hier deine Max Spindel Drehzahl stehen. Und der Offset dient als Feintuning. Sollte aber ein positiver Wert sein wenn du nach oben korrigieren möchtest. Wenn alles stimmt sollte dann auch programmierte Drehzahl = realer Drehzahl sein. 
 

Please Log in or Create an account to join the conversation.

More
24 Aug 2021 13:32 - 24 Aug 2021 13:36 #218622 by xpkiller

DEFAULT_SPINDLE_0_SPEED = 10000

Hallo,
Ich habe noch einiges ausprobiert, auch DEFAULT_SPINDLE_0_SPEED = 10000 dabei ändert sich nichts, wenn ich setp pwmgen.0.offset -1.4 den - wegnehme, wird die Spindel noch langsamer und erreicht die max. Drehzal nicht. Ich würde gerne wissen, wo ich im Startprogramm die Drehzal eingeben kann, damit man den Umweg über G-Code Eingabe sparen kann? Ob ich da jetzt 23000 oder 35000 eingebe ist eigendlich Wurst, haupsache die Spindel kommt auf ihre Drehzal. ich glaube bis ich dahintersteige wird noch einige Zeit in Anspruch nehmen, ich habe jetzt fast 2 Jahre nicht mehr gefräst. Ich bin ja schon froh, das ich probe_basic zum laufen gbracht habe, obwohl ich mich damit auch erst einarbeiten muß.  zur Not kann ich ja noch mit Axis arbeiten, aber das ist nicht so mein Ding.

Last edit: 24 Aug 2021 13:36 by xpkiller.

Please Log in or Create an account to join the conversation.

Time to create page: 0.065 seconds
Powered by Kunena Forum