Basic configuration for a chinese 6040 cnc router please

More
04 Dec 2018 02:22 #121793 by gzcwnk
Hi,

I am looking for a guide to connect a chinese 6040 cnc up.

thanks

Please Log in or Create an account to join the conversation.

More
06 Dec 2018 17:24 #121965 by andypugh
Do you intend to control it via the parallel port?

linuxcnc.org/docs/2.7/html/config/stepconf.html

If it is one of the ones with a USB interface then it is possible to control it with LinuxCNC, but a lot of work to gut the controller. In that case I would say it is easier to run with the supplied pirated version of mach3.

Please Log in or Create an account to join the conversation.

More
06 Dec 2018 18:04 #121977 by gzcwnk
No, I specifically spec'd the parallel port version specifically to run linuxcnc. I have a i7 Dell1500 to which I added PCI parallel port and have 2.7 installed. The CNC is in transit, maybe today or more like Monday or Tuesday. I will probably boot the pirated mach3 just to try it so the Dell is dual boot but I dont like using pirated stuff and I use linux for a living anyway. The initial setup is just a bit daunting.

Please Log in or Create an account to join the conversation.

More
06 Dec 2018 18:12 #121978 by andypugh
Stepconf should make it fairly easy, all you really need to know is which stepper driver is on each pin.

Please Log in or Create an account to join the conversation.

More
06 Dec 2018 18:12 #121979 by gzcwnk
Probably going to gut the control box anyway eventually and put in good electronics, just starting with what I could afford. I have 4 stepper controllers from the USA as kits that are supposed to be very good. I just need to assemble them so the last stage is to find a linuxcnc friendly breakout board. Then replace the X rails and maybe Y as I go along. HGR20 rails and HGW20 boggies look the biz.

Please Log in or Create an account to join the conversation.

More
11 Dec 2018 07:10 - 11 Dec 2018 08:42 #122182 by gzcwnk
Ok so I have it setup in terms of hardware. parallel port is on 14f2:0121. The spindle turns via its controller but despite running setpconf I have no movement.

The controller is a 3/4axis jb3163 type Ive tried two configs.

2=x step
3=xdir
4= y step
5 = y dir
6 = z step
7 = z dir

No movement.


The other way is I can import a mach.ini? if anyone has the same hardware?

**edit**
Ok Ive got a little further, I re-did the stepconf but didnt change a single thing and now when I go to test the axis I can here a small "thunk" from X and y steppers. Not for Z, that sounds like a relay is closing when I try and move. Hmmm so my noob opinion is I think the parallel card is detected OK and it sounds like something is happening so its down to I have the wrong pinouts?

***edit2***

Have case off, I have one lit red LED next to the parallel port and 8 green LEDs. first 6 = lit right to left X-pu, X-dr, Y-pu, y-dr z-pu, z-dr these are lit Green 7 is unknown and unit. When I toggle the em stop in Linux cnc green led 8 toggles also.

I can toggle the X and Y dr leds Ok while in test the axis. Hmm something needs enabling? something inverting?
Last edit: 11 Dec 2018 08:42 by gzcwnk.

Please Log in or Create an account to join the conversation.

More
11 Dec 2018 08:50 #122187 by pl7i92
there might be a Estop chain Hint
check the full pinout as input is connected

Please Log in or Create an account to join the conversation.

More
11 Dec 2018 09:07 #122189 by gzcwnk
So
pin1 = estop
pin2 = X step
pin 3 = X dir
pin 4 = Y step
pin 5 = Y direction
pin 6 = Z step
pin 7 = Z dir

pin 14 = Amplifier enable

At this point I think I'll go to bed.....a little progress anyway!

Please Log in or Create an account to join the conversation.

More
11 Dec 2018 10:45 #122201 by andypugh
Is there any documentation with the machine? It seems odd that they expect you to work it out entirely for yourself.

Please Log in or Create an account to join the conversation.

More
11 Dec 2018 19:36 - 11 Dec 2018 19:38 #122227 by gzcwnk
Hi, I have been promised it, repeatedly. I asked before I bought and was told yes we'll send it, so far, despite re-asking, no They will get a crap review on service.

3/4axis jb3163 type is a clont of a chinese? clone? pics Ive seen of the "real" chinese clone list the above and a board revision, this clone is blank.

Anyway with movement the worst job is solved, now its calibration. Though it has no homing switches so these I have to fit and configure.

Where is the best point to put homing switches? lower front left? Z at lowest movement point I assume?
Last edit: 11 Dec 2018 19:38 by gzcwnk.

Please Log in or Create an account to join the conversation.

Time to create page: 0.117 seconds
Powered by Kunena Forum