Mitsubishi SSCNET

More
27 Apr 2023 19:47 #270079 by tropostudio
Replied by tropostudio on topic Mitsubishi SSCNET
Dmitry - I'm running your YMD2SP Meldas adapter in Buster 10.13 with LCNC 2.8.4. What is the possibility of running the card in LCNC 2.9 or 3.0 in Bullseye 11?

Please Log in or Create an account to join the conversation.

More
28 Apr 2023 09:41 - 28 Apr 2023 09:49 #270101 by Aciera
Replied by Aciera on topic Mitsubishi SSCNET
I'm sorry wrong post, disregard.
Last edit: 28 Apr 2023 09:49 by Aciera.

Please Log in or Create an account to join the conversation.

More
28 Apr 2023 10:12 #270106 by tommylight
Replied by tommylight on topic Mitsubishi SSCNET

I'm sorry wrong post, disregard.

You are entering "the twilight zone" ... :)

Please Log in or Create an account to join the conversation.

More
28 Apr 2023 11:36 #270109 by dm17ry
Replied by dm17ry on topic Mitsubishi SSCNET

Dmitry - I'm running your YMD2SP Meldas adapter in Buster 10.13 with LCNC 2.8.4. What is the possibility of running the card in LCNC 2.9 or 3.0 in Bullseye 11?

possible, but no binary packages from me until 2.9 is out.
if you don't use absolute encoders - halcompiling the nyx.comp and installing nyx.ko is enough. if you do - lcnc has to be patched a bit.
i've played with debian 12/lcnc master lately. they have eliminated 'build deb package' functionality from DKMS, have to figure out how to do it manually...

Please Log in or Create an account to join the conversation.

More
29 Apr 2023 01:16 - 29 Apr 2023 01:21 #270155 by tropostudio
Replied by tropostudio on topic Mitsubishi SSCNET
Gotcha. Only reason I ask is because of some touchscreen issues in top-level dropdown menus in Buster, independent of desktop. Those look to be an issue that got resolved in Bullseye (and beyond). But that's not your problem!

Are you able to ship cards?  Not in need of one immediately - just wondering if you are subject to export restrictions. Cheers!
Last edit: 29 Apr 2023 01:21 by tropostudio. Reason: typo

Please Log in or Create an account to join the conversation.

More
29 Apr 2023 15:57 #270215 by dm17ry
Replied by dm17ry on topic Mitsubishi SSCNET
if a newer kernel eliminates your touchscreen problems - tell me which debian release you are happy with, i'll install it and build lcnc 2.9 prerelease.

i can ship whatever i have with me. i've fled moscow last october for good, leaving all my stuff behind :) so far have mostly settled in bucharest. starting from scratch, so it will take some time to restart production
The following user(s) said Thank You: tommylight, tropostudio

Please Log in or Create an account to join the conversation.

More
01 Jul 2023 16:00 #274607 by tropostudio
Replied by tropostudio on topic Mitsubishi SSCNET
dm17ry

Earlier on in the thread you mentioned issues with Mitsu #36 alarm codes with some of  drives when developing theYMDS2P board.  I'm having this problem with the 2 MDS-A-V2-0505 drives in my retrofit.  Motor and drives in the intro to my PAR file below:

; Howa 320H VCJ parameters
; originally MELDAS 520AM control
;
; 0: X    MDS-A-V2-0505    HA43NC-S
; 1: Y                    HA43NC-S
; 2: Z    MDS-A-V2-0505    HA43NCB-C
; 3: JC                    HA43NC-3
; 4: MG    MDS-A-SVJ-01    HA-FH13C-Y
; 5: TC    MDS-A-SVJ-03    HA-FH23C-Y
; 6: S    MDS-C1-SPH-110    SJ-N-11LZM
;    PS    MDS-A-CV-150
; Last Revision: 06/30/23 - CK

Screenshot after startup.  Servo period is 888888ns.  I added an 'err-count' readout to the right of 'phase' display.  
 

Any idea what's causing the alarms?
 
Attachments:

Please Log in or Create an account to join the conversation.

More
01 Jul 2023 17:26 #274610 by dm17ry
Replied by dm17ry on topic Mitsubishi SSCNET
not 100% sure, but it may be provoked by other drives in alarm state..
i would start from the end of the chain. connect the card to the spindle drive's CN1A. MDS-CV i guess is hooked to the spindle. get it up and running without alarms.
then add one SVJ before it, get rid of the encoder alarm 20.
and so on..

Please Log in or Create an account to join the conversation.

More
01 Jul 2023 18:12 #274612 by tropostudio
Replied by tropostudio on topic Mitsubishi SSCNET
Makes sense. Fix it one by one.
Thanks!

Please Log in or Create an account to join the conversation.

More
03 Jul 2023 23:04 - 03 Jul 2023 23:08 #274717 by tropostudio
Replied by tropostudio on topic Mitsubishi SSCNET
dm17ry -

I put together LinuxCNC machine configurations that let me isolate and check individual Mitsu drives. MDS-C1-SPH-110 is fine by itself. Both MDS-A-V2-0505's throw #36 'NC transmission' errors on each drive, no matter what I adjust within the .PAR files - even setting them up with Mitsubishi standard parameter for the drive and motor settings. Maybe it is a matter of re-zeroing axes, even with absolute encoders that report back as OK?

We can take this to email if it's getting into the weeds. What is the best way to contact you?
Last edit: 03 Jul 2023 23:08 by tropostudio. Reason: typo

Please Log in or Create an account to join the conversation.

Time to create page: 0.138 seconds
Powered by Kunena Forum