LinuxCNC Uspace

More
17 Jan 2019 13:44 #124350 by BigJohnT
LinuxCNC Uspace was created by BigJohnT
I'm collecting in one place instructions to build/install the Preempt RT kernel on various OS's and building or getting LinuxCNC.

gnipsel.com/linuxcnc/uspace/index.html

JT
The following user(s) said Thank You: Mike_Eitel, shayloco, tommylight, Badger, tivoi, jimmyman

Please Log in or Create an account to join the conversation.

More
17 Jan 2019 15:56 #124356 by pl7i92
Replied by pl7i92 on topic LinuxCNC Uspace
nice work
but isent there the stretch only to be practicle as ubuntu dosent suport preamt realtime anymore

Please Log in or Create an account to join the conversation.

More
17 Jan 2019 16:18 - 17 Jan 2019 16:18 #124363 by BigJohnT
Replied by BigJohnT on topic LinuxCNC Uspace
I'm not sure what your trying to say but you can pick from Debian 7, Debian 9, Linux Mint 18.3 and Linux Mint 19.1. I have no instructions for Ubuntu.

JT
Last edit: 17 Jan 2019 16:18 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
17 Jan 2019 17:53 - 17 Jan 2019 17:57 #124370 by PCW
Replied by PCW on topic LinuxCNC Uspace
If you build your own kernel (as Johns instructions show),
Any Debian based distribution including ubuntu should work

I'm running LinuxCNC uspace + Preempt-RT on Ubuntu18.04:

peter@dc7800:~/Desktop$ cat /etc/issue
Ubuntu 18.04.1 LTS \n \l
peter@dc7800:~/Desktop$ uname -a
Linux dc7800 4.19.10-rt8 #1 SMP PREEMPT RT Wed Jan 2 10:23:30 PST 2019 x86_64 x86_64 x86_64 GNU/Linux
Last edit: 17 Jan 2019 17:57 by PCW.
The following user(s) said Thank You: tivoi

Please Log in or Create an account to join the conversation.

More
13 Apr 2019 13:26 #130768 by tjtr33
Replied by tjtr33 on topic LinuxCNC Uspace
John Thornton, Hello,
I have a problem upgrading from Debian 8 to Debian 9 ( Jessie to Stretch i think they are named ).

I followed these notes
gnipsel.com/linuxcnc/uspace/debian9-emc.html
I had no errors or warnings until
near the end I got this message
(while installing linuxcnc-uspace)

tomp@jessie:~$ sudo apt-get install linuxcnc-uspace
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
linuxcnc-uspace : Depends: libboost-python1.62.0 but it is not installable
Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u2 is to be installed
Recommends: linux-image-rt-amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.

i already have libboost-python 1.55 and no 1.6 listed by synaptic
I already have libstdc++ 4.9.2.10+deb8u2 ,
( i have no idea what is meant by "is to be installed" , its already there )

some info about my system:

tomp@jessie:~$ uname -a
Linux jessie 3.16.0-9-rtai-amd64 #1 SMP PREEMPT Debian 3.16.7-6linuxcnc (2015-11-30) x86_64 GNU/Linux

tomp@jessie:~$ cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 8 (jessie)"
NAME="Debian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=debian
HOME_URL=" www.debian.org/ "
SUPPORT_URL=" www.debian.org/support "
BUG_REPORT_URL=" bugs.debian.org/ "

any hints?

thanks
tomp

Please Log in or Create an account to join the conversation.

More
13 Apr 2019 20:07 - 13 Apr 2019 20:08 #130790 by InMyDarkestHour
Replied by InMyDarkestHour on topic LinuxCNC Uspace
Where John mentions stretch in the instructions you will have to replace it with jessie.

eg:
sudo add-apt-repository "deb http://linuxcnc.org/ stretch base 2.7-uspace"

will be
sudo add-apt-repository "deb http://linuxcnc.org/ jessie base 2.7-uspace"
Last edit: 13 Apr 2019 20:08 by InMyDarkestHour.

Please Log in or Create an account to join the conversation.

More
14 Apr 2019 08:00 #130830 by tjtr33
Replied by tjtr33 on topic LinuxCNC Uspace
Thanks for the answer
but
the effort is to upgrade from jessie ( what i got )
to stretch ( what i want to upgrade to ).

methinks keeping the repos as they were already would have no effect

are you sure about editing all 3 instances of "stretch" to "jessie" ?

Maybe I dont understand, willing to try but i got a munged system already.

Please comnsider my hesitation and tell me what you think.
Thanks
TomP

Please Log in or Create an account to join the conversation.

More
14 Apr 2019 08:28 #130833 by pl7i92
Replied by pl7i92 on topic LinuxCNC Uspace
is there TCP M128 on the new ISO already provided

Please Log in or Create an account to join the conversation.

More
14 Apr 2019 09:55 - 14 Apr 2019 11:31 #130841 by InMyDarkestHour
Replied by InMyDarkestHour on topic LinuxCNC Uspace
If you system is "munged", copy what you want from your home directory and do a fresh install with stretch.

A whole lot easier than trying to recover.

Just pick one of the three linuxcnc repos, don't add all three.
Last edit: 14 Apr 2019 11:31 by InMyDarkestHour.

Please Log in or Create an account to join the conversation.

More
17 Apr 2019 09:54 #131048 by BigJohnT
Replied by BigJohnT on topic LinuxCNC Uspace
Those instructions are for a fresh clean install not an upgrade.

JT

Please Log in or Create an account to join the conversation.

Time to create page: 0.118 seconds
Powered by Kunena Forum