(superseeded) Linuxcnc on Linux Mint 19.3 quick and easy installation

More
27 Oct 2020 00:26 #187357 by irwinger
BAHHH!!! back to the 2 parallel port error messages now... but I noticed that the 'power' button for LinuxCNC was no longer greyed out - so I thought... "if it smokes, I'll probably be able to figure it out!".

Hit the power button and the I can manually move the system around. Normally - I use the arrow keys to move it - but only the left/right keys work and they move the head diagonally. To change the diagonal direction (+y|+/-x to -y|+/-x) I have to tap either the up or down arrow key. When using the homing function - it also moves diagonally and not in one direction.

I appreciate your time and quick responses - the question is... are these errors causing the diagonal movement (somehow I don't think so?) or is that a different configuration issue I need to resolve?

Arden

Please Log in or Create an account to join the conversation.

More
27 Oct 2020 00:59 - 27 Oct 2020 01:00 #187359 by irwinger
Wahoo!! it works (I think). At least the manual motion around the surface is now correct - I had a configuration error in my stepconf file. I corrected that and it now moves and homes correctly.

I'm going to try a test cut to see and then I am off to the races (I hope).

Thanks Beaglebrainz for your work in developing this LinuxCNC/Linux Mint marriage and thanks so much for working to help me get going. I'm still not sure about the errors I experience on loading - I hope the don't rear their ugly head half-way through one of my 4+ hour cuts...

Arden
Last edit: 27 Oct 2020 01:00 by irwinger. Reason: wrong word - completely changed the meaning of my first couple statements

Please Log in or Create an account to join the conversation.

More
27 Oct 2020 02:12 - 27 Oct 2020 02:13 #187362 by BeagleBrainz
Not completely out of the woods yet.
What we need to do is stop those modules from loading every time you boot.

The file that I have attached needs to be renamed blacklist-linuxcnc-ppdev.conf and then copied using sudo to /etc/modprode.d/
mv blacklist-linuxcnc-ppdev.conf.txt blacklist-linuxcnc-ppdev.conf
cp sudo blacklist-linuxcnc-ppdev.conf /etc/modprobe.d

Then reboot and see if linuxcnc runs. If not we will have to try some thing else.
Attachments:
Last edit: 27 Oct 2020 02:13 by BeagleBrainz.

Please Log in or Create an account to join the conversation.

More
18 Nov 2020 23:46 #189739 by aparecido
Hello everyone, everything good? I'm trying to run the autoleveller software, but it is giving me an error with the installed java, I couldn't solve it, the author of the software suggests installing the JRE version 11 or earlier, I followed tutorials that found and it didn't work with any.
can you help me? Thanks.

Please Log in or Create an account to join the conversation.

More
19 Nov 2020 00:16 #189741 by tommylight
Did you set the permissions for the file to be executable ?
And start a new topic for software questions and issues not related to this tutorial.
The following user(s) said Thank You: aparecido

Please Log in or Create an account to join the conversation.

More
19 Nov 2020 00:24 - 19 Nov 2020 00:29 #189743 by aparecido
Yes, I gave the permissions.
Just explaining to me that I posted here .. I posted on this topic, because I am not using the installation of the main page, I am using Mint 19.3 and I thought the post here would be more appropriate, as there must be differences between it and Debian.
I created the topic , thanks again tommylight.
Last edit: 19 Nov 2020 00:29 by aparecido.

Please Log in or Create an account to join the conversation.

More
19 Nov 2020 00:56 #189745 by tommylight
Yup i thought you are using this, but that is a Linux issue and this is for installation of LinuxCNC issues.
You are welcomed, always.
The following user(s) said Thank You: aparecido

Please Log in or Create an account to join the conversation.

More
09 Jan 2021 12:44 - 09 Jan 2021 12:45 #194586 by Fiury
Hello,

i intalled Mint 19.3 and linuxcnc , but i cannt run VDF via terminal:

a) PC - intell NUC
b) board - mesa7i76ed

i have warning in setup of mesa (by spindle): You are using a simulated-realtime version of LinuxCNC, so testing / tuning of hardware is unavailable.


Have i problem with system or VDF setup ? (is the warning ok ? probably not i think so..)

Thank you for support
Attachments:
Last edit: 09 Jan 2021 12:45 by Fiury.

Please Log in or Create an account to join the conversation.

More
09 Jan 2021 12:54 #194587 by tommylight
Ahoj Jane,
On the first page of pncconf untick the "create simulated......"
And start a new topic for the VFD issues, this is for installation issues only.

Please Log in or Create an account to join the conversation.

More
09 Jan 2021 14:47 #194590 by my1987toyota
Glad to see this topic at the top of the Installing Linuxcnc page

Please Log in or Create an account to join the conversation.

Time to create page: 0.237 seconds
Powered by Kunena Forum