New Configuration Error

More
15 Jul 2020 02:14 #174677 by phillc54
Replied by phillc54 on topic New Configuration Error

Helping a guy run configurator to get his table going for the first time. Afterward, encountered this error on start-up "signal 'spindle-at-speed' not found".

It turns out that this line regarding the spindle was not commented out, and caused the problem:
sets spindle-at-speed true

Commenting it out solved the problem. If I recall, I think the configurator was recently updated to comment out spindle lines, it looks like perhaps one slid through the cracks.

Fixed...
The following user(s) said Thank You: tommylight, snowgoer540

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 10:43 #174721 by snowgoer540
Replied by snowgoer540 on topic New Configuration Error

Helping a guy run configurator to get his table going for the first time. Afterward, encountered this error on start-up "signal 'spindle-at-speed' not found".

It turns out that this line regarding the spindle was not commented out, and caused the problem:
sets spindle-at-speed true

Commenting it out solved the problem. If I recall, I think the configurator was recently updated to comment out spindle lines, it looks like perhaps one slid through the cracks.

Fixed...


Good work. I think we'll let you stay on as lead developer! :laugh:
The following user(s) said Thank You: rodw

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 10:48 #174724 by phillc54
Replied by phillc54 on topic New Configuration Error

Good work. I think we'll let you stay on as lead developer! :laugh:

Bugger... :(

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 10:53 #174726 by snowgoer540
Replied by snowgoer540 on topic New Configuration Error

Good work. I think we'll let you stay on as lead developer! :laugh:

Bugger... :(


Don't be sad, it comes with a 100% pay increase!

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 10:54 #174728 by phillc54
Replied by phillc54 on topic New Configuration Error

Good work. I think we'll let you stay on as lead developer! :laugh:

Bugger... :(


Don't be sad, it comes with a 100% pay increase!

Oh goody, now I'll be able to buy..... nothing

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 10:55 #174729 by rodw
Replied by rodw on topic New Configuration Error

Good work. I think we'll let you stay on as lead developer! :laugh:

Bugger... :(


Don't be sad, it comes with a 100% pay increase!


100% of current pay = ????
0 *200% = in the money!
The following user(s) said Thank You: snowgoer540

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 10:57 #174730 by phillc54
Replied by phillc54 on topic New Configuration Error

Good work. I think we'll let you stay on as lead developer! :laugh:

Bugger... :(


Don't be sad, it comes with a 100% pay increase!


100% of current pay = ????
0 *200% = in the money!

My biggest pay increase ever...
The following user(s) said Thank You: rodw

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 10:58 #174732 by snowgoer540
Replied by snowgoer540 on topic New Configuration Error

Good work. I think we'll let you stay on as lead developer! :laugh:

Bugger... :(


Don't be sad, it comes with a 100% pay increase!

Oh goody, now I'll be able to buy..... nothing


Now THAT'S the spirit! :laugh:

(but you will have a sweet, robust software driving your plasma table :))

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 10:59 #174733 by snowgoer540
Replied by snowgoer540 on topic New Configuration Error

Good work. I think we'll let you stay on as lead developer! :laugh:

Bugger... :(


Don't be sad, it comes with a 100% pay increase!


100% of current pay = ????
0 *200% = in the money!


Checks in the mail! :P

Please Log in or Create an account to join the conversation.

More
19 Jul 2020 19:51 - 19 Jul 2020 19:52 #175191 by snowgoer540
Replied by snowgoer540 on topic New Configuration Error
Not sure if it matters, but the following line slipped through the cracks under the spindle section:
setp   pid.s.error-previous-target true

While I bring that up, should we comment out the maxerror lines in the .hal as well for stepper systems (I think this was just a stepper thing)? There could be a check box in the configurator for stepper vs servo system.

If it was a stepper system, we'd comment out the following lines (the only 4 with "maxerror" in them):
setp   pid.x.maxerror .0005
setp   pid.y.maxerror .0005
setp   pid.y2.maxerror .0005
setp   pid.z.maxerror .0005
Last edit: 19 Jul 2020 19:52 by snowgoer540.

Please Log in or Create an account to join the conversation.

Moderators: phillc54
Time to create page: 0.094 seconds
Powered by Kunena Forum