QtPlasmaC update problem

More
25 Oct 2021 02:44 #224167 by CFE
Replied by CFE on topic QtPlasmaC update problem
Hi Phil,

Yes, I changed the sources in Synaptic. Linux upgraded to Buster with problems, lost the gnome desktop and had to manually install that. It's working now, but when I start LinuxCNC then I get this message :

Traceback (most recent call last):
File "/usr/bin/qtvcp", line 417, in <module>
APP = QTVCP()
File "/usr/bin/qtvcp", line 261, in __init__
window.handler_instance.initialized__()
File "/usr/share/qtvcp/screens/qtplasmac/qtplasmac_handler.py", line 288, in initialized__
self.init_preferences()
File "/usr/share/qtvcp/screens/qtplasmac/qtplasmac_handler.py", line 665, in init_preferences
self.soft_keyboard()
File "/usr/share/qtvcp/screens/qtplasmac/qtplasmac_handler.py", line 2093, in soft_keyboard
self.vkb_check()
File "/usr/share/qtvcp/screens/qtplasmac/qtplasmac_handler.py", line 3385, in vkb_check
head = _translate('VIRTUAL KB ERROR')
TypeError: translate(str, str, disambiguation: str = None, n: int = -1): not enough arguments

Any idea what's going here ? Seems a python problem ?

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 02:48 #224169 by phillc54
Replied by phillc54 on topic QtPlasmaC update problem
No, it is a Phill problem. I am out at the moment and will fix when I get back.
If you uncheck the virtual keyboard it may work for you until fixed.

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 02:50 #224170 by CFE
Replied by CFE on topic QtPlasmaC update problem
Hi Phil,

LinuxCNC doesn't show any graphical interface at all when I start it up, it just gives this error. So I can't uncheck the virtual keyboard.

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 03:25 #224173 by phillc54
Replied by phillc54 on topic QtPlasmaC update problem
Maybe try opening Synaptic and installing onboard keyboard.

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 03:35 #224175 by CFE
Replied by CFE on topic QtPlasmaC update problem
Hi Phil,

That worked, at least QtPlasmaC is running. It shows it is at v1.0.78, the update list says it should be at v1.215.107 ? Wait till the buildbot catches up ?

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 03:39 #224177 by phillc54
Replied by phillc54 on topic QtPlasmaC update problem
1.0.78 is back in September, it should be up to 1.215.107

Try sudo apt update then sudo apt dist-upgrade.

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 03:44 #224180 by CFE
Replied by CFE on topic QtPlasmaC update problem
Hi Phil,

I will give a go. I am a bit apprehensive, somehow when I used the sudo upgrade command before to upgrade to buster I ran into a ton of problems, no graphical display manager, autologin not able to restore, you name. Drives me nuts this linux sometimes.

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 03:50 #224182 by phillc54
Replied by phillc54 on topic QtPlasmaC update problem
It is a big upgrade from Stretch to Buster, you shouldn't have issues now that Buster is running.

If you are concerned, you can just do sudo apt update which just updates the package list so it only finds out what needs updating, then you can apt list --upgradable which will show you what will be upgraded if you go ahead.

I have just pushed the fix for the error message.

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 03:53 #224183 by CFE
Replied by CFE on topic QtPlasmaC update problem
Thanks Phil,

I have just run update and dist-upgrade, but it still shows v1.0.78. I have shutdown the computer and restarted after the upgrade, same result ?

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 03:58 #224186 by phillc54
Replied by phillc54 on topic QtPlasmaC update problem
Weird... can you run sudo apt update > ~/apt-sources.txt and post the apt-sources.txt file in your home directory here, you will get a warning but it will be OK.

Please Log in or Create an account to join the conversation.

Moderators: phillc54
Time to create page: 0.079 seconds
Powered by Kunena Forum