QtPlasmac setup

More
02 Jan 2024 17:29 #289580 by David Herrera
I am setting up a new machine using 7i96s, and the problem i am having is the torch will not fire when running gcode. torch does fire with torch pules button. ant help would be appreciated

Thank you

Please Log in or Create an account to join the conversation.

More
02 Jan 2024 17:36 #289581 by snowgoer540
Replied by snowgoer540 on topic QtPlasmac setup
Could you post your gcode?

It may also help if you preemptively posted a backup of your config made from the settings tab.
The following user(s) said Thank You: David Herrera

Please Log in or Create an account to join the conversation.

More
02 Jan 2024 17:51 - 02 Jan 2024 17:51 #289583 by David Herrera
Replied by David Herrera on topic QtPlasmac setup
Thanks for the quick reply
I'm new to this and  I don't know how to get the "config" under settings tab.
The gcode that I'm using is the Wench example that come with linuxcnc.
Last edit: 02 Jan 2024 17:51 by David Herrera.

Please Log in or Create an account to join the conversation.

More
02 Jan 2024 18:10 - 02 Jan 2024 19:03 #289586 by David Herrera
Replied by David Herrera on topic QtPlasmac setup
sorry cant find the config file
 Generated by PNCconf at Tue Jan  2 16:39:10 2024
# Using LinuxCNC version:  Master (2.9)
# If you make changes to this file, they will be
# overwritten when you run PNCconf again

loadrt [KINS]KINEMATICS
loadrt [EMCMOT]EMCMOT servo_period_nsec=[EMCMOT]SERVO_PERIOD num_joints=[KINS]JOINTS num_spindles=[TRAJ]SPINDLES
loadrt hostmot2
loadrt hm2_eth board_ip="192.168.1.121" config="num_encoders=1 num_pwmgens=1 num_stepgens=5 sserial_port_0=00000000"
setp    [HMOT](CARD0).pwmgen.pwm_frequency 20000
setp    [HMOT](CARD0).pwmgen.pdm_frequency 6000000
setp    [HMOT](CARD0).watchdog.timeout_ns 5000000
loadrt pid names=pid.x,pid.y,pid.z,pid.s
loadrt plasmac

addf [HMOT](CARD0).read          servo-thread
addf motion-command-handler   servo-thread
addf motion-controller        servo-thread
addf pid.x.do-pid-calcs       servo-thread
addf pid.y.do-pid-calcs       servo-thread
addf pid.z.do-pid-calcs       servo-thread
addf pid.s.do-pid-calcs       servo-thread
addf plasmac                  servo-thread
addf [HMOT](CARD0).write         servo-thread
setp [HMOT](CARD0).dpll.01.timer-us -50
setp [HMOT](CARD0).stepgen.timer-number 1

# ---PLASMA INPUT DEBOUNCE---
#values for these are in custom.hal
loadrt dbounce names=db_breakaway,db_float,db_ohmic,db_arc-ok
addf db_float     servo-thread
addf db_ohmic     servo-thread
addf db_breakaway servo-thread
addf db_arc-ok    servo-thread

# ---JOINT ASSOCIATED WITH THE Z AXIS---
net plasmac:axis-position joint.2.pos-fb => plasmac.axis-z-position

# ---PLASMA INPUTS---
# ---all modes---
net plasmac:float-switch     => db_float.in
net plasmac:breakaway        => db_breakaway.in
net plasmac:ohmic-probe      => db_ohmic.in
net plasmac:ohmic-sense-in   => plasmac.ohmic-sense-in
# ---modes 0 & 1
net plasmac:arc-voltage-in   => plasmac.arc-voltage-in
# ---modes 1 & 2
net plasmac:arc-ok-in        => db_arc-ok.in
# ---mode 2
net plasmac:move-up          <= plasmac.move-up
net plasmac:move-down        <= plasmac.move-down

# ---PLASMA OUTPUTS---
# ---all modes---
net plasmac:ohmic-enable     <= plasmac.ohmic-enable
net plasmac:scribe-arm       <= plasmac.scribe-arm
net plasmac:scribe-on        <= plasmac.scribe-on

# ---OHMIC SENSE LINK---
net plasmac:ohmic-probe <= plasmac.ohmic-sense-out

# external output signals

# --- PLASMAC:TORCH-ON ---
net plasmac:torch-on  =>     [HMOT](CARD0).ssr.00.out-00

# --- PLASMAC:OHMIC-ENABLE ---
net plasmac:ohmic-enable  =>     [HMOT](CARD0).ssr.00.out-01


# external input signals

# --- BOTH-X ---
net both-x     <=  [HMOT](CARD0).inm.00.input-00

# --- BOTH-Y ---
net both-y     <=  [HMOT](CARD0).inm.00.input-01

# --- BOTH-Z ---
net both-z     <=  [HMOT](CARD0).inm.00.input-02

# --- HOME-X ---
net home-x     <=  [HMOT](CARD0).inm.00.input-03

# --- HOME-Y ---
net home-y     <=  [HMOT](CARD0).inm.00.input-04

# --- HOME-Z ---
net home-z     <=  [HMOT](CARD0).inm.00.input-05

# --- PLASMAC:ARC-OK-IN ---
net plasmac:arc-ok-in     <=  [HMOT](CARD0).inm.00.input-06

# --- PLASMAC:OHMIC-SENSE-IN ---
net plasmac:ohmic-sense-in     <=  [HMOT](CARD0).inm.00.input-07

# --- PLASMAC:MOVE-UP ---
net plasmac:move-up     <=  [HMOT](CARD0).inm.00.input-08

# --- PLASMAC:MOVE-DOWN ---
net plasmac:move-down     <=  [HMOT](CARD0).inm.00.input-09

# --- ESTOP-EXT ---
net estop-ext     <=  [HMOT](CARD0).inm.00.input-10-not


#*******************
#  AXIS X JOINT 0
#*******************

setp   pid.x.Pgain     [JOINT_0]P
setp   pid.x.Igain     [JOINT_0]I
setp   pid.x.Dgain     [JOINT_0]D
setp   pid.x.bias      [JOINT_0]BIAS
setp   pid.x.FF0       [JOINT_0]FF0
setp   pid.x.FF1       [JOINT_0]FF1
setp   pid.x.FF2       [JOINT_0]FF2
setp   pid.x.deadband  [JOINT_0]DEADBAND
setp   pid.x.maxoutput [JOINT_0]MAX_OUTPUT
setp   pid.x.error-previous-target true
# This setting is to limit bogus stepgen
# velocity corrections caused by position
# feedback sample time jitter.
setp   pid.x.maxerror 0.000500

net x-index-enable  =>  pid.x.index-enable
net x-enable        =>  pid.x.enable
net x-pos-cmd       =>  pid.x.command
net x-pos-fb        =>  pid.x.feedback
net x-output        <=  pid.x.output

# Step Gen signals/setup

setp   [HMOT](CARD0).stepgen.00.dirsetup        [JOINT_0]DIRSETUP
setp   [HMOT](CARD0).stepgen.00.dirhold         [JOINT_0]DIRHOLD
setp   [HMOT](CARD0).stepgen.00.steplen         [JOINT_0]STEPLEN
setp   [HMOT](CARD0).stepgen.00.stepspace       [JOINT_0]STEPSPACE
setp   [HMOT](CARD0).stepgen.00.position-scale  [JOINT_0]STEP_SCALE
setp   [HMOT](CARD0).stepgen.00.step_type        0
setp   [HMOT](CARD0).stepgen.00.control-type     1
setp   [HMOT](CARD0).stepgen.00.maxaccel         [JOINT_0]STEPGEN_MAXACCEL
setp   [HMOT](CARD0).stepgen.00.maxvel           [JOINT_0]STEPGEN_MAXVEL

# ---closedloop stepper signals---

net x-pos-cmd    <= joint.0.motor-pos-cmd
net x-vel-cmd    <= joint.0.vel-cmd
net x-output     => [HMOT](CARD0).stepgen.00.velocity-cmd
net x-pos-fb     <= [HMOT](CARD0).stepgen.00.position-fb
net x-pos-fb     => joint.0.motor-pos-fb
net x-enable     <= joint.0.amp-enable-out
net x-enable     => [HMOT](CARD0).stepgen.00.enable

# ---setup home / limit switch signals---

net home-x     =>  joint.0.home-sw-in
net both-x     =>  joint.0.neg-lim-sw-in
net both-x     =>  joint.0.pos-lim-sw-in

#*******************
#  AXIS Y JOINT 1
#*******************

setp   pid.y.Pgain     [JOINT_1]P
setp   pid.y.Igain     [JOINT_1]I
setp   pid.y.Dgain     [JOINT_1]D
setp   pid.y.bias      [JOINT_1]BIAS
setp   pid.y.FF0       [JOINT_1]FF0
setp   pid.y.FF1       [JOINT_1]FF1
setp   pid.y.FF2       [JOINT_1]FF2
setp   pid.y.deadband  [JOINT_1]DEADBAND
setp   pid.y.maxoutput [JOINT_1]MAX_OUTPUT
setp   pid.y.error-previous-target true
# This setting is to limit bogus stepgen
# velocity corrections caused by position
# feedback sample time jitter.
setp   pid.y.maxerror 0.000500

net y-index-enable  =>  pid.y.index-enable
net y-enable        =>  pid.y.enable
net y-pos-cmd       =>  pid.y.command
net y-pos-fb        =>  pid.y.feedback
net y-output        <=  pid.y.output

# Step Gen signals/setup

setp   [HMOT](CARD0).stepgen.01.dirsetup        [JOINT_1]DIRSETUP
setp   [HMOT](CARD0).stepgen.01.dirhold         [JOINT_1]DIRHOLD
setp   [HMOT](CARD0).stepgen.01.steplen         [JOINT_1]STEPLEN
setp   [HMOT](CARD0).stepgen.01.stepspace       [JOINT_1]STEPSPACE
setp   [HMOT](CARD0).stepgen.01.position-scale  [JOINT_1]STEP_SCALE
setp   [HMOT](CARD0).stepgen.01.step_type        0
setp   [HMOT](CARD0).stepgen.01.control-type     1
setp   [HMOT](CARD0).stepgen.01.maxaccel         [JOINT_1]STEPGEN_MAXACCEL
setp   [HMOT](CARD0).stepgen.01.maxvel           [JOINT_1]STEPGEN_MAXVEL

# ---closedloop stepper signals---

net y-pos-cmd    <= joint.1.motor-pos-cmd
net y-vel-cmd    <= joint.1.vel-cmd
net y-output     => [HMOT](CARD0).stepgen.01.velocity-cmd
net y-pos-fb     <= [HMOT](CARD0).stepgen.01.position-fb
net y-pos-fb     => joint.1.motor-pos-fb
net y-enable     <= joint.1.amp-enable-out
net y-enable     => [HMOT](CARD0).stepgen.01.enable

# ---setup home / limit switch signals---

net home-y     =>  joint.1.home-sw-in
net both-y     =>  joint.1.neg-lim-sw-in
net both-y     =>  joint.1.pos-lim-sw-in

#*******************
#  AXIS Z JOINT 2
#*******************

setp   pid.z.Pgain     [JOINT_2]P
setp   pid.z.Igain     [JOINT_2]I
setp   pid.z.Dgain     [JOINT_2]D
setp   pid.z.bias      [JOINT_2]BIAS
setp   pid.z.FF0       [JOINT_2]FF0
setp   pid.z.FF1       [JOINT_2]FF1
setp   pid.z.FF2       [JOINT_2]FF2
setp   pid.z.deadband  [JOINT_2]DEADBAND
setp   pid.z.maxoutput [JOINT_2]MAX_OUTPUT
setp   pid.z.error-previous-target true
# This setting is to limit bogus stepgen
# velocity corrections caused by position
# feedback sample time jitter.
setp   pid.z.maxerror 0.000500

net z-index-enable  =>  pid.z.index-enable
net z-enable        =>  pid.z.enable
net z-pos-cmd       =>  pid.z.command
net z-pos-fb        =>  pid.z.feedback
net z-output        <=  pid.z.output

# Step Gen signals/setup

setp   [HMOT](CARD0).stepgen.02.dirsetup        [JOINT_2]DIRSETUP
setp   [HMOT](CARD0).stepgen.02.dirhold         [JOINT_2]DIRHOLD
setp   [HMOT](CARD0).stepgen.02.steplen         [JOINT_2]STEPLEN
setp   [HMOT](CARD0).stepgen.02.stepspace       [JOINT_2]STEPSPACE
setp   [HMOT](CARD0).stepgen.02.position-scale  [JOINT_2]STEP_SCALE
setp   [HMOT](CARD0).stepgen.02.step_type        0
setp   [HMOT](CARD0).stepgen.02.control-type     1
setp   [HMOT](CARD0).stepgen.02.maxaccel         [JOINT_2]STEPGEN_MAXACCEL
setp   [HMOT](CARD0).stepgen.02.maxvel           [JOINT_2]STEPGEN_MAXVEL

# ---closedloop stepper signals---

net z-pos-cmd    <= joint.2.motor-pos-cmd
net z-vel-cmd    <= joint.2.vel-cmd
net z-output     => [HMOT](CARD0).stepgen.02.velocity-cmd
net z-pos-fb     <= [HMOT](CARD0).stepgen.02.position-fb
net z-pos-fb     => joint.2.motor-pos-fb
net z-enable     <= joint.2.amp-enable-out
net z-enable     => [HMOT](CARD0).stepgen.02.enable

# ---setup home / limit switch signals---

net home-z     =>  joint.2.home-sw-in
net both-z     =>  joint.2.neg-lim-sw-in
net both-z     =>  joint.2.pos-lim-sw-in

#  ---motion control signals---

net in-position               <=  motion.in-position
net machine-is-enabled        <=  motion.motion-enabled

#  ---digital in / out signals---

#  ---estop signals---

net estop-out     <=  iocontrol.0.user-enable-out
net estop-ext     =>  iocontrol.0.emc-enable-in


# ---QTPLASMAC TOOLCHANGE PASSTHROUGH---
net tool:change iocontrol.0.tool-change  => iocontrol.0.tool-changed
net tool:prep   iocontrol.0.tool-prepare => iocontrol.0.tool-prepared
 
Last edit: 02 Jan 2024 19:03 by David Herrera.

Please Log in or Create an account to join the conversation.

More
02 Jan 2024 19:46 - 02 Jan 2024 20:05 #289592 by David Herrera
Replied by David Herrera on topic QtPlasmac setup
.
Last edit: 02 Jan 2024 20:05 by David Herrera. Reason: sent twice

Please Log in or Create an account to join the conversation.

More
02 Jan 2024 20:24 #289595 by chuben
Replied by chuben on topic QtPlasmac setup
Do you have it activated in the control panel?

Please Log in or Create an account to join the conversation.

More
03 Jan 2024 00:55 - 03 Jan 2024 00:59 #289629 by David Herrera
Replied by David Herrera on topic QtPlasmac setup
yes I have the torch on enabled, and when i select the torch pulse button it works.
The problem is when i run a cycle the torch wont come on, arc ok signal and thc signal not recognized.
Last edit: 03 Jan 2024 00:59 by David Herrera.

Please Log in or Create an account to join the conversation.

More
03 Jan 2024 01:00 #289630 by phillc54
Replied by phillc54 on topic QtPlasmac setup

I'm new to this and  I don't know how to get the "config" under settings tab.

 

Via the BACKUP CONFIG button:
linuxcnc.org/docs/2.9/html/plasma/qtplas...#plasma:settings-tab
 

Please Log in or Create an account to join the conversation.

More
03 Jan 2024 01:44 #289631 by tommylight
Replied by tommylight on topic QtPlasmac setup

Could you post your gcode?

+1
Should have posted your as requested above, why do you make us repeat requests several times when trying to help you?
Probably the gcode you are running does not have M3 Sxxxx $0 in it, so the torch will not fire.

Please Log in or Create an account to join the conversation.

More
04 Jan 2024 17:42 - 04 Jan 2024 17:58 #289793 by David Herrera
Replied by David Herrera on topic QtPlasmac setup
I am new to this, sorry to bother you with my questions.This is what I'm working on, Have since realized the issue and will resolve.

Thank You for your help

 David Herrera

 
Attachments:
Last edit: 04 Jan 2024 17:58 by David Herrera. Reason: picture left out

Please Log in or Create an account to join the conversation.

Moderators: snowgoer540
Time to create page: 0.221 seconds
Powered by Kunena Forum