(SOLVED!!!) Probe Basic - rotary axis jogging

More
31 Oct 2021 15:22 - 31 Oct 2021 15:23 #224773 by TurBoss
hello

you can just delete that line
github.com/kcjengr/probe_basic/blob/master/setup.py#L24


if you have qtpyvcp in a directory called develop (doesn't matter)
probe_basic python3
and qtpyvcp.conversational python3

and run
cd ~/develop/qtpyvcp/
python3 -m pip install -e .
qcompile .
cd ../probe_basic
git checkout python3
python3 -m pip install -e .
qcompile .
Last edit: 31 Oct 2021 15:23 by TurBoss.
The following user(s) said Thank You: spumco

Please Log in or Create an account to join the conversation.

More
31 Oct 2021 15:54 #224777 by spumco
It's already installed and appears to be working ok, I shouldn't need to reinstall everything, do I?

If not, and the change you suggested is just for installation, you might suggest to Spi in his thread "Definitive guide to installation" that he can update his instructions accordingly.

Please Log in or Create an account to join the conversation.

More
31 Oct 2021 16:02 #224778 by TurBoss
oh you right

i miss-understood your post
The following user(s) said Thank You: spumco

Please Log in or Create an account to join the conversation.

More
01 Nov 2021 03:54 - 01 Nov 2021 04:20 #224830 by spumco

qtpyvcp master branch now has support or a new machine action:
machine.jog.set-angular-speed-percentage

If you use an action slide with this action it will perform in the same manner as the linear version. In the case of Probe Basic you can add a hidden slide with this action and using signals from the existing slider have the hidden one slaved off the existing linear. This means moving that single slider will drive the % of jog against the MAX_ANGULAR_VELOCITY and MAX_LINEAR_VELOCITY as set in the config INI file.

For angular axis you should be setting DEFAULT_ANGUALR_VELOCITY and MAX_ANGULAR_VELOCITY in the config ini.

Cheers - James.
 

Had a go at this a minute ago and got an error.

LCNC reported that qtpyvcp.machine.jog.set-angular-speed-percentage-enable exceeded maximum number of characters (47)

Still a little fuzzy on the architechture - will the new machine action be an exported hal pin I can link in my hal file, or is it slaved to the existing linear slider inside probe_basic.ui inside QT Designer?


-Ralph


EDIT - I used "HAL slider" instead of "VCP slider", so that's sorted out now.

Next hurdle... I've got a new slider on the screen as I wasn't sure how to hide it and it isn't slaved to the linear jog percentage slider.  Not a problem at the moment.

Under the slider settingName field I entered machine.jog.set-angular-speed-percentage.

The issue is that it doesn't appear to be doing anything.  I can slide it back and forth, but it doesn't change my angular axis speed using the screen jog buttons.  Same response as before I did the git pull - feedrate display jumps to '100' and doesn't change regardless of the slider position.

I have both angular velocity settings my INI file as mentioned above.

Any idea what I've done wrong?
Last edit: 01 Nov 2021 04:20 by spumco.

Please Log in or Create an account to join the conversation.

More
01 Nov 2021 06:30 #224843 by Joco
The slider to be used is:  ActionSlider
There should be a field in propert editor under the ActionSlider section called:  actionName. Place your "machine.jog.set-angular-speed-percentage" text there.
Also remember to set the objectName to something meaningful.

Create a signal with:
Sender:  select object name of master action slider
Signal: ValueChanged(int)
Receiver: objeect name of slave action slider
Slot:  SetValue(int)

While I have no 4th axis I can see the machine angular speed and linear speeds being changed at the software level.
To hide it gets a little more fiddly.  That might need to be done using some python code in the main UI python module. Unless I can figure out a stylesheet setting that will hide it.


 

Please Log in or Create an account to join the conversation.

More
03 Nov 2021 02:36 #225065 by spumco
James,

Finally got around to trying this again - no dice.

I created an action slider and slaved it to the existing jog slider.  That worked just fine, and the linear axis jog speed still changes appropriately.  But the angular speed does not change, and I got an error during startup stating:

type object 'jog' has no attribute 'set_angular_speed_percentage'

Does this mean when I did the git pull that the updated (new) machine function isn't present?

Please Log in or Create an account to join the conversation.

More
03 Nov 2021 03:28 - 03 Nov 2021 03:29 #225070 by Joco
that looks to me like you have not got the latest version down yet.    So in the qtpyvcp directory:
git pull

To check you have the right version is in the file:  qtpyvcp/actions/machine_actions.py
look at lines 905 to 916, there will be function and setting references to things like 'machine.jog.angular-speed-percentage' and similar.

Cheers - James.
Last edit: 03 Nov 2021 03:29 by Joco.

Please Log in or Create an account to join the conversation.

More
03 Nov 2021 11:35 #225092 by spumco
I don't think that was it.  I just checked and I've got this in machine_actions.py:

@setting('machine.jog.angular-speed-percentage',
         default_value=int(DEFAULT_JOG_ANGULAR_SPEED * 100 / MAX_JOG_ANGULAR_SPEED),
         min_value=0,
         max_value=100,
         persistent=False)
def jog_angular_speed_percentage(obj):
    return obj.value


Maybe my INI file needs a DEFAULT_JOG_ANGULAR_SPEED and MAX_JOG_ANGULAR_SPEED statement in it?

Please Log in or Create an account to join the conversation.

More
03 Nov 2021 17:24 #225121 by Joco

Maybe my INI file needs a DEFAULT_JOG_ANGULAR_SPEED and MAX_JOG_ANGULAR_SPEED statement in it?


For some reason I thought you had done that. Yes you need those defaults.

Please Log in or Create an account to join the conversation.

More
04 Nov 2021 01:18 #225182 by spumco
Still no dice.

I tried putting the INI statements in both the [TRAJ] section and [DISPLAY] where some other velocity settings are.

Same outcome - same qtpyvcp error (type object 'jog' has no attribute 'set_angular_speed_percentage'), and the on-screen A-axis jog button jogs at '100' no matter where the slider(s) are.

And PB is using the max angular velocity in my INI file (100), but it (still) appears to be interpreting/commanding in degrees per minute - not per second.

Unless I'm reading the LCNC docs wrong, all velocity statements in the INI file are in machine units per second, right?

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.086 seconds
Powered by Kunena Forum