Probe_Basic Install

More
06 Mar 2022 06:14 #236486 by jkkicks
Replied by jkkicks on topic Probe_Basic Install
Okay yes i found it and copied it into my test config. its called "probe_basic_postgui.hal" ill call it in the [HAL] of ini. Should I add another line like "HALFILE = probe_basic_postgui.hal" or edit "POSTGUI_HALFILE"?

When setting up there was no time.hal in my install so i grabbed it from github.

currently looks like:
{
HALFILE = custom.hal
SHUTDOWN = shutdown.hal
HALUI = halui
HALFILE = test5.hal
POSTGUI_HALFILE = time.hal
}

Please Log in or Create an account to join the conversation.

More
06 Mar 2022 06:16 #236487 by Lcvette
Replied by Lcvette on topic Probe_Basic Install
Replace time.hal with the other, the time. Hal is now integrated into the probe basic post gui file

Please Log in or Create an account to join the conversation.

More
06 Mar 2022 06:24 #236489 by jkkicks
Replied by jkkicks on topic Probe_Basic Install
Okay did that and it spit out an error. Too large to put in one post so ive attached it below

 

File Attachment:

File Name: Debug-error.txt
File Size:6 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
06 Mar 2022 17:45 #236521 by Lcvette
Replied by Lcvette on topic Probe_Basic Install
In the postgui hall file comment out the scale to rpm lines. Those are for when you stop a spindle feedback to display actual rpm

Please Log in or Create an account to join the conversation.

More
07 Mar 2022 00:21 #236547 by jkkicks
Replied by jkkicks on topic Probe_Basic Install
That seemed to be the ticket, thank you!

Now just working on some underlying latency issues with my intel nuc, hopefully getting isolcpus going and editing the bios a bit.

Please Log in or Create an account to join the conversation.

More
07 Mar 2022 00:31 #236549 by Lcvette
Replied by Lcvette on topic Probe_Basic Install
Good luck, hope you can resolve it, but my experience with micro pc's is they don't work well. Even if you resolve the rt latency, the non rt signals are very laggy. Had another user fight an issue for over a year replacing endless machine components before figuring out it was the micro pc he was using. If you want to resolve with a proven pc, grab a hp elite 8300 usdt core i5 with 8gb of ram for debian11. Debian 10 seems fine with 4gb.

Please Log in or Create an account to join the conversation.

More
07 Mar 2022 00:51 #236552 by tommylight
Replied by tommylight on topic Probe_Basic Install

grab a hp elite 8300 usdt core i5 with 8gb of ram for debian11. Debian 10 seems fine with 4gb.

I had 4 as advised by PCW, they do work nicely even with Linux Mint 19.3 and 4GB, they are in use daily for over a year, no issues. Mine are/were 4 core i5 in USFF with separate power bricks, one also had a discrete graphic card by AMD.

Please Log in or Create an account to join the conversation.

More
07 Mar 2022 01:04 #236554 by jkkicks
Replied by jkkicks on topic Probe_Basic Install
Dually noted, i’ll keep that in mind. I’m not having many issues after isolating the cpu. Just ran a 45 min gcode test with no errors at all. only stopped since everything is setup on the office desk and the steppers got a bit too hot for my liking. On my way now to buy an infrared thermometer to check on them. Still need to get ball screws for my mill and the rest for the electrical cabinet. Just wanted to get it all mostly working on the desk before spending a bunch more money

Please Log in or Create an account to join the conversation.

More
12 Nov 2022 19:48 - 12 Nov 2022 19:54 #256526 by anton610
Replied by anton610 on topic Probe_Basic Install
Hello,

i'm trying to install probe basic.
Is the link in the quick installation guide dead?
I cannot download the installation script.

repository.qtpyvcp.com/repo/pb-py2/bin/P...r-py2+3.g231c7ff.run

can i use the insallation script on github instead?
Thanks!
BR Anton
 
Last edit: 12 Nov 2022 19:54 by anton610.

Please Log in or Create an account to join the conversation.

More
12 Nov 2022 23:02 #256548 by anton610
Replied by anton610 on topic Probe_Basic Install
Done,
works with the script on github.

Thx

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.128 seconds
Powered by Kunena Forum