Elumatec SBZ 130/01 retrofit

More
14 Jan 2017 19:10 #85774 by tommylight
Another thing i remebered today, i read somewhere on this forum a while ago about mesa 7ixx outputs not working and having to wire logic ground to vfield ground
this is caused when using non earthed computer cable, so the computer ground is not at the same level as the machine ground.
The best solution for this is to wire the computer power inside the machine cabinet and use an earthed cable for power to computer. All desktops have 0V wired to ground.
Failing to have this can cause the servo drives to fly at full speed as soon as enabled.
It has been mentioned here several times about how important having proper grounding is.

Please Log in or Create an account to join the conversation.

More
14 Jan 2017 19:26 #85777 by PCW
Replied by PCW on topic Elumatec SBZ 130/01 retrofit
There is in general no reason to wire field ground to logic ground and in many cases
its better to keep them isolated as it decouples the 24V switching noise from logic ground

You just have to use the field common as the return path for Field I/O outputs

The analog and encoder I/O on the 7I77 however share a common ground with PC ground
(for PCI and PCIE cards) so this needs to be kept in mind.

Please Log in or Create an account to join the conversation.

More
14 Jan 2017 19:33 - 14 Jan 2017 19:36 #85778 by tommylight
Yup, got that from experience today, just had to use a grounded power cable for the PC. Without it the spindle would run as soon as i enable it.
Thank you Peter.
B.Th.W i did not wire the logic ground to field ground, that can cause some trouble if anything goes wrong on the machine or PC.
Last edit: 14 Jan 2017 19:36 by tommylight.

Please Log in or Create an account to join the conversation.

More
14 Jan 2017 20:26 #85780 by bevins
Replied by bevins on topic Elumatec SBZ 130/01 retrofit
What are you guys calling logic ground? 5V-GND?

Because the manual shows Field I/O Logic Power uses the same ground as VIN, (VIN,VField,Common). And this should not be the same ground as the computer ground, or it would not be isolated or floating.
Or is this just talking about the logic only for the field I/O, and board logic is from the 5V?

Confusion has set in......

Please Log in or Create an account to join the conversation.

More
14 Jan 2017 20:56 #85782 by tommylight
7i77 has analogue out gnd wired to computer ground or logic ground, that is separate from Vin and Vfield ground.
Case in point, PC needs to have grounding for analogue out ground to be at the same potencial.
In my case i have removed all the wires from the existing control box, so they are floating as they got the ground from that control box. Now using new computer and controls they have to be at the same ground.

Please Log in or Create an account to join the conversation.

More
14 Jan 2017 21:05 #85784 by bevins
Replied by bevins on topic Elumatec SBZ 130/01 retrofit

tommylight wrote: 7i77 has analogue out gnd wired to computer ground or logic ground, that is separate from Vin and Vfield ground.
Case in point, PC needs to have grounding for analogue out ground to be at the same potencial.
In my case i have removed all the wires from the existing control box, so they are floating as they got the ground from that control box. Now using new computer and controls they have to be at the same ground.


Gotcha....

Please Log in or Create an account to join the conversation.

More
15 Jan 2017 18:46 #85835 by tommylight

PCW wrote: freeby.mesanet.com/77ssiss.zip

Has the 5i25/6i25 bitfile and the new pinout file source code
P3 --> 7I77
P2 --> 7I74 (channels 0..3= SSI 4..7= Sserial)

Not tested, better to test with a 6i25 than 5I25 since a 6I25 can be boostrapped without
JTAG if a non-workin bitfile is loaded


Tested today, but it can not find analogout 's !!! Also checked the show pin and show param, no analog outs there.
Must something with addresses. Another thing i noticed after flashing this file, "reload" does not function any more. Flashed back the 5i25_7i74_7i77 bit file that comes with 5i25 configs, and reload works, analog works, all is good.
Hmmmmm i wonder.............. did a lot of research before reloading the working firmware, so i changed the 5V power supplies several times, just to be sure, wasn't it.
Back to the drawing board, PCW can i test this on another 7i92_7i77 combo, as far as i know it should work as 5i25 configs work always after changing the pci to eth and card name (well, number).

Please Log in or Create an account to join the conversation.

More
15 Jan 2017 18:54 - 15 Jan 2017 19:03 #85836 by PCW
Replied by PCW on topic Elumatec SBZ 130/01 retrofit
NO! NEVER load a bitfile thats is not specifically for the FPGA card or you will brick the card
I will check the bitfile tomorrow

( hal files are compatible across cards with minor changes but FPGA bit files are card specific )

Also noticed you said you used 7I74_7I77 bit file
If that the case you would have a 7I74 on P3 and a 7I77 on P2,
the config I supplied has the 7I77 on P3 and 7I74 on P2 so it is not going to work without swapping connectors
Last edit: 15 Jan 2017 19:03 by PCW.

Please Log in or Create an account to join the conversation.

More
15 Jan 2017 19:00 #85838 by tommylight
Oh cr@p, sorry for the mess up.
And i may add, damn you are quick !!! :)
Thank you very much Peter.
Assumptions are the mother of all f.........!!!!
Going in the corner to feel ashamed for a while......

Please Log in or Create an account to join the conversation.

More
15 Jan 2017 19:05 #85839 by PCW
Replied by PCW on topic Elumatec SBZ 130/01 retrofit
Note my edit on previous post, you may have to swap connectors to get things to work
in any case its worthwhile to do a
mesaflash --device 5i25 --readhmid to verify the pinout

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.192 seconds
Powered by Kunena Forum