Lathe Macros

More
28 Dec 2017 15:32 #103796 by JackBerkhout
Replied by JackBerkhout on topic Lathe Macros
Hi Andy,
that looks nice. I'm not sure how it works.
Also, I noticed do not have the 'Cycles' tab with all the tabs below that.
Do I need to download and install software for that?

Please Log in or Create an account to join the conversation.

More
04 Jan 2018 15:49 #104023 by andypugh
Replied by andypugh on topic Lathe Macros
You need to create the "Cycles" tab with an edit to the INI file.
The following user(s) said Thank You: JackBerkhout

Please Log in or Create an account to join the conversation.

More
22 Jan 2018 05:04 #104829 by AppleAssassin
Replied by AppleAssassin on topic Lathe Macros
Anyone else having the problem where it won't run and says "unable to open file <turning>" for example. It's the same for any operation like "unable to open file <boring>" etc.

Please Log in or Create an account to join the conversation.

More
22 Jan 2018 07:55 #104833 by andypugh
Replied by andypugh on topic Lathe Macros
Where have you put the files in question? You might need to add that location to the SUBROUTINE_PATH

Please Log in or Create an account to join the conversation.

More
22 Jan 2018 14:31 #104843 by AppleAssassin
Replied by AppleAssassin on topic Lathe Macros
I put them in the configs folder for my profile then changed the INI file with the EMBED_TAB_NAME and EMBED_TAB_COMMAND lines. Now when I click the little play button on the Cycles interface nothing happens but the text on the window border changes to (no file)

Please Log in or Create an account to join the conversation.

More
22 Jan 2018 15:15 #104848 by andypugh
Replied by andypugh on topic Lathe Macros
You probably need to add :./ to the SUBROUTINE_PATH.
(ie, the folder containing the INI)

The lathemacro.ini has
SUBROUTINE_PATH = ../../../nc_files/gladevcp_lib:./

Please Log in or Create an account to join the conversation.

More
16 Feb 2018 08:54 #106006 by Coockie
Replied by Coockie on topic Lathe Macros
Hello! Im installed Linux cnc on my old computer, all ok, next step i will install your macros, im install it, but background picture does not displayed... what i doing wrong?

Please Log in or Create an account to join the conversation.

More
25 Feb 2018 20:48 #106515 by andypugh
Replied by andypugh on topic Lathe Macros
It may be that your installation does not have the required SVG file viewer.

If you start LinuxCNC from the command line it is possible that you might get a message saying what the problem is.

Please Log in or Create an account to join the conversation.

More
26 Feb 2018 19:00 #106547 by Coockie
Replied by Coockie on topic Lathe Macros
Okay, greet thank you! Im try repair it) Sory for my bad english :)

Please Log in or Create an account to join the conversation.

More
06 Apr 2018 11:17 #108488 by tecno
Replied by tecno on topic Lathe Macros
Can somebody please point out where I can find the axis-lathe.ngc with all necessary sub routines for Lathe Macro?

Please Log in or Create an account to join the conversation.

Time to create page: 0.128 seconds
Powered by Kunena Forum