CamView for Wheesy and Jessie

More
07 Dec 2018 12:09 #122001 by Nitram
Hallo Norbert.

Ich war in Australien geboren aber meine Eltern haben Deutsch zu Hause gesprochen :)
Vielen dank fuer Ihre hilfe.

I do not see a "camview" button in the camera tab of Gmoccapy. I currently have the ini file tab location set to "ntb_preview". Maybe I need a bigger view??
Sometimes when I expand Gmoccapy to full screen, I see the "ghosting" of some buttons beneath, but nothing really to act upon, hence I don't know of the "camview" button.

I was also using the camera tab today and while some people are talking of a slow frame rate, I see something slightly different... I see intermittent capture rate, so in other words, for about 4 seconds the refresh rate is OK, then for 2 seconds I see the frame freeze, then for the next 4 seconds it refreshes OK again etc. I feel this is different behavior from simply a slow frame rate but rather something coming to a limit, then clearing a buffer, then back to a limit again, in a 4/2/4/2/4/2 second cycle. If you were not watching closely it could be confused for a slow frame rate, but I think it is something different.

I wonder if you have any thoughts on both of the above issues?

Nochmal vielen dank!
Chuess,
Marty.

Please Log in or Create an account to join the conversation.

More
10 Dec 2018 04:34 - 10 Dec 2018 12:40 #122128 by Nitram
I have noticed another interesting behavior.
After Gmoccapy is opened but before the machine is out of E-Stop, the camera under the camera tab runs seamlessly. Good refresh rate, no lagging.
As soon as the machine is taken out of E-Stop, when I go back to the camera tab, the picture is slow and laggy. I hope this information helps. Of note (possibly?), I am also running Any Pugh's Lathe macros (which I believe is also via gvp and py??), could there be a conflict?

Norbert, I have also tried your modification as below, and it works, but the behavior as specified above is still there with in and out of E-Stop lag/refresh.

If you have installed all dependencies as mentioned in previous post, you just will need to add to your INI File:
EMBED_TAB_NAME = Camera
EMBED_TAB_LOCATION = ntb_user_tabs
EMBED_TAB_COMMAND = gladevcp -x {XID} -c emb_cam -H emb_cam.hal -u emb_cam.py emb_cam.glade

and copy the following files to your config dir:
emb_cam.hal
emb_cam.py
emb_cam.glade



BUT, given the above, I wonder if that is slowing my system down overall, so, I wonder if someone could tell me how to disable the cam portion please? Is there a way of commenting out a line or some other action etc. which will prevent this from loading and potentially slowing down the machine but still allowing me to un-comment the line etc and try other options or cameras with linuxcnc?

Thanks,
Marty.
Last edit: 10 Dec 2018 12:40 by Nitram.

Please Log in or Create an account to join the conversation.

More
13 Dec 2018 03:18 #122346 by bogie6040
Marty,

The default comment character in the .ini file is # (hash character).
Place one at the beginning of a line and it will treat that entire line as a comment.
As to your video lag issue, it sounds like maybe a latency issue (ie: the RT kernel is busy keeping up with servicing LCNC's house keeping requests and then finally getting around to the less important non real time threads)
see: http://wiki.linuxcnc.org/cgi-bin/wiki.pl?Latency-Test

Bogie

Please Log in or Create an account to join the conversation.

More
08 May 2019 22:08 #133202 by paulctan

Is there any advantage to doing this vs just embedding mplayer as below? At least I don't have to install OpenCV and mplayer is already in the distro.

Just wondering what I could gain (or not) by switching over.

EMBED_TAB_NAME = Camera
EMBED_TAB_LOCATION = ntb_preview
EMBED_TAB_COMMAND = mplayer -wid {XID} tv:// -vf rectangle=-1:2:-1:240,rectangle=2:-1:320:-1

Please Log in or Create an account to join the conversation.

Moderators: mhaberler
Time to create page: 0.122 seconds
Powered by Kunena Forum