Error after Update

More
29 Apr 2020 22:41 #166153 by snowgoer540
Updated, went to cut a job, get the following error wrt pmx485:

Attachments:

Please Log in or Create an account to join the conversation.

More
29 Apr 2020 22:42 - 29 Apr 2020 22:44 #166154 by phillc54
Replied by phillc54 on topic Error after Update
If you updated LinuxCNC before late yesterday (my time) that would be the problem.

Try updating LinixCNC again now.

sourceforge.net/p/emc/mailman/emc-develo...ail.com/#msg36996185
Last edit: 29 Apr 2020 22:44 by phillc54.

Please Log in or Create an account to join the conversation.

More
29 Apr 2020 22:50 #166156 by snowgoer540
Replied by snowgoer540 on topic Error after Update

If you updated LinuxCNC before late yesterday (my time) that would be the problem.

Try updating LinixCNC again now.

sourceforge.net/p/emc/mailman/emc-develo...ail.com/#msg36996185


hmmm. I literally just did it before I made the post (still standing at the machine)...

Also, before updating I was getting a weird "can't do that (EMC_TRAJ_SET_TELEOP_ENABLE) in auto mode with the interpreter paused" multiple times when running a 48.5 inch cut i made from the straight line conversational...

Please Log in or Create an account to join the conversation.

More
29 Apr 2020 22:51 #166157 by snowgoer540
Replied by snowgoer540 on topic Error after Update
gitpull says "already up to date" :(

I disabled the pmx comms to get this job done, that will work for now. Still concerned about the weird error

Please Log in or Create an account to join the conversation.

More
29 Apr 2020 22:52 #166158 by phillc54
Replied by phillc54 on topic Error after Update
did you run make?

Please Log in or Create an account to join the conversation.

More
29 Apr 2020 22:54 #166159 by snowgoer540
Replied by snowgoer540 on topic Error after Update

did you run make?


yep, in the src directory, followed by sudo make setuid, and then closed terminal opened rip'd enviro and checked configurator for good measure

Please Log in or Create an account to join the conversation.

More
29 Apr 2020 23:01 #166160 by phillc54
Replied by phillc54 on topic Error after Update
Sorry, I cocked up again.

I just pushed the fix.

Please Log in or Create an account to join the conversation.

More
29 Apr 2020 23:06 #166162 by snowgoer540
Replied by snowgoer540 on topic Error after Update

Sorry, I cocked up again.

I just pushed the fix.


Thanks Phill!

Also, any thoughts on the "you cant do that" error?

Please Log in or Create an account to join the conversation.

More
29 Apr 2020 23:13 #166164 by phillc54
Replied by phillc54 on topic Error after Update

Thanks Phill!

We aim to please...:)

Actually you were fortunate in your timing, I had just finished checking my emails and was about to head out for a few hours when your post turned up.


Also, any thoughts on the "you cant do that" error?

Not off the top of my head, that is something from LinuxCNC itself. I will have a look when I get back. Could you post a screenshot of the settings you were using.

Please Log in or Create an account to join the conversation.

More
29 Apr 2020 23:19 - 29 Apr 2020 23:20 #166165 by snowgoer540
Replied by snowgoer540 on topic Error after Update

Thanks Phill!

We aim to please...:)

Actually you were fortunate in your timing, I had just finished checking my emails and was about to head out for a few hours when your post turned up.


Also, any thoughts on the "you cant do that" error?

Not off the top of my head, that is something from LinuxCNC itself. I will have a look when I get back. Could you post a screenshot of the settings you were using.


Yea, will do. Dinner's ready, so after that!

I'm running into a few more errors:

1. The conversational is still cutting at 60% of the previous job's hole speed. I know someone else said that too. But I cut a 4 hole pattern of holes that were .4" diameter. Then I went to cut a 47" circle, after clearing everything, and it's still 60% of velocity (as can be seen in teh screen shot).

2. Despite choosing center and giving a start of X0 Y0, my circle is definitely shifted Positively about 2 inches in Y. The circle is not being cut around the center. Added Gcode here too.
Attachments:
Last edit: 29 Apr 2020 23:20 by snowgoer540.

Please Log in or Create an account to join the conversation.

Moderators: snowgoer540
Time to create page: 0.354 seconds
Powered by Kunena Forum