Prototrak Plus Retrofit with Mesa 7i77 & 5i25 cards

13 Mar 2017 20:18 #89546 by lakeweb
Hi Andy,
I'm going by that C3 is the high power cap and on his diagram I believe he is showing the back traces as dashed lines. In that case, the + of C3 goes to the red circle. And yea, there must be another to come from the rect-bridge, but not obvious. C1, and C2 are very small so probably the 40 volts he is measuring? And those were used for signal supplies, milliamps, not amps as R1 and R2 drop the high power in. Those would be unapplicable now.

Very hard to figure for sure without having hands on it.

That is why the light bulb and a 'DC' volt meter, you are looking for high voltage, high power. BTW, are you 120 or 240 volts for your typical plug? I'd guess it means your light bulb is 240 not 120 as I was assuming.
Best, Dan.
The following user(s) said Thank You: new2linux
13 Mar 2017 21:17 - 15 Mar 2017 17:49 #89551 by new2linux
Dan & andypugh thank you for your advise! Typical 120v plug. The dashed lines I had thought that it may be reading continuity back thru capacitor. I have tried to tease out the dotted line means or does, if on the ohm meter, is on R x 100 scale, testing continuity, if the meter is applied to the + of c3 to terminal and where "the dashed lines end or note 1" (to the left) the meter will fill and drop very small amount "hold steady"; if the meter were between the "left side" of c3 to terminal to the + of c3 to terminal, the meter will fill but will start to drift lower and lower, and the same when meter is between the "left side" of c3 to terminal and where the "the dashed lines end or note 1", again the meter will fill but drift down. I hope that helps. I will update diagram pic, please see the bottom (for notes) to leads for transformer and rectifier.

Many thanks!

Edit: Currently there is a separet transformer (provided by BigJohnT) for the 5v and the 24v connected to the TB1 (ground as marked) & TB2 (pin 1 and pin 8) on 7i77 card. The current configuration for TB5 "x" axes on terminals 3 & 4; "y" axes on terminals 7 & 8.

Edit 01: Attached a better pic of diagram, in addition each terminal has a number specific to it, with that said the test with voltmeter between the following terminals for power go like this:
40v=L2 & L3 or r2 & r3;
40v=L1 & L3 or r1 & r3;
75v=L1 & L2 or r1 & r2;
If testing resistance on R x 100 scale between the following terminals go like this:
The needle starts high but will fall it tested between C3+ & B2,L2,T2 & r2
The needle starts high but will fall it tested between C3b+ & B1,L1,T1 & r1
C3a does not seem to connect to anything.
By and large when testing resistance on the other terminals the reading is steady, some go 80% scale others go 55% scale, but firm, don't seem to drop very quickly. I will gladly test and retest and post results on the rest of PCB if that will help.
Many, many thanks for all the great help. If I am over my head (because you don't know what you don't know, so it's hard to know when to call it a day) I will still need to know the correct questions for the real electrician.

many thanks!!

Edit02: This link is most helpful, "analog drive configuration &setup notes"

Many thanks!!
Last edit: 15 Mar 2017 17:49 by new2linux. Reason: additional info; updated diagram:02 to add link
16 Mar 2017 17:33 - 23 Mar 2017 12:26 #89758 by new2linux
Many, many thanks to all that have help with this project!
And special thanks to the following: andypugh, Todd Zuercher, lakeweb, PCW, tommylight, and bevins for there invaluable assistance!!

As for the power supply, upon study of old and how the new AMC amps work my thinking is to try the (P2 location on amp) pins: 3, 4 & 5. My thinking (I know, some of you think, this may not turn out good) is to follow the diagram and testing I have shown in prior post.
40v=L2 & L3 or r2 & r3;
40v=L1 & L3 or r1 & r3;
75v=L1 & L2 or r1 & r2;
So if you reference the r1&r2;L1&L2 to the diagram you will see the why. The big foot print of copper on near and far sides of PCB just seem to be uniform in appearance, to be placed on pin 3 or 4 and pin 5 goes to r3&L3. Both r3&L3 (if you follow diagram) go to #1 on transformer, and neither have any reference to note 1 or 2 on diagram. There is a reference to the DIP switches a way to set max current, test mode and tuning procedure, but the 4.1.6 is 1st.

I have been reading & pondering, it appears the 1st requirement to preform Current Limiting Procedure. If this is not the way to approach please say so:
My servos are rated at 1/3 horsepower at 75vDC (max output of transformer,as tested) so:
1/3hp x 746 watts=248.66
248.66/75=3.32 amps (if you do the math using 80vdc=3.11 Amps.)

The following is from this link page 46 (pdf 53/73)

4.1.6 Current Limiting Procedure (there is 2nd part if required)
Before operating a drive, the current output of the drive must be limited based on motor and
system current limitations. Depending on the drive model, ADVANCED Motion Controls’ analog
servo drives feature a number of different current limiting methods. However, the procedure
for setting the current limit will essentially be the same for each drive. Consult the drive
datasheet to see what current limiting options are available on a specific drive.
The current limiting steps should be taken with no power applied to the drive.
1. The following two options may be used separately or in conjunction with each other to
reduce the current limits. Keep in mind that any current reductions enacted by the use of
an external resistor will come secondary to DIP switch settings.
— If available, position any current scaling or current limit ratio DIP switches to the
desired position (see “Potentiometer Function Details” on page 43).
— If available, use an external resistor connected to the Continuous Current Limiting Pin
based on the values given on the drive datasheet (see “Continuous Current Limit Pin”
on page 41).

I will be working this and moving thru setup. Using this link as well for setup.

Many thanks for all the help!!

Edit: To clarify for next person, the DC voltage out of PCB (bridge retrifier) as per prior diagram, goes like this:
38vdc=L3 or r3 to ground
0vdc=L2 or r2 to ground
75vdc=L1 or r1 to ground
So at the amplifier (each is very specific, as to the setup) make shore to have on hand the most current manual, to your application and follow closely to it. I have several steps to go.
Last edit: 23 Mar 2017 12:26 by new2linux. Reason: spelling, clairify
01 Apr 2017 17:43 - 02 Apr 2017 13:31 #90721 by new2linux
I would like to send a huge thank you to all that make this forum possible!
After some exhaustive testing and diagnostic work, the 3 used, (AMC) amp from ebay, 1 of the 3 had green light working (the vendor made it right) and now have 2 working amps, that will in the "test mode", stay still (no servo motion), with the manual in hand, using potentiometer to reverse direction with changing speed, servos.
I am having "hal pin 51 (analogout 0-scalemax) " issues. Attached are the files as described, the showpinparmmore file has error file from start up from the ""terminal window" linuxcnc", in addition to pin and pram, from the halrun commands.
The AMC amps are all anybody could want! It took a while to understand some of the small bits in the manual, but look good, set just over 3 amps (as per prior post).
The place it seems to hang up in the "halrun" is after the "loadr" stuff and try the "loudusr halmeter", just will not show any motion in the DRO screen, or the top pick (just have looked too long for now) can't remember the "top pick" in the hal meter windows.

Many, many thanks for any help!! Hope I have explained my short comings well enough. I have goofed around in the .hal file. I have what has changed written down if I need to go back. OK with a fresh (delete old ini and hal) as to start new, pncconf wizard if quicker.


Edit: Currently (TB5) Drv0 position 3 = position 5 (+REF IN) on amplifier and Drv0 position 4 = position 4 (- REF IN) on amplifier.
Last edit: 02 Apr 2017 13:31 by new2linux. Reason: additional info
04 Apr 2017 13:51 #90868 by new2linux
tommylight, many thanks for all your help! I have read this and tried some very small edits, but I don''t see the change later in the hal file you describe. Below is a section of an earlier post, advise you offered I did not make out so good, could you offer any suggestions? I do not think I used the "replace" anywhere.

""Even after this you will have to edit a bit, but very little. And use the "replace" in gedit or mousepad or whatever text editor you are using.
Do not use replace for replacing 1 with 0 or similar short things, never.
Select a long part that is the same in all the lines you want to replace and just replace with the same thing plus changes.""

If there is a section (or somebody) of hal file that I should study, please point me in best direction.
Many, many thanks!
04 Apr 2017 18:24 #90873 by tommylight
You mean editing the hal file right?
That was for replacing 5i25 config with 7i92 stuff if i am not misstaken.
All the text editors have a "find and replace" feature.
The following user(s) said Thank You: new2linux
04 Apr 2017 18:43 #90877 by new2linux
thanks tommylight!

So really its a edit feather only, and then really more for complex/lengthy editing.

many thanks
04 Apr 2017 21:47 #90888 by new2linux
tommylight, I had to go back and read the post again myself. What do you think?


tommylight wrote: Well, you will have to fix more of those errors there, plenty more to go.
You have to use the replace function for doing such editing, and you have to keep track of what is changing and to what and how that change effects the other parts.
You can learn that in half hour, and it will save you a lot of time later.
Back on topic.
You still have to fix things like
You have scalemax and scalemin to analogout0 and analogout 1 as output for the same axis. That will not work. Same thing with limits and encoders.
It is much easier to do a new config, and place the connectors on the 7i77 in the coresponding places.
I do not understand why you change and edit hal to switch places, just unplug the connectors on the 7i77 and plug them as they should normaly be.
Even after this you will have to edit a bit, but very litle. And use the "replace" in gedit or mousepad or whatever text editor you are using.
Do not use replace for replacing 1 with 0 or similar short things, never.
Select a long part that is the same in all the lines you want to replace and just replace with the same thing plus changes.


truly, many thanks, for all the help!!
04 Apr 2017 22:39 #90891 by tommylight
That was general advice on editing hal and ini files, your hal and ini were very messy. Did you do a new config? You should start fresh and have things connected in order so you can follow easier what in hal or ini is related to things on the machine and Mesa boards.
The editing part is for examlple:
You have in hal
But you need to have
So you select everything from start to the last thing that is to be changed, in this case up to the last 0 on the first line. Under it you make the changes so when you hit replace it will replace only the last 0 to 1 in any line containing that phrase.
Where are you at now? Do a new config and try to get thing as close as possible in the pncconfig, then you might need a bit of editing but nothing major.
The following user(s) said Thank You: new2linux
05 Apr 2017 00:03 - 05 Apr 2017 14:41 #90895 by new2linux
thank you tommylight!

I am working the fresh PNCconf, attached are the error files along with the hal and ini files. I starting with (TB5) Drv0 position 3 = position 5 (+REF IN) on amplifier and Drv0 position 4 = position 4 (- REF IN) on amplifier for each axes.

I will try the "replace" method in the morning. If I see anything.

Many thanks!

Edit: I see changes in the .hal file when using "replace" as you suggested, many thanks!
Last edit: 05 Apr 2017 14:41 by new2linux. Reason: thanks
Moderators: piasdom
Time to create page: 0.118 seconds
Powered by Kunena Forum